BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 08-24-2006, 02:42 PM   #1 (permalink)
New Member
 
Join Date: Mar 2006
Model: 8320
Carrier: AT&T
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Trouble installing Service Pack 2

Please Login to Remove!

Hey guys,

Im trying to get to the point where we can use bluetooth with our devices, I beleive its a SP3 minimum.

Im trying to install "Service Pack 2 Hotfix #3" and get the following error:

"" Windows Installer

The upgrade patch cannot be installed by the windows installer service because the program to be upgraded may be missing, or the upgrade patch may update a different version of the program. Verify that the program to be upgraded exists on your computer and that you have the correct upgrade patch. "

Does anyone know what I can do to get this upgrade to work?

Thanks in advance.
Offline  
Old 08-24-2006, 02:53 PM   #2 (permalink)
Knows Where the Search Button Is
 
Join Date: Aug 2006
Location: Scotland
Model: 8700g
Carrier: T-Mobile UK
Posts: 44
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Problem
When you attempt to install BlackBerry Enterprise Server 4.0 Service Pack 2 Hotfix 1 or Hotfix 2, the installation fails and you receive the following error:

The upgrade patch cannot be installed by the Windows Installer service because the program to be upgraded may be missing, or the upgrade patch may update a different version of the program. Verify the program to be upgraded exists on your computer and that you have the correct upgrade patch.


Cause
The software bundle installed on your computer is lower than the bundle required for the upgrade. The hotfixes will work as follows:

For Hotfix 1

You must have BlackBerry Enterprise Server 4.0 Service Pack 2 Bundle 11.

For Hotfix 2

You must have BlackBerry Enterprise Server 4.0 Service Pack 2 Bundle 11, or Service Pack 2 Hotfix 1 Bundle 13.

Resolution
Verify the bundle currently installed on the BlackBerry Server.

In Microsoft Windowsxxx174; Control Panel, double-click Add/Remove Programs.
From the list of currently installed programs, select BlackBerry Enterprise Server and click support information to open the Support Info window.
Ensure the version number matches one of the supported software bundles above.
Note: The version number in the Support Info window is formatted as follows: e.g., BlackBerry Enterprise Server 4.0 Service Pack 2 Bundle 11 is formatted as version 4.0.2 (Bundle 11).

Close the Support Info window and the Control Panel.
Download the latest version of BlackBerry Enterprise Server 4.0 Service Pack 2 and install it. See the BlackBerry Enterprise Server for Microsoft Exchange: Installation Guide for instructions.
Install BlackBerry Enterprise Server 4.0 Service Pack 2 Hotfix 1 or Hotfix 2.

I would install Sp2 on it's own first then the hotfix's have to be installed incrementally. 1 then 2 then 3.

Last edited by Lamo : 08-24-2006 at 02:59 PM.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.