BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 03-08-2005, 09:19 AM   #1 (permalink)
CrackBerry Addict
 
rpfeffer's Avatar
 
Join Date: Mar 2005
Location: MD
Model: 9650
OS: 5.0.0.699
Carrier: Sprint BES
Posts: 530
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Upgrading from BES 3.6 to 4.0...

Please Login to Remove!

Seeing as cingular has finally released the 4.0 software for the 7290, I now can proceed with upgrading our BES, the handhelds, and the desktop software.

For those of you that have performed this upgrade already, is there anything important I should look out for? Is there a preferred order of upgrade? Should the server be first or should the devices be first? I know the blackberry website says to install the 4.0 desktop software before installing the handheld software, but does it matter when the server is upgraded?

Thanks in advance!

-Rob
Offline  
Old 03-08-2005, 09:44 AM   #2 (permalink)
Thumbs Must Hurt
 
Join Date: Aug 2004
Location: West Palm Beach, FL
Model: 8100
Carrier: T-Mobile
Posts: 122
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

It has been ahwile since i have completed the upgrade, however i do know that you can upgrade the server and desktop software before upgrading the devices. the only reall problem i ran into was migrating the 3.6 databse which i believe was SQL version 7 to the SQL 2000 database of 4.0. Depending on how many users you have it may be easier to just build the server from scratch rather than upgrade.

What i did was purchase a new copy of BES so i had a different SRP i built up that machine and moved all of my users over and then changed the SRP key back to the original (users will have to re-sync using a wired connection). i then returned the license before the 30 days was up... worked out great.
Offline  
Old 03-08-2005, 09:57 AM   #3 (permalink)
CrackBerry Addict
 
rpfeffer's Avatar
 
Join Date: Mar 2005
Location: MD
Model: 9650
OS: 5.0.0.699
Carrier: Sprint BES
Posts: 530
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Our database is already at SQL 2000, so I don't think we'll run into that problem. We also only have 32 users, which is relatively small. Hopefully that is not a problem.
__________________
9650 Bold - Sprint
BES 4.1 SP7
Offline  
Old 03-08-2005, 10:51 AM   #4 (permalink)
CrackBerry Addict
 
rpfeffer's Avatar
 
Join Date: Mar 2005
Location: MD
Model: 9650
OS: 5.0.0.699
Carrier: Sprint BES
Posts: 530
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Is there a preferred order of upgrade? I know the handheld software requires the desktop software be upgraded first, but can I upgrade the handheld devices before I do the server itself? Server is currently at version 3.6. Handhelds are at version 3.8. Do I have to do the server before I do anything or does it not matter?
__________________
9650 Bold - Sprint
BES 4.1 SP7
Offline  
Old 03-08-2005, 11:29 AM   #5 (permalink)
CrackBerry Addict
 
rpfeffer's Avatar
 
Join Date: Mar 2005
Location: MD
Model: 9650
OS: 5.0.0.699
Carrier: Sprint BES
Posts: 530
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Also, are there any deployment methods to deploy the 4.0 desktop and handheld software to users w/o having to go to each individually and perform the upgrade?
__________________
9650 Bold - Sprint
BES 4.1 SP7
Offline  
Old 03-08-2005, 12:25 PM   #6 (permalink)
BBF Veteran User
 
Join Date: Aug 2004
Location: Hotwiring another Cessna
Model: OU812
Carrier: Nintendo
Posts: 3,492
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Unfortunately not really. I suppose if you used some kind of network software distribution package like ON/SUS or something you could actually push the desktop manager out with the correct handheld code on it. But you would have to write some kind of makeshift manual for the users and what to click.
Offline  
Old 03-08-2005, 04:31 PM   #7 (permalink)
Talking BlackBerry Encyclopedia
 
greywolfe's Avatar
 
Join Date: Mar 2005
Location: NSW, Australia
Model: 8100
Carrier: optus
Posts: 303
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

With BES 4 and Handheld 4, Handset manager does actually allow you to push software configurations out to handsets. However both have to be ON version 4 for this to work, so its kind of redunant telling you this As for distributing desktop manager, unless you can work out a blind install process for it, I dont think its possible.
__________________
BES Admin, sometime God.
Offline  
Old 03-08-2005, 04:51 PM   #8 (permalink)
CrackBerry Addict
 
rpfeffer's Avatar
 
Join Date: Mar 2005
Location: MD
Model: 9650
OS: 5.0.0.699
Carrier: Sprint BES
Posts: 530
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

well, regardless...

7/35 clients are now on 4.0 handheld/desktop manager. We're going to make sure its working ok, then proceed with the server upgrade to 4.0. After the server upgrade, we'll start getting to the rest of our clients, rather then installing 4.0 for them now and going back again after the server upgrade to configure the wireless contacts/memo/and task synchronizations.
Offline  
Old 03-14-2005, 03:53 PM   #9 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2005
Location: Athens, GA
Model: 7750
Posts: 15
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I upgraded our BES to 4.0 last month and the 3.6 desktop manager works fine with it. I'm trying to move everyone over to the 4.0 desktop manager, but it takes a little time. I haven't really looked into it that much, but as long as you have a .msi file you can push it down using Microsoft's Active Directory when the users log into their PCs.
Offline  
Old 03-15-2005, 10:15 AM   #10 (permalink)
CrackBerry Addict
 
rpfeffer's Avatar
 
Join Date: Mar 2005
Location: MD
Model: 9650
OS: 5.0.0.699
Carrier: Sprint BES
Posts: 530
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well the day is near...any last minute advice?
Offline  
Old 03-15-2005, 10:37 PM   #11 (permalink)
Talking BlackBerry Encyclopedia
 
greywolfe's Avatar
 
Join Date: Mar 2005
Location: NSW, Australia
Model: 8100
Carrier: optus
Posts: 303
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

What database are you using btw?
__________________
BES Admin, sometime God.
Offline  
Old 03-16-2005, 08:52 AM   #12 (permalink)
CrackBerry Addict
 
rpfeffer's Avatar
 
Join Date: Mar 2005
Location: MD
Model: 9650
OS: 5.0.0.699
Carrier: Sprint BES
Posts: 530
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by greywolfe
What database are you using btw?
SQL 2000
Offline  
Old 03-17-2005, 10:07 PM   #13 (permalink)
Talking BlackBerry Encyclopedia
 
greywolfe's Avatar
 
Join Date: Mar 2005
Location: NSW, Australia
Model: 8100
Carrier: optus
Posts: 303
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

db upgrade wont be a prob then. If it for some reason fails to update the db on the install, just copy the contents of the createdb.exe folder off the cd to your sql server and run it from there.
__________________
BES Admin, sometime God.
Offline  
Old 03-18-2005, 11:09 AM   #14 (permalink)
CrackBerry Addict
 
rpfeffer's Avatar
 
Join Date: Mar 2005
Location: MD
Model: 9650
OS: 5.0.0.699
Carrier: Sprint BES
Posts: 530
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by greywolfe
db upgrade wont be a prob then. If it for some reason fails to update the db on the install, just copy the contents of the createdb.exe folder off the cd to your sql server and run it from there.
off the 3.6 cd? we don't have a CD for 4.0, I just downloaded that software.
Offline  
Old 03-18-2005, 11:15 AM   #15 (permalink)
BlackBerry God
 
jibi's Avatar
 
Join Date: Oct 2004
Location: Jibi's Secret Place
Model: 8900
OS: 4.6.1.174
Carrier: AT&T
Posts: 11,310
Post Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by rpfeffer
off the 3.6 cd? we don't have a CD for 4.0, I just downloaded that software.
look in the Database folder in the files you downloaded.
__________________
In the beginning the Universe was created. This has made a lot of people very angry and is widely regarded as a bad move.
Offline  
Old 03-18-2005, 02:20 PM   #16 (permalink)
CrackBerry Addict
 
rpfeffer's Avatar
 
Join Date: Mar 2005
Location: MD
Model: 9650
OS: 5.0.0.699
Carrier: Sprint BES
Posts: 530
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by jibi
look in the Database folder in the files you downloaded.
it's failing at this point, but why would you use the createdb.exe if the database already exists? We used this in the beginning to create it. It just needs to update it now.
Offline  
Old 03-20-2005, 04:08 PM   #17 (permalink)
Talking BlackBerry Encyclopedia
 
greywolfe's Avatar
 
Join Date: Mar 2005
Location: NSW, Australia
Model: 8100
Carrier: optus
Posts: 303
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

If youre upgrading I wouldnt think it would have a problem...and createdb can be run with the update flag I believe.
__________________
BES Admin, sometime God.
Offline  
Old 03-21-2005, 02:34 PM   #18 (permalink)
CrackBerry Addict
 
rpfeffer's Avatar
 
Join Date: Mar 2005
Location: MD
Model: 9650
OS: 5.0.0.699
Carrier: Sprint BES
Posts: 530
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well , we upgraded and it seems to be working...for the most part. However, we're getting alot of warnings in the event log of the server looking like this.

"Drop DELETE command because the response from device is SYNC_DATABASE_NOT_ENABLED. (UserLast, UserFirst:18, DS=EXCHANGE, DB=MEMOS)"

where userlast, userfirst is the user name. This happens for tasks, memos, and contacts. However, all wireless sync's are working, just not instantaneously. Has anyone else seen this in their logs?
Offline  
Old 03-21-2005, 02:37 PM   #19 (permalink)
CrackBerry Addict
 
rpfeffer's Avatar
 
Join Date: Mar 2005
Location: MD
Model: 9650
OS: 5.0.0.699
Carrier: Sprint BES
Posts: 530
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

we also saw quite a few "[SYNC-DSession] Recieved empty add for backup's recipient Cache. [UserLast, UserFirst:29]"

These occured when the enterprise activation was first run.
Offline  
Old 03-25-2005, 06:59 PM   #20 (permalink)
New Member
 
Join Date: Mar 2005
Location: Boston
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation Can a 3.6 desktop interact with a 4.0 device?

I had a BB that I docked in to my worstations cradle, and it was 4.0, so it upgraded the bb 7750 to 4.0 also. Now the user this belongs to has Desktop 3.6, and for one reason or another they are unable to upgrade to 4.0 the install dies during the last few moments when the help files are being copied this has made my life hell.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.