BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 12-07-2006, 10:26 AM   #1 (permalink)
New Member
 
Join Date: Dec 2006
Model: 7200
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation Calendar Sync only working in one direction

Please Login to Remove!

Hello,

I need some input on what I can look at to get this issue resolved. Here is what I have going on.

Enviroment: BES 4.0.6.7 - Exchange 2003 SP2 - AD 2003

Problem: Several users when creating appointments on their Blackberry, the appointment does not sync to their Exchange account - However appointments entered into Outlook will be sent to the Blackberry. All other bi-directional sync is working properly (Email, Contacts, etc). All syncronization is wireless.

What I have checked so far:
Bi-directional sync is enabled in BES for the calendar. The CDO.DLL file on our BES server is the same as the one running on our Exchange server (6.5.7638.2). I have even tried giving the BES service account Owner access to a user's calendar and that did not work.

One thing I do see that I'm not 100% sure about it that the BES service account is a member of a group that is denied Full Mailbox Access to the users mailbox. Does the service account need that type of access? I am not sure if this account was made a member of this group when I deployed BES.

Any thoughts on this?

Thanks...
Offline  
Old 12-07-2006, 11:26 AM   #2 (permalink)
Talking BlackBerry Encyclopedia
 
tbdiscovery's Avatar
 
Join Date: Nov 2006
Location: Marcus Hook / Philadelphia , PA
Model: 8703e
Carrier: Sprint
Posts: 323
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I had the same issue. Do their contacts, tasks and memo sync? I tried to reactive on the BES and now I can't get back on.
__________________
"War protects the people from the corruption which an everlasting peace would bring upon it."
-GWF Hegel
Offline  
Old 12-08-2006, 06:51 AM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: Sep 2006
Location: U.k
Model: 7100v
Carrier: vodafone
Posts: 17
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

hi
i had the same problem. it was the permission for the bes account it needed full access to the mailboxes remove the deny access to the mailbox permission.

Last edited by ajaibm : 12-08-2006 at 09:09 AM.
Offline  
Old 12-08-2006, 03:29 PM   #4 (permalink)
Knows Where the Search Button Is
 
punkinwing's Avatar
 
Join Date: May 2005
Location: Bethlehem, PA - USA
Model: 8310
Carrier: AT&T
Posts: 22
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by ajaibm
hi
i had the same problem. it was the permission for the bes account it needed full access to the mailboxes remove the deny access to the mailbox permission.
Actually, just the opposite.. I had this same issue and it was that the service account had TOO MANY privilages.. Read the access requirments for the service account and apply exactly as documented.. It'll work fine!
Offline  
Old 12-08-2006, 07:32 PM   #5 (permalink)
New Member
 
Wino's Avatar
 
Join Date: May 2006
Location: Wine Country
Model: 8700
Carrier: T-Mobile
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Can I get a link please to the article referenced for permissions? I have the same issue with one user with a 8703e and calendar syncing. His email and contacts sync ok. Using Exchange Server 2003 SP2. Have a crackberry server setup and logging in as user BESadmin. thank you
Offline  
Old 12-11-2006, 02:31 AM   #6 (permalink)
New Member
 
Join Date: Dec 2006
Model: 8700C
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

BESAdmin rights as follows

User groups in AD - Domain Users ONLY Builtin Admins is ok if BES install on DC

Right click First Administrative groups in ESM, select delegate control, make BESAdmin Exchange View Only Administrator.

Assign send as, recieve as, and adminster information store at each ex server level in domain in ESM.

Done...except local permissions...which really should be a factor.

With calendaring issues, there's really only 2 factors...CDO.DLL versions..which you've shown are fine...and permissions...Permissions NEED to be correct..otherwise, this is the result.

-Cheers.
Offline  
Old 12-12-2006, 12:32 PM   #7 (permalink)
New Member
 
Join Date: Dec 2006
Model: 7130
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

After all this time and the thousands of BB's sold, has nobody come up with a solution? I see multiple people with the same issue! Who can we write or call to get the fix?
Offline  
Old 12-12-2006, 12:59 PM   #8 (permalink)
BlackBerry Extraordinaire
 
Frank Castle's Avatar
 
Join Date: Jul 2005
Location: MA
Model: 9930
PIN: PM Me!
Carrier: VZW
Posts: 1,073
Post Thanks: 0
Thanked 4 Times in 3 Posts
Default reapply the CDO

wireless calendar relies on CDO .. you have verified it's the same version so I would delete the blackberry one .. copy over the one from exchange and regsvr it.
Offline  
Old 12-12-2006, 01:45 PM   #9 (permalink)
New Member
 
Join Date: Dec 2006
Model: 7200
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for the input guys. Someone suggested that the blackberry service account needs full mail access. This is what I thought might be the problem. I don't have an audit trail, but the service account is a member of a group that denies FMA. I cannot remember if I configured this before, and someone went in after me and added this group membership back. I will try removing to this group and see if this fixes the issue.
Offline  
Old 12-12-2006, 03:15 PM   #10 (permalink)
New Member
 
Join Date: Dec 2006
Model: 7200
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default It worked

Quote:
Originally Posted by brichbou
Thanks for the input guys. Someone suggested that the blackberry service account needs full mail access. This is what I thought might be the problem. I don't have an audit trail, but the service account is a member of a group that denies FMA. I cannot remember if I configured this before, and someone went in after me and added this group membership back. I will try removing to this group and see if this fixes the issue.

Looks like that did the trick! Thanks for all of the input!

Brantley
Offline  
Old 12-13-2006, 11:28 AM   #11 (permalink)
New Member
 
Join Date: Dec 2006
Model: 7130
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up Solution to gain 2way sync from BB to Outlook Calendar

My company's computer & communications guy figured it out. I don't quite understand it but then again I don't need to. As long as it works and he's on it! But hope this helps the rest....

The service account was a member of other groups in active directory (Domain Admins or Enterprise Admins) that were explicitly denied some permissions within exchange (Send As, Receive As)
I created a new service account assigned only the permissions I needed in exchange and SQL then changed all the blackberry services on the BES to use the new account.
I also had to export the registry info from [HKEY_CURRENT_USER\Software\Research In Motion] and log on as the new user and import it.
And run through the Configuration Wizard again for good measure.
Offline  
Old 01-03-2007, 11:34 AM   #12 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Feb 2005
Location: North Carolina
Model: Storm
OS: 5.0.0.419
Carrier: Verizon
Posts: 482
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Just wanted to say thanks guys for refreshing my memory about this issue. We just upgraded our server hardware and some of the exchange server settings didn't transfer over. We ended up with the 1-way calendar sync issue again. Once we checked the correct permissions we got 2-way sync again.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.