BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 04-24-2007, 09:29 AM   #1 (permalink)
New Member
 
Join Date: Apr 2007
Model: 8700
PIN: N/A
Carrier: TIM
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default BES 4.1.3 Exchange 2007 device to outlook calendar sincronization problem

Please Login to Remove!

HI,
i am testing BES 4.1.3 on exchange 2007 environment, all semm to work, the only thing that does not work is the device to outlook calendar sincronization.
IN the BES log i have this error.

[40700] (04/24 16:10:23.276):{0xD1C} {xxx@mydomain.com} Receiving packet from device, size=119, TransactionId=1727319260, Tag=124, content type=CICAL, cmd=0x3
[40000] (04/24 16:10:23.276):{0xD1C} {xxx@mydomain.com}-HandleAppointmentToSynchronize-Entering-Tag=124
[30193] (04/24 16:10:23.286):{0xD1C} {xxx@mydomain.com} Receiving calendar update from device, RefId=51724657, Tag=124, TransactionId=1727319260
[40000] (04/24 16:10:23.316):{0xD1C} Starting new CDO helper 0100bfe8
[40574] (04/24 16:10:24.259):{0xA80} CDO helper 0100bfe8 started
[30001] (04/24 16:10:26.065):{0xA80} CDOCalendar::Initialize - Code = 80040705, WCode = 0505, Code meaning = IDispatch error #1285,
[30002] (04/24 16:10:26.065):{0xA80} Server = exchfull, Mailbox = /o=Exchange07Org/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=mzeni Description = The Microsoft Exchange Server computer is not available. Either there are network problems or the Microsoft Exchange Server computer is down for maintenance. [Microsoft Exchange Server Information Store - [MAPI_E_FAILONEPROVIDER(8004011D)]]
[30180] (04/24 16:10:26.065):{0xA80} {mzeni} CDOCalendar::Initialize - Error in call m_spCalendarFolder = m_spCDOSession->GetDefaultFolder
[40000] (04/24 16:10:26.065):{0xA80} CDO initializing failure in CDO helper 0100bfe8 (1)
[30001] (04/24 16:10:27.288):{0xA80} CDOCalendar::Initialize - Code = 80040705, WCode = 0505, Code meaning = IDispatch error #1285,
[30002] (04/24 16:10:27.288):{0xA80} Server = exchfull, Mailbox = /o=Exchange07Org/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=mzeni Description = The Microsoft Exchange Server computer is not available. Either there are network problems or the Microsoft Exchange Server computer is down for maintenance. [Microsoft Exchange Server Information Store - [MAPI_E_FAILONEPROVIDER(8004011D)]]
[30180] (04/24 16:10:27.288):{0xA80} {mzeni} CDOCalendar::Initialize - Error in call m_spCalendarFolder = m_spCDOSession->GetDefaultFolder
[40000] (04/24 16:10:27.288):{0xA80} CDO initializing failure in CDO helper 0100bfe8 (2)
[30001] (04/24 16:10:28.743):{0xA80} CDOCalendar::Initialize - Code = 80040705, WCode = 0505, Code meaning = IDispatch error #1285,
[30002] (04/24 16:10:28.743):{0xA80} Server = exchfull, Mailbox = /o=Exchange07Org/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=mzeni Description = The Microsoft Exchange Server computer is not available. Either there are network problems or the Microsoft Exchange Server computer is down for maintenance. [Microsoft Exchange Server Information Store - [MAPI_E_FAILONEPROVIDER(8004011D)]]
[30180] (04/24 16:10:28.743):{0xA80} {mzeni} CDOCalendar::Initialize - Error in call m_spCalendarFolder = m_spCDOSession->GetDefaultFolder
[40000] (04/24 16:10:28.743):{0xA80} CDO initializing failure in CDO helper 0100bfe8 (3)
[30001] (04/24 16:10:29.846):{0xA80} CDOCalendar::Initialize - Code = 80040705, WCode = 0505, Code meaning = IDispatch error #1285,
[30002] (04/24 16:10:29.846):{0xA80} Server = exchfull, Mailbox = /o=Exchange07Org/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=mzeni Description = The Microsoft Exchange Server computer is not available. Either there are network problems or the Microsoft Exchange Server computer is down for maintenance. [Microsoft Exchange Server Information Store - [MAPI_E_FAILONEPROVIDER(8004011D)]]
[30180] (04/24 16:10:29.846):{0xA80} {mzeni} CDOCalendar::Initialize - Error in call m_spCalendarFolder = m_spCDOSession->GetDefaultFolder
[40000] (04/24 16:10:29.846):{0xA80} CDO initializing failure in CDO helper 0100bfe8 (4)
[30001] (04/24 16:10:30.959):{0xA80} CDOCalendar::Initialize - Code = 80040705, WCode = 0505, Code meaning = IDispatch error #1285,
[30002] (04/24 16:10:30.959):{0xA80} Server = exchfull, Mailbox = /o=Exchange07Org/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=mzeni Description = The Microsoft Exchange Server computer is not available. Either there are network problems or the Microsoft Exchange Server computer is down for maintenance. [Microsoft Exchange Server Information Store - [MAPI_E_FAILONEPROVIDER(8004011D)]]
[30180] (04/24 16:10:30.959):{0xA80} {mzeni} CDOCalendar::Initialize - Error in call m_spCalendarFolder = m_spCDOSession->GetDefaultFolder
[40000] (04/24 16:10:30.959):{0xA80} CDO initializing failure in CDO helper 0100bfe8 (5)
[40580] (04/24 16:10:31.962):{0xA80} CDO helper 0100bfe8 closing after CDO initialize failure
[40000] (04/24 16:10:32.062):{0xA80} CalHelper failed 0100bfe8, ErrorCode = -11, Thread activity was Checking CDO object list
[40577] (04/24 16:10:32.163):{0xA80} CDO helper 0100bfe8 stopped


I am testing an exchange shared configuration for multiple domain and i have done some address list hiding configuration ...
Some one can help me.
thank you
Offline  
Old 04-24-2007, 12:15 PM   #2 (permalink)
Thumbs Must Hurt
 
Join Date: Apr 2005
Location: Toronto, ON
Model: 8100
Carrier: Rogers
Posts: 108
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Exchange 2007 is not officially supported in SP3. It is suppose to be in SP4.

Have you installed the "Microsoft Exchange Server MAPI Client and Collaboration Data Objects 1.2.1". Search the Microsoft web site for the quoted string.

Also take a look at: BlackBerry
Offline  
Old 04-25-2007, 08:52 AM   #3 (permalink)
Thumbs Must Hurt
 
Dookie's Avatar
 
Join Date: Oct 2005
Location: Prague
Model: 9000
Carrier: T-Mo
Posts: 175
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by aschieman View Post
Exchange 2007 is not officially supported in SP3. It is suppose to be in SP4.

Have you installed the "Microsoft Exchange Server MAPI Client and Collaboration Data Objects 1.2.1". Search the Microsoft web site for the quoted string.

Also take a look at: BlackBerry
But it works with 2007 - there is a complete thread with all settings about that. Try to find that.
Offline  
Old 05-02-2007, 08:47 AM   #4 (permalink)
New Member
 
Join Date: May 2007
Model: None
PIN: N/A
Carrier: Various
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Its all in the global address books

You need to allow BESadmin full access to the global address books which you have users who require access. You may allows have to use th ADSI edit tool for windows to place additional full control on these. Also the BEAdmin user needs to appear in the Global Address list for each domian, you can then set it as hiden from the address book so users do not mail it.
Offline  
Old 05-04-2007, 09:12 AM   #5 (permalink)
New Member
 
Join Date: Apr 2007
Model: 8700
PIN: N/A
Carrier: TIM
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Still i have the problem

Hi thank to all,
i have followed all your suggestion, but i still have the same problem,
i have tested the rights og the besadmin user, and it seems correctly configured; if i use outlook with the besadmin profile i can add appointment to the BB user with no problem.
Any other suggestion.
Thank You
ZIOZIOZIO
Offline  
Old 05-09-2007, 01:13 AM   #6 (permalink)
Knows Where the Search Button Is
 
Join Date: Sep 2006
Location: Melbourne
Model: 8800
Carrier: Telstra
Posts: 46
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

On the server you have selected to load BlackBerry Enterprise Server download and install “Microsoft Exchange Server MAPI Client and Collaboration Data Objects 1.2.1” which is available from the Microsoft Download site (a.k.a ExchangeMapiCdo.EXE). This will install the CDO and MAPI DLLs which are no longer available in Exchange 2007. This replaces the previous requirement to have Exchange System Manager installed as in Exchange 2000 or 2003 environments. The current download link is as follows:
Download details: Microsoft Exchange Server MAPI Client and Collaboration Data Objects 1.2.1
Offline  
Old 05-09-2007, 03:36 AM   #7 (permalink)
New Member
 
Join Date: Apr 2007
Model: 8700
PIN: N/A
Carrier: TIM
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by garycutri View Post
On the server you have selected to load BlackBerry Enterprise Server download and install “Microsoft Exchange Server MAPI Client and Collaboration Data Objects 1.2.1” which is available from the Microsoft Download site (a.k.a ExchangeMapiCdo.EXE). This will install the CDO and MAPI DLLs which are no longer available in Exchange 2007. This replaces the previous requirement to have Exchange System Manager installed as in Exchange 2000 or 2003 environments. The current download link is as follows:
Download details: Microsoft Exchange Server MAPI Client and Collaboration Data Objects 1.2.1
Hi Garicury,
i have already installed the MAPI client and collaboration Data Object 1.2.1.
But i have the problem, all the other BES redirection work well.
Thenk you
Offline  
Old 05-09-2007, 03:36 AM   #8 (permalink)
New Member
 
Join Date: Apr 2007
Model: 8700
PIN: N/A
Carrier: TIM
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by garycutri View Post
On the server you have selected to load BlackBerry Enterprise Server download and install “Microsoft Exchange Server MAPI Client and Collaboration Data Objects 1.2.1” which is available from the Microsoft Download site (a.k.a ExchangeMapiCdo.EXE). This will install the CDO and MAPI DLLs which are no longer available in Exchange 2007. This replaces the previous requirement to have Exchange System Manager installed as in Exchange 2000 or 2003 environments. The current download link is as follows:
Download details: Microsoft Exchange Server MAPI Client and Collaboration Data Objects 1.2.1
Hi Garicury,
i have already installed the MAPI client and collaboration Data Object 1.2.1.
But i have the problem, all the other BES redirection work well.
Thenk you
Offline  
Old 05-09-2007, 04:27 AM   #9 (permalink)
Knows Where the Search Button Is
 
Join Date: Sep 2006
Location: Melbourne
Model: 8800
Carrier: Telstra
Posts: 46
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by zioziozio View Post
Hi Garicury,
i have already installed the MAPI client and collaboration Data Object 1.2.1.
But i have the problem, all the other BES redirection work well.
Thenk you

Do you have the old Exchange System Manager installed on the BES server? Also rerun the "MAPI client and collaboration Data Object 1.2.1" install as the files don't appear to be registered correctly.
Offline  
Old 05-09-2007, 04:52 AM   #10 (permalink)
New Member
 
Join Date: Apr 2007
Model: 8700
PIN: N/A
Carrier: TIM
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by garycutri View Post
Do you have the old Exchange System Manager installed on the BES server? Also rerun the "MAPI client and collaboration Data Object 1.2.1" install as the files don't appear to be registered correctly.
Hi Garycutri,
NO i nvere installed the old exchange system manager, i have directly installed the "MAPI client and collaboration Data Object 1.2.1" on my bes server.
thank you
Offline  
Old 05-09-2007, 07:59 AM   #11 (permalink)
Knows Where the Search Button Is
 
Join Date: Sep 2006
Location: Melbourne
Model: 8800
Carrier: Telstra
Posts: 46
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Can you please follow this guide and confirm all the steps?

http://www.blackberryforums.com/bes-...unctional.html
Offline  
Old 05-09-2007, 08:20 AM   #12 (permalink)
New Member
 
Join Date: Apr 2007
Model: 8700
PIN: N/A
Carrier: TIM
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by garycutri View Post
Can you please follow this guide and confirm all the steps?

http://www.blackberryforums.com/bes-...unctional.html

Hi Garycutri, i have installed the bes server in this way.
The only diffrence is in the exchange setub because I am testing an exchange shared configuration for multiple domain and i have done some address list hiding configuration.

Thanks in advance
Offline  
Old 05-09-2007, 09:59 AM   #13 (permalink)
Knows Where the Search Button Is
 
Join Date: Sep 2006
Location: Melbourne
Model: 8800
Carrier: Telstra
Posts: 46
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by zioziozio View Post
Hi Garycutri, i have installed the bes server in this way.
The only diffrence is in the exchange setub because I am testing an exchange shared configuration for multiple domain and i have done some address list hiding configuration.

Thanks in advance
In the BES configuration app select "edit mapi profile" and see if you can still resolve the BESadmin account.
Offline  
Old 06-08-2007, 12:42 PM   #14 (permalink)
New Member
 
Join Date: Jun 2007
Model: NA
PIN: N/A
Carrier: Verizon
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Same problem

I am having the same problem. One thing I am running into is that I previously had ESM 2003 installed on the same server as BES and it won't let me install CDO 1.2.1 until ESM 2003 is removed. When I try to remove ESM 2003 it fails every time. Any ideas?
Offline  
Old 06-25-2007, 01:59 PM   #15 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2005
Location: LYON
Model: 8310
OS: 4.5.0.81
Carrier: SFR
Posts: 37
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

hy,

You problem is resolved ?

I have the same probleme :

Bes on a DC windows 2003 serveur cdo.dll 6.57888 (CDO 1.2.1)
Exchange 2007 on a Windows 2003 (DC too)

Besadmin is Domain's Admin

And I have exactly the same logs of zioziozio

OK I'HAVE FOUND, the command in getting started guide is wrong !!!!!

Last edited by RaGe : 06-26-2007 at 03:30 PM.
Offline  
Old 06-27-2007, 08:58 AM   #16 (permalink)
New Member
 
Join Date: Apr 2007
Model: 8700
PIN: N/A
Carrier: TIM
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by RaGe View Post
hy,

You problem is resolved ?

I have the same probleme :

Bes on a DC windows 2003 serveur cdo.dll 6.57888 (CDO 1.2.1)
Exchange 2007 on a Windows 2003 (DC too)

Besadmin is Domain's Admin

And I have exactly the same logs of zioziozio

OK I'HAVE FOUND, the command in getting started guide is wrong !!!!!
HI ... what is the correct command ? thank you
zioziozio
Offline  
Old 06-27-2007, 11:28 PM   #17 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by jwhitwo View Post
I am having the same problem. One thing I am running into is that I previously had ESM 2003 installed on the same server as BES and it won't let me install CDO 1.2.1 until ESM 2003 is removed. When I try to remove ESM 2003 it fails every time. Any ideas?
What error do you receive? I've had the same problem previously; sometimes a repair install does it ... sometimes adding / removing 1 component does it.
Offline  
Old 06-27-2007, 11:30 PM   #18 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by zioziozio View Post
HI ... what is the correct command ? thank you
zioziozio
zioziozio - If you'e modified address list permissions you've probably broken the BESAdmins permissions.

I've setup hosted BES with hosted Exchange and every problem I've had has been address list permissions problems.

Have you also restricted access to the container that the BESAdmin account is in within AD?

Are you using HMC or have you just manually gone in and done addresslist / ou manipulation?
Offline  
Old 06-28-2007, 10:38 AM   #19 (permalink)
New Member
 
Join Date: Apr 2007
Model: 8700
PIN: N/A
Carrier: TIM
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by hdawg View Post
zioziozio - If you'e modified address list permissions you've probably broken the BESAdmins permissions.

I've setup hosted BES with hosted Exchange and every problem I've had has been address list permissions problems.

Have you also restricted access to the container that the BESAdmin account is in within AD?

Are you using HMC or have you just manually gone in and done addresslist / ou manipulation?
hi i have manually modified addresslist / ou.
but using the besadmin account via outlook all work correctly, the nes server does not copy calendar from bb to exchange
tahnk you
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright © 2004-2014 BlackBerryForums.com.
The names RIM © and BlackBerry © are registered Trademarks of BlackBerry Inc.