BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 09-21-2007, 06:42 PM   #61 (permalink)
Thumbs Must Hurt
 
mitchelrl's Avatar
 
Join Date: Sep 2007
Model: 8900
PIN: N/A
Carrier: T-Mobile
Posts: 67
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Please Login to Remove!

[PS] C:\Documents and Settings\mlewis.WPI>add-adpermission -identity "BESadmin"
-user BESAdmin -accessrights ExtendedRight -extendedrights Send-As, Receive-As,
ms-Exch-Store-Admin

I added an identity portion in there and got it taken care of.

This is a very helpful thread!
Offline  
Old 09-24-2007, 05:06 PM   #62 (permalink)
New Member
 
Join Date: Sep 2007
Model: 8830
PIN: N/A
Carrier: Verison
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

[quote=garycutri;531888]Install BES 4.1.3 or higher in an Exchange 2007 Environment
By Gary Cutri (BlackBerry Forums - Asia Pacific)
Version 1.0

Note: In an Exchange 2007 environment BlackBerry Enterprise Server cannot be installed on the mail server as the BES software is not 64BIT compatible.

2. Log onto your Exchange Server using an account which has permissions to create an account. Open the Exchange Management Console and create a service account called BESadmin.[quote]

How do you create a service account in Exchange Management Console? Im having trouble with premissions starting my service and just going though the steps and confussed about #2.


-Sean
Offline  
Old 10-07-2007, 05:17 PM   #63 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Mar 2005
Location: Chicago
Model: 9000
Carrier: AT&T
Posts: 435
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

We moved to a native 2007 enviornment last week. All works 100%. I am having an issue with sending BES Alerts from the BES Server itself. Tried to use local IP, fqdn, internal fqdn email, it can't find a valid SMTP Server. RIM support was clueless.

Funny thing is all my other devices/apps (APC, Antivirus, Monitoring, etc) send alerts fine through 2007.

Anyone have had similar issues and find a resolution?
Offline  
Old 10-07-2007, 06:07 PM   #64 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Can you post any errors / logs? I'd recommend starting a new thread for this.
Offline  
Old 10-07-2007, 06:53 PM   #65 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Mar 2005
Location: Chicago
Model: 9000
Carrier: AT&T
Posts: 435
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by hdawg View Post
Can you post any errors / logs? I'd recommend starting a new thread for this.
Fixed

turns out BES isn't sending the fqdn string to the exchange server. It sends <BESAdmin> and not [email address].

On the exchange shell, ran:

Set-ReceiveConnetor "your default receive connector here" -DefaultDomain "your domain name here"

If the exchange 2007 Antispam is not enabled, no further action is needed.

If Exchange 2007 Antispam is enabled, mail will be blocked via Content Filtering.

Added the BES Server IP address under Exchange 2007 AntiSpam IP Allow List.

Mail now getting through

Last edited by jnelson2000 : 10-08-2007 at 12:04 AM.
Offline  
Old 10-22-2007, 08:55 PM   #66 (permalink)
Knows Where the Search Button Is
 
Join Date: Aug 2007
Location: Quebec, CAN
Model: 8100
PIN: 205D45FA
Carrier: Rogers
Posts: 23
Post Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation Everything except caendar works!

Hi!

I installed my BES and follow your instructions.

Everything works: I plugged the two BB's on the user's computers and the activation is successfull...the emails get in and out, the can synchronize their contacts, tasks, notes, etc....BUT THE CALENDAR IS ONLY WORKING ONE WAY OUT OF THE EXCHANGE!!!!WHHHHHYYYYY!!!!

I keep getting this error in the Windows Log of my BES:

Event Type: Warning
Event Source: BlackBerry Messaging Agent SERVEUR Agent 1
Event Category: None
Event ID: 20216
Date: 10/22/2007
Time: 9:50:37 PM
User: N/A
Computer: SERVEUR
Description:
[email address]} Synchronize() failed: ERR_FAIL, Tag=1159

Sorry for my english...but could someone help me! My boss is going to get mad if I can't get his calendar to work!!!

Thank you!
Offline  
Old 10-22-2007, 09:50 PM   #67 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'd really recommend doing a little searching on this ... but it is most likely due to a mismatch of cdo.dll versions between your BES & Exchange. Have you applied all Exchange patches / service packs to your BES that you've done on your Exchange server? Search here and at BlackBerry Technical Solution Center
Offline  
Old 10-23-2007, 05:37 AM   #68 (permalink)
Knows Where the Search Button Is
 
Join Date: Aug 2007
Location: Quebec, CAN
Model: 8100
PIN: 205D45FA
Carrier: Rogers
Posts: 23
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by hdawg View Post
I'd really recommend doing a little searching on this ... but it is most likely due to a mismatch of cdo.dll versions between your BES & Exchange. Have you applied all Exchange patches / service packs to your BES that you've done on your Exchange server? Search here and at BlackBerry Technical Solution Center
I'm trying right now with the updates...will get back with the results!
Offline  
Old 10-23-2007, 07:35 AM   #69 (permalink)
Knows Where the Search Button Is
 
Join Date: Aug 2007
Location: Quebec, CAN
Model: 8100
PIN: 205D45FA
Carrier: Rogers
Posts: 23
Post Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation

Alright...

I updated the BES...the update "Rollback Exchange 4" or something like that wasn't done...so I did it...

I tried deleting the user from the BES, wiping the BB, adding the user to the BES again and cable activated it...

Everything activates fine...mail is going through, notes, contacts, tasks are synching...everything except the f***ing calendar!!!

Could someone help me?

I'm running Exchange 2007, on a Windows 2003 Standard R2 x64 SP2 machine. The BES is installed on a Windows 2003 Standard SP2. Everything is updated...from the Microsoft Updates for Windows and Exchange to the last version of BES 4.1.4.12.

I added the "Send-As" "Receive-As" "ms-Exch-Store-Admin" for Besadmin...

Please!!! Make it work!!! I'm paying the beer!
Offline  
Old 10-31-2007, 08:11 PM   #70 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by garycutri View Post
To run Exchange 2007 it has to be installed on Microsoft 2003 Server 64-Bit. Also BES DOES NOT run on 64-Bit platforms.
Win2k3 64-bit is now supported with BES 4.1 SP4 - BlackBerry Search Results
Offline  
Old 10-31-2007, 09:45 PM   #71 (permalink)
Knows Where the Search Button Is
 
Join Date: Aug 2007
Location: Quebec, CAN
Model: 8100
PIN: 205D45FA
Carrier: Rogers
Posts: 23
Post Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation

Up!

Just to see if anyone has any idea for my problem...
Offline  
Old 11-06-2007, 02:32 AM   #72 (permalink)
Knows Where the Search Button Is
 
Join Date: Sep 2006
Location: Melbourne
Model: 8800
Carrier: Telstra
Posts: 46
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by hdawg View Post
Win2k3 64-bit is now supported with BES 4.1 SP4 - BlackBerry Search Results
I personally wouldn't install BES 4.1.4 on the Exchange 2007 server. Just as an inside tip BES 4.1 Service Pack 5 will be adding full support for x64.
Offline  
Old 11-06-2007, 04:05 AM   #73 (permalink)
Thumbs Must Hurt
 
hitty's Avatar
 
Join Date: Jun 2006
Model: 9780
Carrier: Vodafone UK
Posts: 71
Post Thanks: 2
Thanked 2 Times in 2 Posts
Default Permissions not working with BES 4.1.4 on Exchange 2007

Hi
Our clients BES 4.1.4 on Exchange 2007 and was working fine, except for a calendar issue.
We recommended checking whether the BESAdmin user was a domain admin. It was, and so they removed it.
After it was removed, they restarted the BES, then nothing worked at all (i.e. no e-mail to phone).
We checked and redid the permissions as per the BlackBerry KB12483

get-mailboxserver <mail_server_name> | add-adpermission –user BESAdmin –accessrights Genericread, GenericWrite –extendedrights Send-As, Receive-As, ms-Exch-Store-Admin
No luck.

We then setup an entirely new BES on an entirely new machine with an entirely new user, again *Nothing* worked (i.e. no e-mail to phone).
We then reverted back to the original BES. If we add back BESAdmin into the domain admin groups, we get e-mail to the device again, but the calendar syncing does not work properly.
Exchange Mapi Client and CDO 1.2.1 is installed on the BES.

Whenever BESAdmin is NOT in the domain admin group, we get a MAPI error that we have below:
MAPIMailbox::CreateSearchFolder - Open Entry (0x80070005) failed
If It IS, it works OK (apart from the calendar syncing).

SRP shows Connected
BlackBerry Services are all running fine with the correct login
Components NOT working: mail inbound, mail outbound, PIM data contacts and tasks, PIM data calendar

Result of IEMSTest
C:\Program Files\Research In Motion\BlackBerry Enterprise Server\Utility>IEMSTes
t.exe
BlackBerry Enterprise Server Utility - IEMSTest.exe (IExchangeManageStore), Vers
ion 1.0
Copyright (c) Research In Motion, Ltd. 1999. All rights reserved.
Opening Default Message Store Mailbox - BESAdmin2.
Opening message store for test user using /o=MBR/ou=first administ
rative group/cn=Recipients/cn=test /o=MBR/ou=Exchange Administrative Group (FYDI
BOHF23SPDLT)/cn=Configuration/cn=Servers/cn=BOOTHOME/cn=Microsoft Private MDB.
test users Mailbox opened successfully.
Root Folder opened successfully.
Failed to create a folder in test users mailbox.

Can anyone please provide assistance?
Thanks
Offline  
Old 12-04-2007, 06:12 AM   #74 (permalink)
Thumbs Must Hurt
 
hitty's Avatar
 
Join Date: Jun 2006
Model: 9780
Carrier: Vodafone UK
Posts: 71
Post Thanks: 2
Thanked 2 Times in 2 Posts
Smile all sorted, just followed this:

Create a new Active Directory user account for BES admin
Create a mailbox for the new BES admin account

To assign permissions for the BES admin account please go through the steps in the Knowledgebase articles that apply to you:-

KB02276

System Requirements

KB13302

Obtaining Mapi and CDO clients

KB12697
Offline  
Old 12-04-2007, 03:05 PM   #75 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Dec 2005
Location: San Diego, CA
Model: 9000
OS: 4.6.0.210
Carrier: AT&T
Posts: 203
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

OK EVERYONE! I just got off the phone with Spencer @ RIM and we found the problem! The documentation is wrong... The documentation on PAGE 27 of BlackBerry Enterprise Server for Microsoft Exchange - Version 4.1.4 STATES:

3.Type the following command:
set-mailboxserver “<messaging_server_name>” | add-adpermission –user “BESAdmin”
–accessrights ExtendedRight –extendedrights Send-As, Receive-As, ms-Exch-Store-Admin

IT NEEDS TO BE:


set-mailboxserver “<messaging_server_name>” | add-adpermission –user “BESAdmin”
–accessrights GenericRead, GenericWrite, ExtendedRight –extendedrights Send-As, Receive-As, ms-Exch-Store-Admin


Notice the addition of GenericRead and GenericWrite.

This will resolve all one-way syncronization issues with Calendar! You dont even need to restart the darn BES services, it just starts working...

RIM is changing the doucmentation ASAP...

Bradley
Offline  
Old 12-05-2007, 10:52 AM   #76 (permalink)
Knows Where the Search Button Is
 
Join Date: Aug 2007
Location: Quebec, CAN
Model: 8100
PIN: 205D45FA
Carrier: Rogers
Posts: 23
Post Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation

I still have trouble with my freakin calendar!

Event Type: Warning
Event Source: BlackBerry Messaging Agent SERVEUR Agent 1
Event Category: None
Event ID: 20216
Date: 12/5/2007
Time: 11:47:46 AM
User: N/A
Computer: SERVEUR
Description:
[email address]} Synchronize() failed: ERR_FAIL, Tag=3298

I did that and re-activated the wireless calendar sync:
set-mailboxserver “<messaging_server_name>” | add-adpermission –user “BESAdmin” –accessrights GenericRead, GenericWrite, ExtendedRight –extendedrights Send-As, Receive-As, ms-Exch-Store-Admin

Does anyone know what to do with that?
Offline  
Old 02-07-2008, 01:20 PM   #77 (permalink)
New Member
 
Join Date: Jun 2005
Location: Greenwood, SC
Model: 7103e
Carrier: Verizon
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

great write up. Installed our Bes 4.1.4 with exch07 sp1. No problems. Blackberry docs dont tell you about the mapi client and collaboration objects (at least the ones i found).
Offline  
Old 02-12-2008, 04:54 PM   #78 (permalink)
Knows Where the Search Button Is
 
Join Date: May 2007
Location: Pennsylvania
Model: 9530
PIN: N/A
Carrier: Verizon
Posts: 19
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Co Existence

We are starting our migrations to Exchange 2007 soon and I anticipate being in coexistence mode for something like 18 months. The comments on coexistence are worrisome. Is it as simple as ensuring that the CDO.dll is the newest and the same accross my BES environment or will I have to stand up another BES?
Offline  
Old 02-14-2008, 12:24 PM   #79 (permalink)
Knows Where the Search Button Is
 
DTSBES's Avatar
 
Join Date: Jun 2005
Model: 8703e
Carrier: Sprint
Posts: 23
Post Thanks: 0
Thanked 0 Times in 0 Posts
Lightbulb

I think it is pretty clear that you need a separate BES for Exchange 2007. We had not thought about this either but we are now as we are in the midst of planning our Exchange 2003 to Exchange 2007 migration.

If you have Exchange Systems Manager 2003 installed on the BES server it will fully support Exchange 2003 but won't fully sync with Exchange 2007 (e.g. Calendar sync doesn't work). If you remove Exchange System Manager and install "MAPI Client and Collaboration Data Objects 1.2.1" it will fully support Exchange 2007 but will have sync issues with Exchange 2003 (e.g. Calendar sync doesn't work).
Offline  
Old 02-18-2008, 10:25 AM   #80 (permalink)
Knows Where the Search Button Is
 
Join Date: May 2007
Location: Pennsylvania
Model: 9530
PIN: N/A
Carrier: Verizon
Posts: 19
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Coexistence

Thanks - I suspected as much...
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright © 2004-2014 BlackBerryForums.com.
The names RIM © and BlackBerry © are registered Trademarks of BlackBerry Inc.