BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 01-30-2009, 09:55 AM   #101 (permalink)
New Member
 
Join Date: Jan 2009
Model: 9500
PIN: N/A
Carrier: Verizon
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Please Login to Remove!

I will admit I am new to all of this IT work but I work for a small company (18 people and only 8 Blackberrys maybe) and they need me to manage their servers along with all of my other duties. The boss just got a Storm and wants to have push email and have his calendar and contacts and what not synched to his phone and all the other blackberrys. I have one server runner W2k3 that is my domain controller and then I have another server running Exchange 2007. I do not want to install BES express on our domain controller is possible/compatible to run BES express on our Exchange 2007 server or not?? Thank you ahead of time for your comments and thoughts.
Offline  
Old 02-02-2009, 09:21 AM   #102 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Z30
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,721
Post Thanks: 272
Thanked 288 Times in 272 Posts
Default

What OS is exchange installed on?

Server 2008 is not supported yet.
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Z30, Z10 and Q10
Online  
Old 02-02-2009, 09:59 AM   #103 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Feb 2007
Location: Toronto
Model: 9800
Carrier: Rogers
Posts: 319
Post Thanks: 2
Thanked 5 Times in 5 Posts
Default

Quote:
Originally Posted by jfults2000 View Post
I will admit I am new to all of this IT work but I work for a small company (18 people and only 8 Blackberrys maybe) and they need me to manage their servers along with all of my other duties. The boss just got a Storm and wants to have push email and have his calendar and contacts and what not synched to his phone and all the other blackberrys. I have one server runner W2k3 that is my domain controller and then I have another server running Exchange 2007. I do not want to install BES express on our domain controller is possible/compatible to run BES express on our Exchange 2007 server or not?? Thank you ahead of time for your comments and thoughts.


Not a good idea to run BES on Exchange or on DC, you need a dedicated box
Offline  
Old 02-16-2009, 04:29 AM   #104 (permalink)
New Member
 
Join Date: Feb 2009
Model: 8310
PIN: N/A
Carrier: Vodafone
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have an issue with my current fresh BES install.

Environment is as follows:

BES Server - Win2k3 SP2 (Domain Controller) with the mapi and cdo 1.2.1 + mdac installed + BES 4.1.4b
Exchange Server - Windows 2008 + Exchange 2007 (08.01.0240.006 = SP1?).

I've gone through the setup but when I come to set the mapi profile it refuses to resolve the name, it will resolve the administrator name but not the besadmin name.

I have set ViewOnlyAdmin and other writes using:

set-mailboxserver <servername> | add-ADpermission -user BESAdmin -accessrights GenericRead, GenericWrite, ExtendedRight -extendedrights Send-As, Receive-As, ms-Exch-Store-Admin

Permissions check:

User : DOMAIN\BESAdmin
Identity : EXCHANGESERVER
Deny : False
AccessRights : {Self, WriteProperty, GenericRead}
ExtendedRights :
IsInherited : False
Properties :
ChildObjectTypes :
InheritedObjectType :
InheritanceType : All

User : DOMAIN\BESAdmin
Identity : EXCHANGESERVER
Deny : False
AccessRights : {ExtendedRight}
ExtendedRights : {Receive-As}
IsInherited : False
Properties :
ChildObjectTypes :
InheritedObjectType :
InheritanceType : All

User : DOMAIN\BESAdmin
Identity : EXCHANGESERVER
Deny : False
AccessRights : {ExtendedRight}
ExtendedRights : {ms-Exch-Store-Admin}
IsInherited : False
Properties :
ChildObjectTypes :
InheritedObjectType :
InheritanceType : All

User : DOMAIN\BESAdmin
Identity : EXCHANGESERVER
Deny : False
AccessRights : {ExtendedRight}
ExtendedRights : {Send-As}
IsInherited : False
Properties :
ChildObjectTypes :
InheritedObjectType :
InheritanceType : All

Still MAPI errors, I tried to look for away to amend the GAL permissions but I'm not particularly familiar with exchagne 2007 and the management shell.

Last edited by Sp00n : 02-16-2009 at 04:57 AM.
Offline  
Old 02-16-2009, 06:11 AM   #105 (permalink)
New Member
 
Join Date: Feb 2009
Model: 8310
PIN: N/A
Carrier: Vodafone
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

The besadmin accounts needs a mailbox, who knew
Offline  
Old 02-21-2009, 08:46 AM   #106 (permalink)
New Member
 
Join Date: Feb 2009
Model: 7100T
PIN: N/A
Carrier: Orange
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default This is a handy step by step guide for setting up BES with Exchange 2007

Useful how-to guide for setting up BES with EX2007

itexpertmag.com/telecoms/setting-up-blackberry-enterprise-server-bes-with-exchange-2007

Hope this helps the community
Regards
Julian
Offline  
Old 05-19-2009, 09:05 AM   #107 (permalink)
BlackBerry Extraordinaire
 
Frank Castle's Avatar
 
Join Date: Jul 2005
Location: MA
Model: 9930
PIN: PM Me!
Carrier: VZW
Posts: 1,073
Post Thanks: 0
Thanked 4 Times in 3 Posts
Default Mix Exchange 2003 & 2007

Hi,

So we finally have our 1st Exchange 2007 mailbox up.

What is the latest with a mix 2003 & 2007? BES is on it's own box and has ESM tools. Service account is staying in 2003.

Are there still calendar issues?

Anything I missed?
Offline  
Old 06-24-2009, 05:15 PM   #108 (permalink)
New Member
 
Join Date: Jun 2009
Model: 8310
PIN: N/A
Carrier: Rogers
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default BES 4.1.6/Exchange 2007 Calendar Sync

I had a lot of problems with Calendar Sync in BES 4.1.6 and Exchange 2007 in a hosted environment. You can check out the solution at blackberryforums.com/bes-admin-corner/194863-solved-bes-4-1-6-exchange-2007-calendar-sync-issue.html
Offline  
Old 09-01-2009, 09:06 AM   #109 (permalink)
Thumbs Must Hurt
 
guruleenyc's Avatar
 
Join Date: Oct 2006
Location: nYc & CT
Model: 8820
Carrier: AT&T/Sprint/Nextel
Posts: 186
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Excellent and to the point! Thanks for the resource as it worked like a charm in my BES svc account migration from Exch2k3 to Exch2k7 cohabitating for some time.
__________________
BES Admin/Nextel 60x 7520's/10x AT&T 8800's/2x BES

"Knowledge breeds confidence and confidence breeds success"
Offline  
Old 11-18-2009, 04:06 PM   #110 (permalink)
New Member
 
Join Date: Sep 2009
Model: 7100
PIN: N/A
Carrier: Verizon
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Sp00n View Post
The besadmin accounts needs a mailbox, who knew
I'm having a problem creating this mailbox at the moment. Exchange 2007 won't let me.
Offline  
Old 12-13-2009, 08:29 PM   #111 (permalink)
New Member
 
Join Date: Dec 2009
Model: 9000
PIN: N/A
Carrier: Telstra
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default How and where do you create a service account in Exchange Management Console?

Quote:
Originally Posted by garycutri View Post
Install BES 4.1.3 or higher in an Exchange 2007 Environment

2. Log onto your Exchange Server using an account which has permissions to create an account. Open the Exchange Management Console and create a service account called BESadmin.
Silly question, but exactly how do you do this?

Cheers Steve
Offline  
Old 12-17-2009, 02:43 PM   #112 (permalink)
New Member
 
Join Date: Jul 2008
Model: 831-
PIN: N/A
Carrier: AT&T
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm having some issues pushing an IT policy to a user. We're on BES 5.0.1. When I view the status of the job, it says "optimized out". Does anyone know what this means? Thanks!
Offline  
Old 01-27-2010, 06:45 AM   #113 (permalink)
Knows Where the Search Button Is
 
Tacfire11's Avatar
 
Join Date: Jan 2007
Model: 7100T
Carrier: Verizon
Posts: 42
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

'm running into the same situation, trying to install BES 5.0, on a W2K8 Server. I'm receiving the same errors with regards to Mapi and CDO. I read in an earlier post that these files have been moved in the latest EXMapiCDO.EXE package to C:\Program Files, instead of (as an example) C:\Windows\System32. I have also installed the ESM tools from Exchange 2007. So I had thought that ESM also provided MAPI and CDO for the BES, but I could be wrong (probably, I getting use to it ). Oh, I had originaly downloaded and installed the older version of MAPICDO to install. I did not uninstall when I downloaded and installed the newer version. Probably should do that .

So my question, do I simply move these files (EXMapi.dll and CDO.dll), and will that solve the install error?

Thanks guys.
__________________
"Every great accomplishment was at one time thought to be impossible"
Offline  
Old 01-27-2010, 05:08 PM   #114 (permalink)
BlackBerry Elite
 
knottyrope's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Model: Z30
OS: 10.2.1
PIN: t of blood has been taken
Carrier: AT&T-US with I dee ten tee errors
Posts: 6,721
Post Thanks: 272
Thanked 288 Times in 272 Posts
Default

install the CDO 1.2.1 from here instead of ESM 2003 tools,

http://www.microsoft.com/downloads/d...4286b1f&Displa...
__________________
irony : many old timer posters have de-evolved into the trolls they once fought
I am on http://supportforums.blackberry.com
BES 10 running sweet for my Z30, Z10 and Q10
Online  
Old 01-27-2010, 10:39 PM   #115 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: May 2007
Location: Toronto, Canada
Model: 9700
OS: 5.0.0.423
PIN: 21B694E3
Carrier: Virgin Mobile Canada
Posts: 396
Post Thanks: 1
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by Tacfire11 View Post
'm running into the same situation, trying to install BES 5.0, on a W2K8 Server. I'm receiving the same errors with regards to Mapi and CDO. I read in an earlier post that these files have been moved in the latest EXMapiCDO.EXE package to C:\Program Files, instead of (as an example) C:\Windows\System32. I have also installed the ESM tools from Exchange 2007. So I had thought that ESM also provided MAPI and CDO for the BES, but I could be wrong (probably, I getting use to it ). Oh, I had originaly downloaded and installed the older version of MAPICDO to install. I did not uninstall when I downloaded and installed the newer version. Probably should do that .

So my question, do I simply move these files (EXMapi.dll and CDO.dll), and will that solve the install error?

Thanks guys.
ESM tools don't work on Exchange 2007, if you really need the tools you need to download Exchange 2007 32bit bit from MS and install it on a Windows XP machine. Generally the tools are good for backing up and restoring mailboxes in Exchange since you can't do it on the server level.
Offline  
Old 04-06-2010, 04:27 PM   #116 (permalink)
New Member
 
Join Date: Apr 2010
Model: none
PIN: N/A
Carrier: none
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default SBS 2003 to SBS 2008 Migration

We currently have an SBS 2003 server running Exchange 2003, a dedicated BES (4.1.4) server running on Server 2003, and a freshly loaded SBS 2008 running Exchange 2007.

I am getting ready to migrate network settings and Exchange mailboxes to the new server. I'm totally new to administering BES, and I have read through the thread and am not sure which steps I need to follow, given the versions I'm running.

Thanks in advance.
Offline  
Old 04-08-2010, 05:04 PM   #117 (permalink)
New Member
 
Join Date: Sep 2006
Model: 8310
Carrier: at&t
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I am trying to install BES Express 5.0.1 on an Microsoft 2008 x64 server that is running Exchange 2007 sp2. It is also a Domain Controller. I know I am piling things on here, maybe this is why people go virtual, and I may have to consider running the BES virtual, it is only going to support 3 blackberries, so I can probably allocate pretty low resources for it.
But I have successfully put BPS 4.1 on an SBS2003 server which is essentially doing the same thing I am trying to do now.

It gives me 2 errors.
Unable to find collaboration Data Objects Library (CDO.dll)
Microsoft Exchange Server detected (MAPI version 1.0.2536)

I installed the CDO 1.2.1 from the link above and it went through, after trying the "outlook" version first by accident. I still get the CDO.dll error however.

Edit:
I restarted the server and now the MAPI and CDO pre-requisites are fine. Hopefully this actually works after the install.

Last edited by scott0482 : 04-08-2010 at 05:33 PM.
Offline  
Old 07-08-2010, 05:55 AM   #118 (permalink)
New Member
 
Join Date: Jun 2010
Model: 9700
PIN: N/A
Carrier: jawwal.ps
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default BES with Exchange 2007

I installed exchange 2007 in Server that placed in HeadQuarter office,Can i install BES express in diffrent LAN(other office) Note:IP-VPN between 2 offices
please any one to help!!
Offline  
Old 07-08-2010, 06:11 AM   #119 (permalink)
New Member
 
Join Date: Jun 2010
Model: 9700
PIN: N/A
Carrier: jawwal.ps
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default BES hosted server

server i want to install BES on it, does necessary be domain controller??
Quote:
Originally Posted by Sp00n View Post
I have an issue with my current fresh BES install.

Environment is as follows:

BES Server - Win2k3 SP2 (Domain Controller) with the mapi and cdo 1.2.1 + mdac installed + BES 4.1.4b
Exchange Server - Windows 2008 + Exchange 2007 (08.01.0240.006 = SP1?).

I've gone through the setup but when I come to set the mapi profile it refuses to resolve the name, it will resolve the administrator name but not the besadmin name.

I have set ViewOnlyAdmin and other writes using:

set-mailboxserver <servername> | add-ADpermission -user BESAdmin -accessrights GenericRead, GenericWrite, ExtendedRight -extendedrights Send-As, Receive-As, ms-Exch-Store-Admin

Permissions check:

User : DOMAIN\BESAdmin
Identity : EXCHANGESERVER
Deny : False
AccessRights : {Self, WriteProperty, GenericRead}
ExtendedRights :
IsInherited : False
Properties :
ChildObjectTypes :
InheritedObjectType :
InheritanceType : All

User : DOMAIN\BESAdmin
Identity : EXCHANGESERVER
Deny : False
AccessRights : {ExtendedRight}
ExtendedRights : {Receive-As}
IsInherited : False
Properties :
ChildObjectTypes :
InheritedObjectType :
InheritanceType : All

User : DOMAIN\BESAdmin
Identity : EXCHANGESERVER
Deny : False
AccessRights : {ExtendedRight}
ExtendedRights : {ms-Exch-Store-Admin}
IsInherited : False
Properties :
ChildObjectTypes :
InheritedObjectType :
InheritanceType : All

User : DOMAIN\BESAdmin
Identity : EXCHANGESERVER
Deny : False
AccessRights : {ExtendedRight}
ExtendedRights : {Send-As}
IsInherited : False
Properties :
ChildObjectTypes :
InheritedObjectType :
InheritanceType : All

Still MAPI errors, I tried to look for away to amend the GAL permissions but I'm not particularly familiar with exchagne 2007 and the management shell.
Offline  
Old 07-08-2010, 07:36 AM   #120 (permalink)
New Member
 
Join Date: Apr 2010
Model: none
PIN: N/A
Carrier: none
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default BES Hosted Server

osaid suliebi,

No, the server does not need to be a domain controller. The one we use is not.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.