BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 05-05-2005, 08:44 AM   #1 (permalink)
Thumbs Must Hurt
 
Join Date: Mar 2005
Model: Storm
Carrier: Verizon
Posts: 80
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default Errors in Router & Controller logs

Please Login to Remove!

Lately I've been seeing this error in my Router log. Can anyone shed some info on it? (BES 4.0 SP1 for Exchange 5.5)

SERVICE_RELAY_SESSION:SRP edited:0125f1a8] Service transaction not found. SERVICESESSION_TAG=12939305

Also been having hung threads and Agent crashes detected in the Controller log:

agent 1: hung threads detected. WaitCount = 1
agent 2: crash detected
agent 2 stopped. Exit code = 3


What exactly would cause hung threads?
Offline  
Old 05-05-2005, 09:58 AM   #2 (permalink)
Thumbs Must Hurt
 
Korbyn's Avatar
 
Join Date: May 2005
Location: Calgary, AB
Model: 9800
OS: 6.0.0.246
Carrier: Telus
Posts: 85
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Multiple BES's?

Do you by any chance have multiple BES servers using the same SQL management database?

I just met with a RIM technical rep and supposedly there is a reg hack that needs to be done to help prevent contention between the two BES servers attempting to write to the SQL database at the same time. I'm waiting to receive the reg hack instructions, unless someone has them already
Offline  
Old 05-05-2005, 12:19 PM   #3 (permalink)
Thumbs Must Hurt
 
Join Date: Mar 2005
Model: Storm
Carrier: Verizon
Posts: 80
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

No, single 4.0 BES with a local MSDE database.
Offline  
Old 05-05-2005, 02:58 PM   #4 (permalink)
dev
CrackBerry Addict
 
dev's Avatar
 
Join Date: Apr 2005
Location: Toronto
Model: 8800
Carrier: Rogers
Posts: 571
Post Thanks: 0
Thanked 2 Times in 2 Posts
Default

Could you post the reg hack when available. I'm about to do a multi BES consolidation to use a single SQL db and would appreciate the info.
Thanks.
Offline  
Old 05-16-2005, 11:33 AM   #5 (permalink)
Thumbs Must Hurt
 
Korbyn's Avatar
 
Join Date: May 2005
Location: Calgary, AB
Model: 9800
OS: 6.0.0.246
Carrier: Telus
Posts: 85
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

It's been hard to tell if this has really helped much. As an after thought I checked and my MDAC's versions are not the same on both BES servers.

This reg hack won't eliminate the messages, but it does reduce them I believe.

HK_Local_Machine\Software\Research In Motion\BlackBerry Enterprise Server\Agents
DWORD “SavePagerStatsInterval” set to 780 seconds.
DWORD “GlobalStatsInterval” set to 240 seconds.

FYI: GlobalStats default is 15 and PagerStats is 60

We are in the process of moving all users off the old upgraded BES box to the new clean 4.0 installed box, but of course, these things take time. At this point I'm not going to bother upgrading the MDAC on the old machine, I'm just going to live with it for another couple of weeks only, hopefully.

Cheers
Offline  
Old 05-16-2005, 11:58 AM   #6 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2005
Model: 8100
Carrier: vodafone
Posts: 35
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Receiving the same error messages since upgrading to SP1....! Still waiting for RIM to provide an explanation
Offline  
Old 05-16-2005, 12:07 PM   #7 (permalink)
Thumbs Must Hurt
 
Korbyn's Avatar
 
Join Date: May 2005
Location: Calgary, AB
Model: 9800
OS: 6.0.0.246
Carrier: Telus
Posts: 85
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

This was something that was specifically supposed to be fixed in SP1... guess not eh.
Offline  
Old 09-21-2005, 05:38 AM   #8 (permalink)
New Member
 
Join Date: Sep 2005
Model: 7730
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Got some same problem as mentioned above, has anyone a quick fix tot hat?


thx.

Lately I've been seeing this error in my Router log. Can anyone shed some info on it? (BES 4.0 SP1 for Exchange 5.5)

SERVICE_RELAY_SESSION:SRP edited:0125f1a8] Service transaction not found. SERVICESESSION_TAG=12939305

Also been having hung threads and Agent crashes detected in the Controller log:

agent 1: hung threads detected. WaitCount = 1
agent 2: crash detected
agent 2 stopped. Exit code = 3


What exactly would cause hung threads?
Offline  
Old 06-01-2006, 05:37 PM   #9 (permalink)
Thumbs Must Hurt
 
rliebsch's Avatar
 
Join Date: Apr 2005
Location: SF
Model: 8100
Carrier: TMO
Posts: 138
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Service_relay_session

I have been getting these for a bit.
I rebooted the server when I was getting an inordinate number of Blocked worker threads.

After 40 minutes or so, though we are getting SRP pings, no activity to the handhelds.

These Blackberry Router messages are stacking up.

Edited to add: The blocked worker threads are stacking up as well...
__________________
Robert Liebsch
Systems Psychologist, Network Sociologist, User Therapist.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright © 2004-2014 BlackBerryForums.com.
The names RIM © and BlackBerry © are registered Trademarks of BlackBerry Inc.