BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 05-10-2005, 10:14 AM   #1 (permalink)
bbJ
New Member
 
Join Date: May 2005
Model: 7290
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Lost connection with SQL database

Please Login to Remove!

I would like to know if someone already had a similar problem. The error message in the log is "Lost connection with SQL database". When it happens the reconnection is done successfully in the same second for some users but some others (not always the same users) are not automatically reconnected to Lotus Notes through the BES. The only thing I can do to fix the problem is to kill the domino task and to restart it (when I try to stop Domino, it freezes).

Our setup is:
- Windows 2003 Server
- BES 4.0 for Lotus Domino
- Lotus Domino Server 5.0.13a
- Remote SQL database (hosted on a SQL 2000 Cluster)
- SQL authentication

If you have any idea just let me know....

Thanks!!
Offline  
Old 05-18-2005, 09:03 AM   #2 (permalink)
dev
CrackBerry Addict
 
dev's Avatar
 
Join Date: Apr 2005
Location: Toronto
Model: 8800
Carrier: Rogers
Posts: 571
Post Thanks: 0
Thanked 2 Times in 2 Posts
Default

The problem seems to be between the remote SQL server and the BES. Take a look at the ODBC setup on the BES server. There should be a "test" option for testing connectivity to the SQL server. As for DOmino freezing on shutdown...that's not uncommon. There are about 12 or more services that are running apart from the normally visible ones when a "sh task" is done at the server console. What you need is something called killdomino.exe It's usually found on some Lotus specific sites/forums. It kills all domino tasks when initiated prior to shutdown. You'll however have to create a simple batch file listing all the tasks/services by filename in order to get a "graceful" shutdown.
Offline  
Old 05-18-2005, 09:49 AM   #3 (permalink)
CrackBerry Addict
 
rsun's Avatar
 
Join Date: Oct 2004
Location: Delaware, USA
Model: 8320
Carrier: at&t/T-Mobile/Verizon
Posts: 747
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Also instead of killing the domino process, do a tell bes quit then a load bes and that should re-establish it?
__________________
Richard Sun
[email address]
Offline  
Old 05-18-2005, 09:14 AM   #4 (permalink)
dev
CrackBerry Addict
 
dev's Avatar
 
Join Date: Apr 2005
Location: Toronto
Model: 8800
Carrier: Rogers
Posts: 571
Post Thanks: 0
Thanked 2 Times in 2 Posts
Default

There still remains the "why does it lose the connection" to the SQL server/database. You will still need to examine your connectivity to the remote SQL server, otherwise you are stuck with having to restart the BES task several times....not a normal step for a BES server.
There are some tools on http://www.sqlsecurity.com that could prove handy in troubleshooting.
Offline  
Old 05-18-2005, 01:02 PM   #5 (permalink)
CrackBerry Addict
 
rsun's Avatar
 
Join Date: Oct 2004
Location: Delaware, USA
Model: 8320
Carrier: at&t/T-Mobile/Verizon
Posts: 747
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

All of our connectivity issues were solved in later hot fixes and service packs, we unluckily have a production server and a development server and RIM found that a deadlock condition was created because we were using the same BESMgmt database.
__________________
Richard Sun
[email address]
Offline  
Old 05-23-2005, 04:34 PM   #6 (permalink)
Thumbs Must Hurt
 
Join Date: Sep 2004
Model: 8800
Carrier: AT&T
Posts: 60
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Is your bes setup to resolve sql database via DNS lookups?
I've talked to support over similar issues and they recommend that you put in an IP address.

Ken
Offline  
Old 05-23-2005, 05:42 PM   #7 (permalink)
CrackBerry Addict
 
rsun's Avatar
 
Join Date: Oct 2004
Location: Delaware, USA
Model: 8320
Carrier: at&t/T-Mobile/Verizon
Posts: 747
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

We use the DNS name, next time we do a service pack, we'll consider switching it. Thanks.
__________________
Richard Sun
[email address]
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.