BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 06-13-2007, 01:35 PM   #1 (permalink)
Thumbs Must Hurt
 
centrekin's Avatar
 
Join Date: Dec 2006
Location: Mississippi
Model: 9630
OS: 5.0.0.591
Carrier: Verizon
Posts: 102
Post Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation BlackBerry Agent

Please Login to Remove!

I have recently added a new user; and I'm getting the following message when I try to assign the user to a new device:

"An error occurred while assigning the device to the user.

The user is not yet known to the BlackBerry Agent. It can take several minutes for a newly added user to be fully initialized by the server before they can be provisioned. (16)"

I the user has been added to the BES for 2 days now... Any thoughts?
Offline  
Old 06-13-2007, 01:38 PM   #2 (permalink)
Thumbs Must Hurt
 
Join Date: Sep 2006
Location: Woodbridge, VA
Model: 9530
Carrier: VZW
Posts: 89
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

How many users are on your BES and being controlled by that Agent?
Offline  
Old 06-13-2007, 01:39 PM   #3 (permalink)
Thumbs Must Hurt
 
centrekin's Avatar
 
Join Date: Dec 2006
Location: Mississippi
Model: 9630
OS: 5.0.0.591
Carrier: Verizon
Posts: 102
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I would assume all my user as being controlled by the BlackBerry Agent. 300 at minimum. What is weird, is this just started happening.
Offline  
Old 06-13-2007, 01:50 PM   #4 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

What type messaging server are you using? What version & service pack of BES?
Offline  
Old 06-13-2007, 01:55 PM   #5 (permalink)
Thumbs Must Hurt
 
centrekin's Avatar
 
Join Date: Dec 2006
Location: Mississippi
Model: 9630
OS: 5.0.0.591
Carrier: Verizon
Posts: 102
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Exchange SP2 2k3; BES 4.1.2 SP2
Offline  
Old 06-13-2007, 02:01 PM   #6 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Do you see something like:

User <UserName> not started
[40204] (date+time):{0x2688} MailboxManager::GetMailboxSession - Using MAPI profile
[40430] (date+time):{0x2688} {<user>@<domain>.com} MAPIMailbox::MAPIMailbox(2) - Mailbox opened on session 0x00f925f0 (SATURN)
[40405] (date+time):{0x2688} {<user>@<domain>.com } MAPIMailbox::OpenIPMSubtree - OpenEntry (0x8004010f) failed

in your Messaging Agent log? Sounds like a permissions problem ... What happens if you run an IEMSTest.exe from the BES as your besadmin? any errors?
Offline  
Old 06-13-2007, 02:11 PM   #7 (permalink)
Thumbs Must Hurt
 
centrekin's Avatar
 
Join Date: Dec 2006
Location: Mississippi
Model: 9630
OS: 5.0.0.591
Carrier: Verizon
Posts: 102
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm thinking it's a permissions issue as well. Which log file is that in? MNGR?
Offline  
Old 06-13-2007, 02:12 PM   #8 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Magt
Offline  
Old 06-13-2007, 02:13 PM   #9 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Handy little reference guide .... Abbreviations for BlackBerry Enterprise Server debug logs
Offline  
Old 06-13-2007, 03:06 PM   #10 (permalink)
Thumbs Must Hurt
 
centrekin's Avatar
 
Join Date: Dec 2006
Location: Mississippi
Model: 9630
OS: 5.0.0.591
Carrier: Verizon
Posts: 102
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well it appears that his permissions are correct... any other thoughts?
Offline  
Old 06-13-2007, 03:36 PM   #11 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Has the user received any messages (in their Exchange mailbox or is it a new Exchange user)? If so, I would restart the BlackBerry Controller service, remove the user and re-add.

Other than that, I'd need to see some logs; sorry.
Offline  
Old 06-13-2007, 04:49 PM   #12 (permalink)
Thumbs Must Hurt
 
centrekin's Avatar
 
Join Date: Dec 2006
Location: Mississippi
Model: 9630
OS: 5.0.0.591
Carrier: Verizon
Posts: 102
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok, here's the fix... Please Reference your Installation guide... OMG I'm such a noob.. I should have checked this first.. But, Admin Information Store on the LOCAL Exchange Server was not checked causing this fuss... SO, you stated earlier, permissions were the culprit!! Happy Cracking!!

(In my defense I was not present when this new exchange server was set up.. Please don't hate.. )

Last edited by centrekin : 06-13-2007 at 04:50 PM.
Offline  
Old 06-13-2007, 05:55 PM   #13 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

no hating ... only throwing bananas!
Offline  
Old 06-14-2007, 11:34 AM   #14 (permalink)
Thumbs Must Hurt
 
centrekin's Avatar
 
Join Date: Dec 2006
Location: Mississippi
Model: 9630
OS: 5.0.0.591
Carrier: Verizon
Posts: 102
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

LOL, well it's a lesson learned.. I guess assuming that the new exchange server would inherit the correct setting was a bad idea... Oops.. NO more ASS-U-ME-ING anymore... Thankfully only one new user was affected by this...
Offline  
Old 06-14-2007, 11:42 AM   #15 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

We've all been there ... until you forget, you'll never remember.

Wow, thats a little too zen-like and confusing all at once.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.