BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   BES Admin Corner (http://www.blackberryforums.com/bes-admin-corner/)
-   -   Making the 4.0 to 4.1 Plunge (http://www.blackberryforums.com/bes-admin-corner/83488-making-4-0-4-1-plunge.html)

AlanM 06-28-2007 04:19 PM

Making the 4.0 to 4.1 Plunge
 
Upgrading tonight two 4.0.5 BES servers to 4.1.4.

Finally.

hdawg 06-28-2007 04:31 PM

Good man :)

let us know the results!

x14 06-28-2007 07:31 PM

Good Luck!

AlanM 06-28-2007 08:56 PM

first server done. Had to wait 35 minutes before any email started delivering. Called RIM and they said yeah, it could take a few minutes to scan the mailboxes depending ontheir sizes. (I'm surprised mine scanned in 35 minutes). Trying to upgrade second BES that shares the config db now. Getting an error on install when it tries to upgrade the DB (which is already upgraded). When the secong BES tries to upgrade the remote DB it gives an error that say the DB is pre 3.5 and I can't upgrade.

AlanM 06-28-2007 09:23 PM

DB upgrade error was resolved by creating a temp config DB on the SQL server housing the config DB, then pointing the upgrade to the temp DB. (I had already upgraded the config DB to 4.1.4 and I was trying to upgrade the remote BES to 4.1.0).

hdawg 06-29-2007 07:29 AM

morning after triaging?

BBAdmin 06-29-2007 08:06 AM

To be fair I never do upgrades at the end of the week - too risky - Respect!!!

AlanM 06-29-2007 09:42 AM

One BES is still not upgraded. I'll post more shortly. Fridays here are typically light about half the work force is off due to Alternate Work Schedule (AWS), so if something hits the fan you only have half the users to deal with it, plus if you have to there's the weekend to fix it.

BBAdmin 06-29-2007 09:51 AM

Quote:

Alternate Work Schedule (AWS)
I love Office Abbreviations (otherwise known as OA's)!!!!!!!

AlanM 06-29-2007 09:55 AM

Shoot, my organization's got more acronyms than you can shake a stick at.

AlanM 06-29-2007 04:26 PM

Here's what I've learned.

I had two BES servers sharing a config db. Mail system is Exchange and the database is SQL 2000. I backed up the config DB and stop BES services on both servers. I had the 4.1.0 install and the 4.1.4 SP. First, I upgraded the BES server that hosts the SQL server and config DB. Upgrade went fine. Once complete, I went ahead and applied SP4 to the 4.1 server. No problems there. After the last reboot after the SP4 upgrade, I waited for my Blackberry to receive or send email. Nothing was happening. Looked at the BES MMC and it didn't look like the BES was even scanning the Exchange mailboxes. Called Tech support and explained situation, as I was explaining what was going on mail started delivering. RIM Tech said it can take a few mminutes for the mailboxes to get rescanned. Anyway, at that point I had one working BES server. I started the upgrade on the second BES, using the 4.1.0 installed. When it encountered the remote Config DB the installer returned an error that the DB was pre 3.5 and could not be upgraded. After much looking on the blackberry site and the forums I found a KB that dealt with 4.1.2. Basically, it was either upgrade with the Full 4.1 with current SP or create an empty Temp config DB and point to the temp DB for the 4.1 upgrade and point to the real DB for the SP upgrade. I choose the temp DB option because I didn't have the full 4.1.4 install. I went through the setup again and made it past the DB section and the reboot section. After the reboot I had to enter in my CAL license, but when it made it to the SRP section the SRP info was blank (using an empty temp config db) and greyed out, so I couldn't edit it. At 11 PM and after being on hold waiting for RIM I decided to go home. I moved all my users from the BES that was down to the upgraded BES (benefits of two BESes with shared DB) and went home. This morning I got RIM on the phone and they got me the full 4.1.4 install. I removed all remanants of BES from the second server and installed using the full SP 4 version. Installed like a champ, although I did have to make sure I entered the old BES server name. Bottomline is I am running both BESes now on 4.1.4.

I think if I had only upgraded the first server to 4.1, then upgraded the second server to 4.1 before applying any service packs it would have been fine. I now have to upgrade my second pair of BES servers on the other domain to 4.1.4, of course this time I have the full install.

That's my story and I'm sticking with it.

Alan
:bb:

mahoward 07-02-2007 09:18 AM

Great reporting AlanM, sounds like a good best practice going forward to always get the latest full install package and use that as opposed to stairstepping up to the latest, especially in multiple server environments.


All times are GMT -5. The time now is 04:17 AM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.