BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 08-17-2007, 04:48 PM   #1 (permalink)
New Member
 
Join Date: Aug 2007
Model: 8100
PIN: N/A
Carrier: vodafone
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default ScanGAL problem

Please Login to Remove!

Who can help ?

In theMAGT Logfile I find the following lines:

[30046] (08/17 23:21:56.415):{0x1328} ScanGAL: Detected a mailbox move or key property change for user: <USER>
[30045] (08/17 23:21:56.415):{0x14EC} Stopping handheld for <USER>

What is the problem ?

Also task, memos and addresses are not synchronized wireless.

BES 4.1.4 on Windows Server 2003, Exchange 2007

Thank's a lot.
Offline  
Old 08-19-2007, 11:05 AM   #2 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Does this happen repeatedly? Just the once? Does this happen for multiple users?
Offline  
Old 08-19-2007, 11:21 AM   #3 (permalink)
New Member
 
Join Date: Aug 2007
Model: 8100
PIN: N/A
Carrier: vodafone
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by hdawg View Post
Does this happen repeatedly? Just the once? Does this happen for multiple users?
It happens repeatedly. After a reboot of the (BES-)Server wireless sync of adressbook, tasks and memos is working fine, until the first "ScanGAL" appears.

The problem is given for any user.
Offline  
Old 08-19-2007, 11:36 AM   #4 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

some or all users?
Offline  
Old 08-19-2007, 11:49 AM   #5 (permalink)
New Member
 
Join Date: Aug 2007
Model: 8100
PIN: N/A
Carrier: vodafone
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by hdawg View Post
some or all users?
This is a new BES installation. The problem appears with every user I tried.

Stopping and restarting of the user(s) with every ScanGAL.
Offline  
Old 08-19-2007, 12:55 PM   #6 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

ok, unfortunately I don't have enough experience with Exchange 2007 to help out with this effectively ... make sure you've gone through this entirely: Install BES 4.1.3 or higher in an Exchange 2007 Environment

perhaps install the win2k3 support tools and run a netdiag on the BES and a dcdiag of your network to make sure there aren't any communications problems.

Is your BES on its own dedicated hardware (or virtual hardware)?
Offline  
Old 10-17-2007, 02:36 PM   #7 (permalink)
New Member
 
Join Date: Oct 2006
Model: 8700r
Carrier: Rogers
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm having this same issue on my BES. we you able to resolve it?
Offline  
Old 11-30-2007, 03:16 AM   #8 (permalink)
New Member
 
Join Date: Aug 2007
Model: 8300
PIN: N/A
Carrier: T-Mobile
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Have you solved the problem?

Please tell me how you did solve it.
Offline  
Old 11-30-2007, 08:38 AM   #9 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Is this happening for everyone? Have you made any changes recently to AD / your network?

are you also using 4.1.4? Have you applied any Maintenance Releases?
Offline  
Old 12-03-2007, 02:09 AM   #10 (permalink)
New Member
 
Join Date: Aug 2007
Model: 8300
PIN: N/A
Carrier: T-Mobile
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hello,

We are using version 4.1.4. with MR2.

There were three users which use the use BES.
Only one is running fine. Two others have the ScanGAL problem.
Offline  
Old 12-03-2007, 07:03 AM   #11 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

... and what happens after a reboot of the BES?
Offline  
Old 12-03-2007, 07:05 AM   #12 (permalink)
New Member
 
Join Date: Aug 2007
Model: 8300
PIN: N/A
Carrier: T-Mobile
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

After reboots it works for about 30 minutes.
Then the ScanGAL comes again
Offline  
Old 12-03-2007, 07:17 AM   #13 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Are you having any replication issues with active directory?

Can you run a BBCheck and post the results from it? What else are you seeing in your ALRT / CTRL / MAGT logs that are around this error. Usually there are a few lines of output for errors in BES logs; the surrounding entries explain the data a bit more.
Offline  
Old 12-03-2007, 07:45 AM   #14 (permalink)
New Member
 
Join Date: Aug 2007
Model: 8300
PIN: N/A
Carrier: T-Mobile
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

results from bbcheck:

[START_14:44:08]

Generated by BBCheck Version 1.0.0.2

[GENERAL]

Current User: DHAGNET\besadmin
Host Name: BB-EXCH
OS Version: 5
Build number: 2
ServicePack: 2.0

[BES]

Platform: Exchange
Version: 4.1.4 (Bundle 25)
Install Path: C:\Program Files\Research In Motion\BlackBerry Enterprise Server\
Network Access Node: srp.de.blackberry.net
MAPI Profile: BlackBerryServer
MAPI GC: S005.dhagnet.local

[SERVICE_ACCOUNT]

BlackBerry Service Account: DHAGNET\besadmin

Domain Group Membership:

CN=Exchange View-Only Administrators,OU=Microsoft Exchange Security Groups,DC=dhagnet,DC=local

[EXCHANGE_PERMISSIONS]

Server: CN=S006,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=DHAG,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=dhagnet,D C=local

Accounts/Groups found with Send As/Receive As permissions:

Account: dhagnet\besadmin has Send As Permissions
Account: dhagnet\besadmin has Receive As Permissions

[MAPI_SUBSYSTEM]

MAPI32.DLL: 6.5.7940.0 (c:\windows\system32\mapi32.dll)
EMSMDB32.DLL: 6.5.7940.0 (c:\windows\system32\emsmdb32.dll)
CDO.DLL: 6.5.7940.0 (C:\WINDOWS\system32\cdo.dll)

[GC]

Domain Name: dhagnet.local
GC Name: S004.dhagnet.local
GC IP: 172.16.101.247

[DATABASE]

Hostname: BB-EXCH
DB Name: BESMgmt
Location: Local
SQL Version: Unable to find SQL version!
Location: Local
MSDE Version: 8.00.761
DB info via TSQL: Desktop Engine (8.00.760 SP3)
MDAC Version: 2.82.3959.0
MSADO15.DLL: 2.82.3959.0 (C:\Program Files\Common Files\System\ado\msado15.dll)

[JAVA]

Version: 1.5
Path: C:\Program Files\Java\jre1.5.0_11

MDS JVM Path: C:\Program Files\Java\jre1.5.0_11\bin\client\jvm.dll

[.NET_FRAMEWORK]

Version 1.0: MISSING
Version 1.1 (1.1.4322): INSTALLED
Version 2.0 (2.0.50727): MISSING
Version 3.0 (3.0.0456.30): MISSING

[XML]

XML Parser: 4.20.9818.0 (C:\WINDOWS\system32\msxml4.dll)

[MSMQ]

Microsoft Messaging Queue Version: Unknown

[NETWORK]

Local IP: 172.16.104.231
TCP/IP Providor: 5.2.3790.0 (C:\WINDOWS\System32\wsock32.dll)
Winsock2 File: Network Location Awareness (NLA) Namespace 5.2.3790.3959 (C:\WINDOWS\System32\mswsock.dll)

[SRP_CONNECTIVITY]

Host: srp.de.blackberry.net
IP: 193.109.81.33
Port: 3101

Status: Connection Successful

[SYSTEM]

Processor:

Processor Identifier: x86 Family 15 Model 4 Stepping 8
Processor Vendor: GenuineIntel
Processor Name: Intel(R) Xeon(TM) CPU 2.66GHz
Number of CPUs: 1

Memory:

Memory In Use: 67%
Total Memory: 1,048,012 MB
Memory Available: 338,312 MB
Memory Limit: 2,532,848 MB
Available Commit: 1,775,968 MB
BES Virtual Space: 2,097,024 MB
BES Unused Memory: 2,037,836 MB

Hard Drive:

Total HD Bytes: 3,144,688 MB
Total Free Bytes: 1,294,644 MB

Time Info:

System Up Time: 4 days 3 hours 32 minutes 29 seconds
Local Time Zone: W. Europe Daylight Time (GMT+01:00)

[SYSTEM_HOTFIXES]


[PROCESSES]

Process PID Threads

System 4 82
smss.exe 288 2
csrss.exe 336 14
winlogon.exe 360 20
services.exe 408 16
lsass.exe 420 38
svchost.exe 660 5
svchost.exe 716 9
svchost.exe 772 10
svchost.exe 800 13
svchost.exe 836 51
spoolsv.exe 1008 12
msdtc.exe 1036 18
svchost.exe 1236 2
sqlservr.exe 1848 33
NTRtScan.exe 1932 13
svchost.exe 1984 3
TmListen.exe 2088 13
VMwareService.exe 2148 3
svchost.exe 2224 7
svchost.exe 2248 4
wmiprvse.exe 2652 4
OfcPfwSvc.exe 2688 6
PGA764.EXE 4088 1
svchost.exe 980 23
svchost.exe 4116 15
explorer.exe 4760 12
VMwareTray.exe 5792 1
VMwareUser.exe 4632 1
PccNTMon.exe 748 4
jusched.exe 1072 1
ctfmon.exe 1048 1
sqlmangr.exe 2736 2
jucheck.exe 5932 3
bbmgrw32.exe 248 21
RIMDeviceManager.exe 5868 20
BbDevMgr.exe 476 3
BESAlert.exe 6856 7
BBAttachServer.exe 6900 112
BlackBerryController.exe 7424 7
bmds.exe 7760 262
BlackberryRouter.exe 676 8
ITAdminServer.exe 2680 21
javaservice.exe 3056 236
BlackBerrySyncServer.exe 6804 87
BlackBerryDispatcher.exe 6552 50
BlackBerryAgent.exe 2016 31
BBConvert.exe 8180 2
BBConvert.exe 3596 2
BBConvert.exe 3368 2
wmiprvse.exe 3708 6
BBConvert.exe 1016 3
csrss.exe 3856 9
winlogon.exe 6948 9
rdpclip.exe 5880 5
BBCheck.exe 5892 7
[END_14:44:12]
Offline  
Old 12-03-2007, 07:48 AM   #15 (permalink)
New Member
 
Join Date: Aug 2007
Model: 8300
PIN: N/A
Carrier: T-Mobile
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

We got two ad-server.
I don't know how to find out replication issues. whether we have replication issues
Offline  
Old 12-03-2007, 07:48 AM   #16 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Check your connectivity to S005.dhagnet.local and make sure it isn't having any problems. Can you post any actual events too?
Offline  
Old 12-03-2007, 07:53 AM   #17 (permalink)
New Member
 
Join Date: Aug 2007
Model: 8300
PIN: N/A
Carrier: T-Mobile
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

MAGT-Logfile:

[45051] (12/03 00:08:05.731):{0xC7C} DBNS: renewed subscription, heartbeat 8515
[30181] (12/03 00:08:51.903):{0x1688} Performing system health check (BlackBerry Mailbox Agent 1 - BESX Version 4.1.4.25)
[40360] (12/03 00:08:51.903):{0x1688} [BIPPa] Health: QSize=0, intMap=0
[40000] (12/03 00:09:05.653):{0xC8C} [BIPP] Ping 3276 sent
[40000] (12/03 00:09:05.653):{0xC88} [BIPP] PingResponse 3276 received
[40442] (12/03 00:09:44.716):{0x1748} User settings: email=d**@d****-*.com, routing=S47707775, service=BB-EXCH, device=251308BD, calendar=1, MDS=1, userOTAFM=63, incradle=0, SMIME=0, sentItems=1, dir=drhk, server=S006
[40000] (12/03 00:10:05.653):{0xC8C} [BIPP] Ping 3277 sent
[40000] (12/03 00:10:05.653):{0xC88} [BIPP] PingResponse 3277 received
[30046] (12/03 00:11:03.950):{0xC78} ScanGAL: Detected a mailbox move or key property change for user: Dr. H* K*
[40747] (12/03 00:11:03.966):{0xDC4} License total: 5, used = 3, free = 2
[40000] (12/03 00:11:03.966):{0xC8C} [BIPP] Send data, Tag=10386
[40000] (12/03 00:11:03.966):{0xC88} [BIPP] Received status DELIVERED, Tag=10386
[40645] (12/03 00:11:03.966):{0xC88} [BIPPa] Failed to find user for received status, UserId=21, Tag=10386
[30045] (12/03 00:11:03.966):{0x1B2C} Stopping handheld for Dr. H* K*
[40747] (12/03 00:11:03.982):{0x1B2C} License total: 5, used = 3, free = 2
[30000] (12/03 00:11:03.982):{0x1748} {d**@d****-*.com} Sending data to Dispatcher, size=23, Tag=10387
[40000] (12/03 00:11:03.982):{0x1748} {d**@d****-*.com} SendToDispatcher, Tag=10387
[30070] (12/03 00:11:03.982):{0x1748} User d**@d****-*.com shutting down...
[40000] (12/03 00:11:03.982):{0xC8C} [BIPP] Send data, Tag=10387
[40000] (12/03 00:11:03.982):{0xC88} [BIPP] Received status DELIVERED, Tag=10387
[40645] (12/03 00:11:03.982):{0xC88} [BIPPa] Failed to find user for received status, UserId=19, Tag=10387
[45050] (12/03 00:11:04.029):{0xC7C} DBNS: DbObject=200
[40205] (12/03 00:11:04.482):{0x1B2C} MailboxManager::CloseMailboxSession - closing session
[30000] (12/03 00:11:04.482):{0x1748} [DIAG] EVENT=Unregister_thread, THREADID=0x1748, THREADNAME="UserWorkerThread<S006>"
[30000] (12/03 00:11:04.482):{0xC00} [DIAG] EVENT=Unregister_thread, THREADID=0xC00, THREADNAME="UserWorkerThread<S006>"
[30217] (12/03 00:11:04.482):{0x1B2C} Restarting account for Dr. H* Kr*...
[40153] (12/03 00:11:04.513):{0xC78} PMDatabase::OpenNamedFolder: opening existing folder 'BlackBerryHandheldInfo'
[40155] (12/03 00:11:04.513):{0xC78} PMDatabase::OpenNamedFolder: opened an existing folder 'BlackBerryHandheldInfo'
[40419] (12/03 00:11:04.529):{0xC78} Worker thread 0x15A0 added to thread pool for session 0x013525f0 (S006)
[30000] (12/03 00:11:04.529):{0x15A0} [DIAG] EVENT=Register_thread, THREADID=0x15A0, THREADNAME="UserWorkerThread<S006>"
[40747] (12/03 00:11:04.560):{0xC78} License total: 5, used = 3, free = 2
[30041] (12/03 00:11:04.560):{0xC78} Starting handheld for Dr. H* K*
[40704] (12/03 00:11:04.560):{0xC78} MAPIMailbox::MAPIMailbox(2) ServerDN=/o=DHAG/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=S006/cn=Microsoft Private MDB, MailboxDN=/o=DHAG/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=d**k
[40739] (12/03 00:11:04.575):{0xC78} MAPIMailbox::MAPIMailbox(2) - ResolveName[1] success for DisplayName='/o=DHAG/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=d**k'
[40430] (12/03 00:11:04.591):{0xC78} {d**@d****-*.com} MAPIMailbox::MAPIMailbox(2) - Mailbox opened on session 0x013525f0 (S006)
[40153] (12/03 00:11:04.669):{0xC78} PMDatabase::OpenNamedFolder: opening existing folder 'BlackBerryHandheldInfo'
[40155] (12/03 00:11:04.669):{0xC78} PMDatabase::OpenNamedFolder: opened an existing folder 'BlackBerryHandheldInfo'
[40419] (12/03 00:11:04.700):{0xC78} Worker thread 0x1FFC added to thread pool for session 0x013525f0 (S006)
[30068] (12/03 00:11:04.700):{0xC78} User d**@d****-*.com starting up...
[30000] (12/03 00:11:04.700):{0x1FFC} [DIAG] EVENT=Register_thread, THREADID=0x1FFC, THREADNAME="UserWorkerThread<S006>"
[30069] (12/03 00:11:04.700):{0xC78} {d**@d****-*.com} Mailbox name is drhk
[40221] (12/03 00:11:04.700):{0xC78} {d**@d****-*.com} In Cradle timer is 740000
[40747] (12/03 00:11:04.716):{0xC78} License total: 5, used = 3, free = 2
[30362] (12/03 00:11:04.716):{0xC78} This agent will handle 3 user(s)

Last edited by snoll : 12-03-2007 at 07:57 AM.
Offline  
Old 12-03-2007, 08:00 AM   #18 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

S005.dhagnet.local and S004.dhagnet.local are your domain controllers? Are either an Exchange server or run any other services?
Offline  
Old 12-03-2007, 08:05 AM   #19 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I know this KB article doesn't apply to the specific version you're running, but perhaps you've found a bug ... try this out: KB04772 - Mailbox move repeatedly detected in the BlackBerry Messaging Agent log

Do you have anything constantly updating attributes in active directory?
Offline  
Old 12-03-2007, 08:20 AM   #20 (permalink)
New Member
 
Join Date: Aug 2007
Model: 8300
PIN: N/A
Carrier: T-Mobile
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

First thank you for your help.

We got 2 domaincontrolles, one BES, one Exchangeserver.

I am no AD-Expert. Please tell me what can ad make change attributes.


The kb-article I alreade knew, but it does not solve our problem.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.