BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 08-23-2007, 06:02 PM   #1 (permalink)
tam
New Member
 
Join Date: Feb 2005
Location: UK
Model: 8100
Carrier: voda
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Question BES and LiveMessenger + Java question

Please Login to Remove!

Hi all,

I have around 35 users all running on a BES on a windows 2003 network.

We currently have a single BES running 4.0.7.8

Some of our users are wanting to use MSN messenger a.k.a windows livemessenger

They has pointed me at http://www.blackberry.com/livemessenger however it doesnt appear to be able to be installed on any of the 8100 pearl devices we currently have (o.s. 4.2.1.94)

We get the following error message.
Quote:
HTTP Status 500 - type Exception reportmessagedescription The server encountered an internal error () that prevented it from fulfilling this request.exceptionjavax.servlet.ServletException
org.apache.struts.action.RequestProcessor.processE xception(RequestProcessor.java:535)
org.apache.struts.action.RequestProcessor.processA ctionPerform(RequestProcessor.java:433)
org.apache.struts.action.RequestProcessor.process( RequestProcessor.java:236)
org.apache.struts.action.ActionServlet.process(Act ionServlet.java:1196)
org.apache.struts.action.ActionServlet.doPost(Acti onServlet.java:432)
javax.servlet.http.HttpServlet.service(HttpServlet .java:717)
javax.servlet.http.HttpServlet.service(HttpServlet .java:810)
org.jboss.web.tomcat.filters.ReplyHeaderFilter.doF ilter(ReplyHeaderFilter.java:81)
root causejava.lang.NullPointerException
note The full stack trace of the root cause is available in the Apache Tomcat/5.5 logs.Apache Tomcat/5.5

Now the question is, what's creating that error? The blackberry web-site, the BES that they use to browse the internet through, or the 8100 device themselves?

Any help on this matter would be appreciated, even if its only to point me in roughly the right direction! I've seen service books mentioned as well as OTA installations via the bes??? (I've searched lots but not found anything that matches my issue!)

This is using Vodafone UK as the provider btw .


----------------------

On a separate note (I've not searched as I've just thought about it while typing this! - if its easy fix ignore me and I'll find it in a search!), what Java software version should we be running on our BES, originally it was installed for us and Java 1.4.2_08 was installed.

We've updated the Java to the latest version (1.6.0.20), which appeared to do no damage, however when we upgraded to the latest service pack (8??) the BES no longer worked. The fix was to go back to point the blackberry mobile data service back to the original Java install

Startup command we are currently using in the service startup
Quote:
"C:\Program Files\Research In Motion\BlackBerry Enterprise Server\MDS\bin\bmds.exe" -s jvmpath="C:\Program Files\Java\j2re1.4.2_08\bin\client\jvm.dll" -XX:+DisableExplicitGC -Xss64K -Xmx256M -Xms96M -XX:NewSize=32M -XX:MaxNewSize=96M -XX:NewRatio=2 classpathdir="C:\Program Files\Research In Motion\BlackBerry Enterprise Server\MDS\classpath\\" wrkdir="C:\Program Files\Research In Motion\BlackBerry Enterprise Server\MDS\Servers\XXXX-BES1\\" webserverdir="C:\Program Files\Research In Motion\BlackBerry Enterprise Server\MDS\webserver\\" -log.console -rbes "XXXX-BES1"

Thanks to anyone who replies!

Last edited by tam : 08-23-2007 at 06:03 PM.
Offline  
Old 08-24-2007, 05:31 PM   #2 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

1) First thing you should do is disable the devil-spawn updater that is a part of the Java install. It only does bad things and never does good; never, ever.

2) The error 500 is what your BES is returning if you're using the MDS / BlackBerry Browser. What happens if you try your carrier / Internet Browser on the HH?

Can you load up that page with IE on the BES itself? It should give you a lame notice about you can't get the install from here; but regardless it should load.
Offline  
Old 10-09-2007, 11:29 AM   #3 (permalink)
tam
New Member
 
Join Date: Feb 2005
Location: UK
Model: 8100
Carrier: voda
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by hdawg View Post
1) First thing you should do is disable the devil-spawn updater that is a part of the Java install. It only does bad things and never does good; never, ever.
Devil spawn disabled

Quote:
2) The error 500 is what your BES is returning if you're using the MDS / BlackBerry Browser. What happens if you try your carrier / Internet Browser on the HH?
The vodafone live browser gives me an active x error same as if you visited the site in firefox from your pc. As does the opera mini browser.

Quote:
Can you load up that page with IE on the BES itself? It should give you a lame notice about you can't get the install from here; but regardless it should load.
Yep, page loads fine, but tells me i should use mobile device for that page.


Thanks for your help, sorry for the delay responding, i'd planned to have enough time to work on this before i went off to get married, but then all hell broke out at work and i had to put this on the back burner... however i'm back now and would love to get this working!

regards,

Last edited by tam : 10-09-2007 at 11:32 AM.
Offline  
Old 10-10-2007, 07:54 AM   #4 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

This stinks ... I didn't realize it was as cut and dry as this:

BlackBerry devices supporting Windows Live Messenger
Offline  
Old 10-12-2007, 04:38 AM   #5 (permalink)
tam
New Member
 
Join Date: Feb 2005
Location: UK
Model: 8100
Carrier: voda
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Damn ... :(

Never even thought that there wouldn't be support for it..

Thanks for your help, its very much appreciated.

Regards,
Offline  
Old 06-23-2008, 06:09 PM   #6 (permalink)
New Member
 
Join Date: Jun 2008
Model: 8320
PIN: N/A
Carrier: Vodafone UK
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hey,

I am aslo on Vodafone UK and managed to get a US BB which has MSN installed already. When I open MSN it tells me that handheld does not have the required sevice books and asks me to visit the blackberry.com/livemessenger website. But the link does not help either
Anyone know how to fix this? Please let me know what to do...

Any help is very appreciated and thank you very much in advance!
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.