BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 05-30-2005, 04:15 AM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2005
Model: 7290
Carrier: vodafone
Posts: 22
Post Thanks: 0
Thanked 1 Time in 1 Post
Post Emailing to external addresses

Please Login to Remove!

Hi All I was wondering if anybody else has experienced anything like this. I am experiencing issues with sending emails to external contacts via my blackberry (I can email them via lotus notes without any issue). The emails simply bounce back with a SMTP error 24 hours later (Failed to connect to SMTP host ROGERS.BLACKBERRY.NET because 221 2.0.0 mx05.bwc.na.blackberry.net closing connection).

Now I can email to other external contacts fine, I have a few web mail accounts as well and I can send emails to them ok as well. But I do have two pop3 accounts that I am having this problem with as well. They also have similar errors when a email is sent to them (Failed to connect to SMTP host ORANGE.NET because : SMTP Protocol Returned a Transient Error)

That one does concern me though as my service provider is orange and I doubt there would be any reason why they would block access to themselves. I have tried contacting orange, they have been very friendly but alas so far they are unable to help me resolve this problem.

If anybody has experienced anything like this could you please let me know.

Thanks

Paul
Offline  
Old 05-30-2005, 07:52 AM   #2 (permalink)
dev
CrackBerry Addict
 
dev's Avatar
 
Join Date: Apr 2005
Location: Toronto
Model: 8800
Carrier: Rogers
Posts: 571
Post Thanks: 0
Thanked 2 Times in 2 Posts
Default

Have you tried to SMTP to that server on port 25? This would indicate if the server is listening (as it should) on port 25.
Other possibilities (some of these I have experienced in BES2.2 versions...may not be the same here)..
1. Does your contact list on the device have two addresses for the same contact an smtp address and notes address? I have found senders with more than one address for a receipient received mail router errors. I haven't seen this in BES4.0 as yet though.
2. Check your router service logs for the BEs server and see if there are any address resolution errors. Some receiving MX servers do reverse lookups on the sender and if unable to resolve, simply drop the connection.
Have you been able to send to this receipient from your device before?
A good tool to check smtp connections/DNS issues is SMTPDiag...this can be found on Microsoft's site. Place the *.exe in any designated directory and run the tool from that dir at a comman prompt. It's fairly intuitive to figure out.
Offline  
Old 05-30-2005, 08:26 AM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2005
Model: 7290
Carrier: vodafone
Posts: 22
Post Thanks: 0
Thanked 1 Time in 1 Post
Default

Thanks dev I gave smtpdiag a go to the address but it passed straight through without any errors (checked it a couple of times to be sure). BES logs didn't seem to come up with anything relevent but I got this from the domino log when i sent a message:


30/05/2005 14:07:31 Router: No messages transferred to ROGERS.BLACKBERRY.NET (host mx07.bwc.na.BLACKBERRY.NET) via SMTP: SMTP Protocol Returned a Permanent Error
30/05/2005 14:07:32 Router: No messages transferred to ROGERS.BLACKBERRY.NET (host mx08.bwc.na.BLACKBERRY.NET) via SMTP: SMTP Protocol Returned a Permanent Error
30/05/2005 14:07:33 Router: No messages transferred to ROGERS.BLACKBERRY.NET (host mx05.bwc.na.BLACKBERRY.NET) via SMTP: SMTP Protocol Returned a Permanent Error
30/05/2005 14:07:34 Router: No messages transferred to ROGERS.BLACKBERRY.NET (host mx03.bwc.na.BLACKBERRY.NET) via SMTP: SMTP Protocol Returned a Permanent Error
30/05/2005 14:07:36 Router: No messages transferred to ROGERS.BLACKBERRY.NET (host mx06.bwc.na.BLACKBERRY.NET) via SMTP: SMTP Protocol Returned a Permanent Error
30/05/2005 14:07:37 Router: No messages transferred to ROGERS.BLACKBERRY.NET (host mx04.bwc.na.BLACKBERRY.NET) via SMTP: SMTP Protocol Returned a Permanent Error
30/05/2005 14:07:38 Router: No messages transferred to ROGERS.BLACKBERRY.NET (host mx02.bwc.na.BLACKBERRY.NET) via SMTP: SMTP Protocol Returned a Permanent Error
30/05/2005 14:07:39 Router: No messages transferred to ROGERS.BLACKBERRY.NET (host mx01.bwc.na.BLACKBERRY.NET) via SMTP: SMTP Protocol Returned a Permanent Error

I have never had to send any emails to this address from my blackberry before (always did it from lotus). But its the only address I have for this person in my contact details.
Offline  
Old 05-30-2005, 08:37 AM   #4 (permalink)
dev
CrackBerry Addict
 
dev's Avatar
 
Join Date: Apr 2005
Location: Toronto
Model: 8800
Carrier: Rogers
Posts: 571
Post Thanks: 0
Thanked 2 Times in 2 Posts
Default

Do you have entries in your SMTP outbound relay section in the server doc?
Offline  
Old 05-30-2005, 09:17 AM   #5 (permalink)
dev
CrackBerry Addict
 
dev's Avatar
 
Join Date: Apr 2005
Location: Toronto
Model: 8800
Carrier: Rogers
Posts: 571
Post Thanks: 0
Thanked 2 Times in 2 Posts
Default

I'm kinda stomped here....
Ok...what version of Domino is the BES running on?
Make sure there are not rep conflicts in the server doc on the BES server
Were you able to smtp to that server address from the BES?
Offline  
Old 05-30-2005, 09:24 AM   #6 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2005
Model: 7290
Carrier: vodafone
Posts: 22
Post Thanks: 0
Thanked 1 Time in 1 Post
Default

Do you meen for the BES or my email server? my mail server certainly does have these addresses. The BES settings I will need to check when I get back to the office.
Offline  
Old 05-30-2005, 09:26 AM   #7 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2005
Model: 7290
Carrier: vodafone
Posts: 22
Post Thanks: 0
Thanked 1 Time in 1 Post
Default

6.0.3 on the BES and 6.5.3 on my Email server. Yes I ran the smtp software from the BES and it completed ok.
Offline  
Old 09-15-2006, 01:18 PM   #8 (permalink)
Talking BlackBerry Encyclopedia
 
ZeroKool's Avatar
 
Join Date: Aug 2006
Location: stl, MO
Model: 8330
PIN: nope
Carrier: verizon
Posts: 314
Post Thanks: 2
Thanked 0 Times in 0 Posts
Default

pauu and dev

Did you all ever find any solution to this problem. One of my users is having this problem as well. Its seems to give him this error for ALL outside emails.

EXAMPLE 1:
Your message: Update
was not delivered to: "john doe" <jdoe@us.ibm.com>
because: Router: Failed to connect to SMTP host US.IBM.COM because 221 2.0.0 e34.co.us.ibm.com closing connection:

EXAMPLE 2:
Your message: Update
was not delivered to: "john doe" <johndoe@sbcglobal.net>
because: Router: Failed to connect to SMTP host SBCGLOBAL.NET because 221 2.0.0 ylpvm34.prodigy.net closing connection:

BES 4.1.0.38 / Domino 6.5.4


**EDIT**
I talked to pauuu, and he had given up on the matter. NO SOLUTION. I am just going build new server and move user over to new BES. We will see what happens...

**UPDATE**
Moved the user, and so far so good. He can send external messages and everything. Had him wipe the handheld. Kinda dumb.
__________________
Me likey BlackBerry

Last edited by ZeroKool : 09-23-2006 at 03:35 PM.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.