BlackBerry Forums Support Community

BlackBerry Forums Support Community (
-   BES Admin Corner (
-   -   BES manager "unable to locate server" (

colinb 06-02-2005 06:48 AM

FIXED>>>>>BES manager "unable to locate server"
Hi folks:

I have just had a BES 2.2.3 for Lotus domino running on W2K sp4 stop sending mail, when i try to connect thru the server manager, i get "unable to locate server" has anyone else seen this before? Have tried restarting BES, rebooting of course and the usual stuff.

Can't seem to find much info??


Colin Brown

See last post for resolution

dev 06-02-2005 07:30 AM

Have you restarted the BES more than twice so far? If so the service may have been disconnected at RIM. This is a security precaution in the event someone impersonates your BES. The RIM network will not allow two instances of the service to run. You can check the notes log or view the domino console for any errors related to failed connection to SRP host. However that would not prevent you from connecting thru the BM.
Go to your admin wrkstn and from a cmd prompt at the "Notes" dir where the executables are the following test "NDCTEST". This will determine if the "client" wrkstn can connect via NRPC. Just follow the prompts. You'll be asked for the sever name....use the full heirarchical name and you'll be prompted for a password...use you notes password. If that fails you have an issue within your DNN.

colinb 06-02-2005 08:08 AM


Thanks for the response, connection to srp is good , ran the test, as I watch the bes start after it initializes the users it also shows a connection to srp. Our DNN looks fine as I can route mail to the BES Admin account from our other Domino servers, I just can't get mail flowing thru BES. Thanks for the pointer to the NDCTEST , useful little program and it shows a good connection.

have a Tsupport call in, and fingers crossed..


dev 06-02-2005 08:22 AM

Have a look at the BlackBerryOutbox queue and see if you have users with high pending can also see this from the domino console as well.
I'll assume you have added the BES to the "LocalDomainServers" group and all that other "good stuff" they describe in the install guide?
Try running a trace on the mail server(s) from the BES domino console.
Example....trace server1/OU/O.....also do a "sh us debug"....without the quotes. This will show if there are any TCP connections to the BES server from user(s) wrkstns.

colinb 06-02-2005 08:37 AM

Hmmm, just gets better, no high pending messages for users, actually I have been running BES for 4 years plus, so I am stumped on this episode.. trace works out fine, and sh us debu lists about 10 users connected, still no go..

dev 06-02-2005 08:53 AM that's interesting and odd behaviour...
Have there been any changes to your AV/SPAM SW or filters? Have you changed the polling interval from the 20sec default?
I assume when you said "stop sending" mail you mean that users have not been receiving messages on their BB devices and BB devices are not able to send to receipients?
Are there any error messages generated anywhere?

colinb 06-02-2005 09:11 AM

I am just doing a reboot with the AV disabled, haven't changed any polling intervals, you assume correct... no bberry device can send / recv .... and best of all not seeing any errors generated except for the good old big red X beside the messages on the units!!


colinb 06-02-2005 09:24 AM

guess what... after a reboot with Virusscan enterprise 7.1.0 dat file 4504 scan engine 4.4.00, now I can connect to the BES thru the server manager, the server is queing and processing all sorts of mail, still not delivering any, but that might take a bit of time. I am going to let it go for a bit, then I am going to set the av back and reboot again to see if it screws up..

Good old NAI..


dev 06-02-2005 09:27 AM

Just to be double-sure call RIM and have them determine if your BES is still showing as being connected to their NOC. Have them verify that with you on the phone....they can be slippery sometimes. They will have to ask the guys in OPS to check. This type of behaviour seems to indicate a) You are not connected to the RIM infrastructure
b)Your multiple restarts may have resulted in a "phantom" service being present. This occurs when the domino server services have not all disconnected properly on shhutdown. The task manager does not indicate all the domino services that's running. There's ~12-18 domino services that's associated with the domino server.
c) I would do an UPDALL, FIXUP, COMPACT on the outbox queue db and the profiles db.

colinb 06-02-2005 09:52 AM

gets even better, an odd message is sqeaking thru as delivered.. RIM is on the phone checking now. ran the utilities you mentioned earlier. noticing a few errors referencing design in the last log. maybe it can't recognize the user inboxes?? I will check with RIM to see about a load design or replace design from the command line..

colinb 06-02-2005 09:55 AM

have you ever seen "will not refresh BBSD design for users......?

dev 06-02-2005 10:59 AM

Yes....That's the users' BlackBerryState db it's refering to....Have you done the replace design on the OutBox db when you upgraded to BES2.2? Or was this a fresh install?
Either way you could try a compact from the domino console on the all BES dbs. A bit of work but that would clear up any "white spaces" in the db views.

colinb 06-02-2005 11:01 AM

woo hoo
ran fixup, nupdall, ncompact on the BBDS.ntf, rebooted and it's humming again..

Thanks for all your help..


All times are GMT -5. The time now is 08:27 AM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.