BlackBerry Forums Support Community
              

Closed Thread
 
LinkBack Thread Tools
Old 10-08-2007, 12:00 PM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Oct 2007
Model: 8300
PIN: N/A
Carrier: Orange
Posts: 17
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Users can receive but not send emails, errors in event log

Please Login to Remove!

I have a new BES install which seems to be working fine as I can activate handsets and users can receive emails. However when trying to send emails users get failed error messages and I get event log errors:

{user@tld.com} Send() failed: ERR_SUBMIT_MAIL, Tag=327

I'm not sure what this error message refers to or what it means. Any help would be appreciated.

Thanks and regards

Gordon Copestake
Offline  
Old 10-08-2007, 12:14 PM   #2 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Smells like Send As permissions aren't set within AD: Unable to send messages because the Send As permission has been revoked

Are you using Exchange?
Offline  
Old 10-08-2007, 12:54 PM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: Oct 2007
Model: 8300
PIN: N/A
Carrier: Orange
Posts: 17
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by hdawg View Post
Smells like Send As permissions aren't set within AD: Unable to send messages because the Send As permission has been revoked

Are you using Exchange?
Yes exchange 2003, but i'm 95% sure that the user (BESADMIN) has send as permissions set correctly. I'll double check though.

It's possible that a service pack or hotfix has been applied though that I dont know about, thanks for the article, i'll double check.

Last edited by GordonCopestake : 10-08-2007 at 12:58 PM.
Offline  
Old 10-09-2007, 02:12 AM   #4 (permalink)
Knows Where the Search Button Is
 
Join Date: Oct 2007
Model: 8300
PIN: N/A
Carrier: Orange
Posts: 17
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

OK, it looks like the BESADMIN user DOES have "Send As" permissions set, but we still get the "red cross" symptoms described in the article and a Message Status of "Desktop Email program unable to submit message". I'm not entirely certain what the "desktop email program" is, as we havn't rolled out any desktop software, just the BES and the handhelds.

Anyone else got any thoughts? It would be appreciated.

Last edited by GordonCopestake : 10-09-2007 at 03:01 AM.
Offline  
Old 10-09-2007, 04:20 AM   #5 (permalink)
Kul
Talking BlackBerry Encyclopedia
 
Kul's Avatar
 
Join Date: May 2005
Location: London, England.
Model: Z10
Carrier: Vodafone (UK)
Posts: 467
Post Thanks: 21
Thanked 3 Times in 3 Posts
Default

I had this similar issue last week, and all permissions were fine etc. Bounced the server and everything started working fine.
Offline  
Old 10-09-2007, 05:21 AM   #6 (permalink)
Knows Where the Search Button Is
 
Join Date: Oct 2007
Model: 8300
PIN: N/A
Carrier: Orange
Posts: 17
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Kul View Post
I had this similar issue last week, and all permissions were fine etc. Bounced the server and everything started working fine.
Apologies, but by bounce do you mean reboot? I've rebooted the server and we get the same issue :(

Last edited by GordonCopestake : 10-09-2007 at 06:26 AM.
Offline  
Old 10-09-2007, 05:53 AM   #7 (permalink)
Kul
Talking BlackBerry Encyclopedia
 
Kul's Avatar
 
Join Date: May 2005
Location: London, England.
Model: Z10
Carrier: Vodafone (UK)
Posts: 467
Post Thanks: 21
Thanked 3 Times in 3 Posts
Default

Are you able to check all the validations i.e SRP validation, EMAIL profile , Database etc. successfully ?
Offline  
Old 10-09-2007, 06:03 AM   #8 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

What version of BES (and service pack) are you running? Are the users that are experiencing this problem members of any special groups? ... Administration accounts in protected Active Directory groups
Offline  
Old 10-09-2007, 06:27 AM   #9 (permalink)
Knows Where the Search Button Is
 
Join Date: Oct 2007
Model: 8300
PIN: N/A
Carrier: Orange
Posts: 17
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Kul View Post
Are you able to check all the validations i.e SRP validation, EMAIL profile , Database etc. successfully ?
Sorry, i'm new at this, how do i check the validations?
Offline  
Old 10-09-2007, 06:30 AM   #10 (permalink)
Knows Where the Search Button Is
 
Join Date: Oct 2007
Model: 8300
PIN: N/A
Carrier: Orange
Posts: 17
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by hdawg View Post
What version of BES (and service pack) are you running? Are the users that are experiencing this problem members of any special groups? ... Administration accounts in protected Active Directory groups
I'm running BES 4.1.4.12. I dont believe there is a service pack installed. The users experiencing the problem are only members of "Domain Users". As far as i can tell it's all users but we only have a handful.
Offline  
Old 10-09-2007, 06:34 AM   #11 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

4.1.4.12 is BES 4.1 Service Pack 4; is there any data in the ALRT log files on the server that you can post?

Have you applied any Exchange patches recently?
Offline  
Old 10-09-2007, 06:37 AM   #12 (permalink)
Knows Where the Search Button Is
 
Join Date: Oct 2007
Model: 8300
PIN: N/A
Carrier: Orange
Posts: 17
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by hdawg View Post
4.1.4.12 is BES 4.1 Service Pack 4; is there any data in the ALRT log files on the server that you can post?

Have you applied any Exchange patches recently?
My ALRT log has these error messages:

Code:
[30000] (10/09 12:13:28.274):{0x760} [Alarm::ActivateAlarm] Queuing alarm: <N/A> | BlackBerry Messaging Agent BES Agent 1 (Application Event Log on BES) | 10/09/2007 12:13:21  (AFFF4E43) -> {<user>} CDOCalendar::GetRIMMeetingResp - Exception handled
[30000] (10/09 12:13:28.274):{0x760} [Alarm::ActivateAlarm] Queuing alarm: <N/A> | BlackBerry Messaging Agent BES Agent 1 (Application Event Log on BES) | 10/09/2007 12:13:21  (AFFF4E20) -> {<user>@domain.com} GetRIMMeetingResp Failed for LongTermEntryId=9845 in LaunchCalHelperAndGetResults
[30000] (10/09 12:13:28.274):{0x748} Alarm::ThreadProc: Received an alarm message
[30000] (10/09 12:13:28.274):{0x748} Alarm::ThreadProc: Received an alarm message
[30000] (10/09 12:13:28.274):{0x748} Alarm::ThreadProc: Received an alarm message
[30000] (10/09 12:22:20.384):{0x760} EventLog::ThreadProc: Received notification, processing...
[30000] (10/09 12:22:20.384):{0x760} [Alarm::ActivateAlarm] Queuing alarm: <N/A> | BlackBerry Messaging Agent BES Agent 1 (Application Event Log on BES) | 10/09/2007 12:22:20  (AFFF4E43) -> {<user>} CDOCalendar::~CDOCalendar() - Exception handled
[30000] (10/09 12:22:20.384):{0x748} Alarm::ThreadProc: Received an alarm message
[30000] (10/09 12:31:54.478):{0x760} EventLog::ThreadProc: Received notification, processing...
[30000] (10/09 12:31:59.494):{0x760} EventLog::ThreadProc: Received notification, processing...
[30000] (10/09 12:32:57.805):{0x760} EventLog::ThreadProc: Received notification, processing...
[30000] (10/09 12:33:53.788):{0x760} EventLog::ThreadProc: Received notification, processing...
[30000] (10/09 12:33:53.788):{0x760} [Alarm::ActivateAlarm] Queuing alarm: <N/A> | BlackBerry Messaging Agent BES Agent 1 (Application Event Log on BES) | 10/09/2007 12:33:53  (AFFF4F29) -> {<user>@domain.com} MAPIMailbox::Send(ppMAPIMessage) - SubmitMessage (0x80070005) failed
[30000] (10/09 12:33:53.788):{0x748} Alarm::ThreadProc: Received an alarm message
[30000] (10/09 12:34:01.491):{0x760} EventLog::ThreadProc: Received notification, processing...
[30000] (10/09 12:34:01.491):{0x760} [Alarm::ActivateAlarm] Queuing alarm: <N/A> | BlackBerry Messaging Agent BES Agent 1 (Application Event Log on BES) | 10/09/2007 12:33:54  (AFFF4E20) -> {<user>@domain.com} Send() failed: ERR_SUBMIT_MAIL, Tag=612
[30000] (10/09 12:34:01.491):{0x748} Alarm::ThreadProc: Received an alarm message
I've removed the valid emails BTW

Our exchange server hasn't had any patches recently that would affect BES to my knowledge.
Offline  
Old 10-09-2007, 06:41 AM   #13 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Try these ... Desktop email program unable to store message

Still seems like permissions; hmmn.
Offline  
Old 10-09-2007, 06:44 AM   #14 (permalink)
Knows Where the Search Button Is
 
Join Date: Oct 2007
Model: 8300
PIN: N/A
Carrier: Orange
Posts: 17
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by hdawg View Post
Try these ... Desktop email program unable to store message

Still seems like permissions; hmmn.
Thanks for the tips, i'll go through them now. I'm not sure what the "desktop email program" refers to as the devices have never been connected to a PC and we havn't even opened the desktop software CD's. We just have the BES and the devices. As the devices can recieve email fine we are sure there is connectivity between the BES and the exchange server. We have checked and double checked that the service account has the correct permissions (send as) and all seems ok.
Offline  
Old 10-09-2007, 06:48 AM   #15 (permalink)
Thumbs Must Hurt
 
guruleenyc's Avatar
 
Join Date: Oct 2006
Location: nYc & CT
Model: 8820
Carrier: AT&T/Sprint/Nextel
Posts: 186
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Wirelessly posted (NXTL7520: BlackBerry8800/4.2.1 Profile/MIDP-2.0 Configuration/CLDC-1.1 VendorID/102)

I have this problem too and followed all the documented steps, but to no avail...

Help!
__________________
BES Admin/Nextel 60x 7520's/10x AT&T 8800's/2x BES

"Knowledge breeds confidence and confidence breeds success"
Offline  
Old 10-09-2007, 06:52 AM   #16 (permalink)
Thumbs Must Hurt
 
guruleenyc's Avatar
 
Join Date: Oct 2006
Location: nYc & CT
Model: 8820
Carrier: AT&T/Sprint/Nextel
Posts: 186
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Wirelessly posted (NXTL7520: BlackBerry8800/4.2.1 Profile/MIDP-2.0 Configuration/CLDC-1.1 VendorID/102)

I have this problem too and followed all the documented steps, but to no avail...

Help!
__________________
BES Admin/Nextel 60x 7520's/10x AT&T 8800's/2x BES

"Knowledge breeds confidence and confidence breeds success"
Offline  
Old 10-09-2007, 06:59 AM   #17 (permalink)
Knows Where the Search Button Is
 
Join Date: Oct 2007
Model: 8300
PIN: N/A
Carrier: Orange
Posts: 17
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by guruleenyc View Post
Wirelessly posted (NXTL7520: BlackBerry8800/4.2.1 Profile/MIDP-2.0 Configuration/CLDC-1.1 VendorID/102)

I have this problem too and followed all the documented steps, but to no avail...

Help!
Try this article: Desktop email program was unable to submit an email message

If this doesn't resolve your issue I would surgest creating a new thread as it's likely to get more notice than piggybacking this one.
Offline  
Old 10-09-2007, 07:11 AM   #18 (permalink)
BlackBerry Genius
 
hdawg's Avatar
 
Join Date: Aug 2006
Model: hdawg
PIN: port3101.org
Carrier: hdawg
Posts: 6,632
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

and all of these are set too? Microsoft Exchange and Windows permissions required to install BlackBerry Enterprise Server ... Assigning permissions for the BlackBerry Enterprise Server administration account

Have you ever been able to send from HandHelds?
Offline  
Old 10-09-2007, 07:17 AM   #19 (permalink)
Knows Where the Search Button Is
 
Join Date: Oct 2007
Model: 8300
PIN: N/A
Carrier: Orange
Posts: 17
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by hdawg View Post
Yes, these are all set correctly (just checked). We had a Blackberry Evaluation and some handhelds which worked perfectly (both send and receive).

We have since purchased the software and some new handhelds which is the install I am trying to get working now. We have installed a new (physical) server and new handhelds. These new handhelds (actually the same model as the eval's) can receive but not send emails. I have removed the users from the evaluation BES and deleted all the blackberry information from the mail box, then added the users to the new server. At first i thought that this was the issue, but after adding users who have NEVER been added to the BES before we get the same problem. I have used the same service account (BESADMIN) which is why I know that it's not a permissions problem as it worked perfectly with the evaluation. All I can think is that it must be an issue with the server install.

Any thoughts you might have would be appreciated.
Offline  
Old 10-09-2007, 08:26 AM   #20 (permalink)
CrackBerry Addict
 
mahoward's Avatar
 
Join Date: May 2005
Model: 8900
Carrier: T-Mobile
Posts: 560
Post Thanks: 0
Thanked 1 Time in 1 Post
Default

Install Desktop Manager (or just the BB device manager piece) on a PC, run BB device manager then hook up a BB with this issue to the PC via usb. Enter the password if you have one on the device. Can you send messages then? Doing this test avoids all the wireless infrastructure so takes that out of the equation.

If you do still see a red X what is the error? It may be different now.

Also look at the DISP logs for the same time to see what the BES had to say about this failed transaction.
__________________
BESX 4.1.7 on Exchange 2003: 65 Devices
BESX 5.0.3 on Exchange 2003: 2007 Devices
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

VINTAGE STAPLER
$4.5
VINTAGE STAPLER pictureL16: Vintage Bausch & Lomb Microscope Stand
$489.99
L16: Vintage Bausch & Lomb Microscope Stand pictureL15: Vintage Bausch & Lomb Microscope - Read Description
$689.99
L15: Vintage Bausch & Lomb Microscope - Read Description pictureVintage 1978 Agway Farm Systems Catalog
$15.99
Vintage 1978 Agway Farm Systems Catalog pictureVintage Nippon Conlux Dollar Bill Validator Acceptor Vending Machine Parts Only
$35.0
Vintage Nippon Conlux Dollar Bill Validator Acceptor Vending Machine Parts Only picture






Copyright 2004-2016 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.