BlackBerry Forums Support Community               

Reply
 
LinkBack Thread Tools
Old 06-20-2008, 10:16 AM   #61 (permalink)
Knows Where the Search Button Is
 
wazdat1's Avatar
 
Join Date: Apr 2006
Model: 9810
OS: 7.1.0.284
Carrier: AT&T
Posts: 26
Post Thanks: 0
Thanked 5 Times in 2 Posts
Talking Success!

Please Login to Remove!

I've been wrestling with the BES policy issue like everyone else. Google Maps hangs at 90% while asking permission to access the Radio and GPS.

Here's how I got around it. I had already backed up my 8310 before installing OS 4.5.0.37 from Vodafone.de. I used JL Cmdr to "restoretofactory" which removes all of the BES policies. I then installed Google Maps 2.0.2 and gave it permission to access the radio and GPS (several times). Tested it to make sure it was operational. Then opened Desktop manager and connected the BB to restore my data. The Enterprise Activation started on its own and I was prompted to set password, etc. which told me the IT policy had been restored.

Voila! (But what a pain in the a$$!)

I tried these same steps with GM v2.2.0 and although GM would open and locate me, within a few seconds I would receive a message that stated, "Google Maps requires a data connection... blah, blah, blah" and then it wouldn't update the maps.

Doug
Offline   Reply With Quote
Old 06-23-2008, 11:38 PM   #62 (permalink)
Thumbs Must Hurt
 
Join Date: Jun 2008
Location: Texas
Model: 9700
PIN: N/A
Carrier: AT&T
Posts: 62
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by kmwbberry View Post
So putting all this together...use Spamdumpsters instructions at the top of the post. Uninstall BBMaps through desktop mgr. Delete the service book. Go to the Blackberry Maps download site. Look at the bottom for the link to "push" the file to your computer. Pick a old version. I picked 1.2. Go through the questions...your name, bla bla bla..and you can download to your computer.

Go to desktop mgr. When I clicked "add"...and browsed to the location where I saved the old version...I then went down in the app list and there were two. I deleted both....then added again so I would know there was only 1 in there pointing to the old version. Installed...and it works perfect.

Thanks to all that post to help and allow us to figure this s*** out.

I love getting one over on AT&T when they try to take stuff away.

Hackers forever.
That worked really well. I deleted the currently installed BBMaps before even adding the new one, and it worked just fine.

Here's the link to the BBMaps download page.

Now if I could just get a damn GPS signal indoors...
Offline   Reply With Quote
Old 06-24-2008, 12:07 AM   #63 (permalink)
Thumbs Must Hurt
 
myk.dinis's Avatar
 
Join Date: Aug 2007
Model: 8900
Carrier: AT&T - 8120/8310, Sprint - 8830
Posts: 133
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default OMFG! Worked like a champ!!

Absolutely spot on! The link worked, the steps all worked...I'm on AT&T and I haven't been able to use BB Maps. I can now!

Thanks again!

Myk

Quote:
Originally Posted by OrionXBeta View Post
Theres another easier way to get BBMaps to work.

1.) Download the BBMaps software from RIM, youll need to fill a user information page before the link. It doesnt have to be a real email address. ( Download )

2.) Run Apploader and remove any traces of BBMaps currently on your phone

3.) Extract Files to the OS directory and replace any duplicate files. Make sure you copy whichever ones its asking to replace beforehand as well just to be safe.

4.) Run the AppLoader application and choose the supplied ALX file and then continue the install.

Now I tried this and received the "no additional applications designed for your device" which Ive been getting for everything anyways. But I continued to the next page and the apploader already grabbed that ALX file because there were two Blackberry Maps options to choose from and install. I checked the details and chose the one that had all of the modules that were in the BBMaps ZIP file from RIM.

If you do what was listed above you will have BBMaps no matter what carrier or OS youre running.

Im currently running a Curve 8310 on AT&T with OS 4.5.0.37 with no issues

Enjoy
Offline   Reply With Quote
Old 06-24-2008, 04:50 PM   #64 (permalink)
fmp
Knows Where the Search Button Is
 
Join Date: Apr 2005
Location: Mountain View, CA
Model: 8900
OS: 4.6.1.250
Carrier: T-Mobile
Posts: 31
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

So, I follow all the steps to get the old version of BBMaps on the BB but can't a T-Mobile person export the service books (like they do for Yahoo Messenger) so we can use the new improved version of BBmaps?
Offline   Reply With Quote
Old 06-29-2008, 03:52 AM   #65 (permalink)
New Member
 
Join Date: Jun 2008
Model: 8310
PIN: N/A
Carrier: Rogers
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Spamdumpster View Post

1. Google Maps. The issue reported is that the application hangs after you give it permission to access the radio information. Eventually, the app times out, and it's never usable. I experienced this as well. The solution I found is to downgrade to 4.2.2, install and run google maps, make sure it works, and then upgrade to 4.5 and let BB manager back up all databases, etc. This carries the permissions over and will allow google maps to run.
so i downgrade to 4.2 and then run google maps and then make a backup and then upgrade to 4.5 and then restore the backup file??

im actually a BIS user and my gmaps freezes at 10%, ive set all the permissions to allow and ive done several batter pulls. any suggestions?

Last edited by UneeK : 06-29-2008 at 11:49 AM.
Offline   Reply With Quote
Old 07-04-2008, 02:18 PM   #66 (permalink)
New Member
 
Join Date: Jul 2007
Model: 8100
PIN: N/A
Carrier: Telcel
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Where did you find the 1.6.4 version?? Can't find it anywhere!!
Offline   Reply With Quote
Old 07-05-2008, 09:55 AM   #67 (permalink)
New Member
 
Join Date: May 2008
Model: 8700
PIN: N/A
Carrier: Orange
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default "Nav4All" - works with 4.5?

Hello - is the "Nav4All" working with soft. ver. 4.5?
Anybody tested?

D.
Offline   Reply With Quote
Old 07-08-2008, 08:55 AM   #68 (permalink)
Thumbs Must Hurt
 
BB Beast's Avatar
 
Join Date: Jul 2008
Location: New Jersey
Model: 8900
OS: 5.0.0.238
PIN: 210974bc
Carrier: AT&T/BIS
Posts: 77
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by myk.dinis View Post
Absolutely spot on! The link worked, the steps all worked...I'm on AT&T and I haven't been able to use BB Maps. I can now!

Thanks again!

Myk
Got it worken aswell.....

Last edited by BB Beast : 07-08-2008 at 09:12 AM.
Offline   Reply With Quote
Old 07-08-2008, 09:15 AM   #69 (permalink)
Thumbs Must Hurt
 
sjsilverman's Avatar
 
Join Date: May 2005
Model: 9700
Carrier: T-Mobile & China Mobile
Posts: 191
Post Thanks: 0
Thanked 1 Time in 1 Post
Default

I actually have a different problem. I can get Google Maps to fire up (4.5.0.46 on an 8320). BUT, the triangulation won't work, meaning, it won't find my location using the cell phone towers. I've upgraded to the latest version, but it just won't figure out where I am. Any thoughts?
Offline   Reply With Quote
Old 07-09-2008, 11:43 AM   #70 (permalink)
New Member
 
Join Date: May 2008
Model: 8310
PIN: N/A
Carrier: AT&T
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

After upgrading to OS 4.5, then removing the service book and BBMaps, moving the files over from the previous OS for BBMaps, it all works. Wasn't a quick fix, but thanks to all the great folks here in BBForums, it's working for me as well.
Offline   Reply With Quote
Old 07-09-2008, 12:14 PM   #71 (permalink)
New Member
 
Join Date: Jun 2008
Model: 8320
PIN: N/A
Carrier: telkomsel
Posts: 11
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

work me too
Offline   Reply With Quote
Old 07-09-2008, 04:19 PM   #72 (permalink)
Thumbs Must Hurt
 
bigme's Avatar
 
Join Date: Dec 2005
Location: Orlando, FL
Model: 9700
Carrier: AT&T
Posts: 170
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Does anyone has a valid service book for BB Maps? If would you be kind enough to post it for us? Thanks
__________________
7290->8300->9000>9700>9800>9700 Unlocked | AT&T BIS
Offline   Reply With Quote
Old 07-13-2008, 11:47 PM   #73 (permalink)
New Member
 
Join Date: Mar 2006
Model: 8820
Carrier: Rogers
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

It apears that if you are on BES, and have ANY software configuration assigned (even with no policy associated), Google Maps hangs. If the software configuration for the user is set to None, Google Maps works fine.

Anyone figure out how to get a software configuration to work with Google Maps?
Offline   Reply With Quote
Old 07-13-2008, 11:49 PM   #74 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,679
Post Thanks: 4
Thanked 96 Times in 71 Posts
Default

Wirelessly posted (BB 11020)

Offline   Reply With Quote
Old 07-14-2008, 08:16 AM   #75 (permalink)
Knows Where the Search Button Is
 
Join Date: Mar 2006
Model: 8300
Carrier: att
Posts: 23
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm on BES. 8300 with beta 4.5.0.42.

I saw google maps got updated to 2.0.2 so I did that, without thinking about this thread. I had ignored this thread, because it's been working for me so far (because I had google maps at 4.2, then did the upgrade).

I came to this thread when google maps was now hanging. I wasn't thrilled about any of the options - downgrading or getting IT to remove me then add me back.

So I tried going into advanced options>applications>google maps>edit permissions and set everything to "allow".

That got it to work for me. It seems that 2.0.2 is a little slower to download, but it also seems to cache a bit more.

Have been wondering - if I delete 2.0.2 then goto backup/restore, will it allow me to add back 2.0.1 with all the proper permissions? I know it's a longshot...
Offline   Reply With Quote
Old 07-14-2008, 01:55 PM   #76 (permalink)
New Member
 
Join Date: Feb 2008
Model: 8700g
PIN: N/A
Carrier: cable and wireless
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

this doesnt work in my country
Offline   Reply With Quote
Old 07-14-2008, 01:56 PM   #77 (permalink)
New Member
 
Join Date: Feb 2008
Model: 8700g
PIN: N/A
Carrier: cable and wireless
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

some error
Offline   Reply With Quote
Old 07-19-2008, 02:53 AM   #78 (permalink)
Thumbs Must Hurt
 
ams mike's Avatar
 
Join Date: Dec 2005
Location: Irvine, CA
Model: 9000
OS: 4.6.0.282
Carrier: ATT
Posts: 139
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by myk.dinis View Post
Absolutely spot on! The link worked, the steps all worked...I'm on AT&T and I haven't been able to use BB Maps. I can now!

Thanks again!

Myk
Same with me. Worked for me 1st try. finally have BBMaps on 4.5 OS on my ATT 8310.
__________________
make cars go fast

Last edited by ams mike : 07-19-2008 at 02:54 AM.
Offline   Reply With Quote
Old 07-22-2008, 09:22 AM   #79 (permalink)
Knows Where the Search Button Is
 
Join Date: May 2007
Location: Celina, TX
Model: 8110
PIN: N/A
Carrier: The "new" AT&T.... same old Cingular
Posts: 44
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I got BB Maps working per the link to download the latest from BB. I made sure to remove the lbs.alx file from C:\Program Files\Common Files\Research In Motion\Shared\Loader Files\8110-v4.5.0.44_P2.7.0.61 and all files with LBS in them from the java folder there as well. Worked like a charm first time out.
Offline   Reply With Quote
Old 07-23-2008, 10:55 AM   #80 (permalink)
Talking BlackBerry Encyclopedia
 
jubrand's Avatar
 
Join Date: Oct 2004
Location: Chicago, IL
Model: 8900
OS: 4.6.1.231
Carrier: T-Mobile
Posts: 352
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Where are you guys getting the old versions of google maps from?
Offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.