BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 05-25-2008, 05:01 AM   #1 (permalink)
BlackBerry Extraordinaire
 
flash24's Avatar
 
Join Date: Aug 2006
Location: San Antonio, TX
Model: 9930
OS: 7.1
PIN: 3319688F
Carrier: Verizon
Posts: 2,178
Post Thanks: 1
Thanked 0 Times in 0 Posts
Exclamation 4.5 Killing sim cards?

Please Login to Remove!

It happened to me and reportedly to some who have installed 4.5 to their blackberry device. I've only had the sim card for about 6 months and all of a sudden my blackberry wont connect to tmobile. What could have cause this? 4.5? Any of you guys experience this?
__________________
http://twitter.com/billydasco

Proud to Serve USAF
Offline  
Old 05-25-2008, 06:26 AM   #2 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,907
Post Thanks: 60
Thanked 244 Times in 182 Posts
Default

Wirelessly posted (8310; The Juggernaut)

I haven't had any issues and haven't heard of any either.

How are you certain that it was the OS and what happened?

Last edited by JSanders : 05-25-2008 at 07:48 AM.
Offline  
Old 05-25-2008, 07:30 AM   #3 (permalink)
Grumpy Moderator
 
NJBlackBerry's Avatar
 
Join Date: Aug 2004
Location: Somewhere in the swamps of Jersey
Model: i5s
Carrier: AT&T
Posts: 27,803
Post Thanks: 33
Thanked 441 Times in 381 Posts
Default

Moved to the Beta thread.
Where was this "reported" please?
Offline  
Old 05-25-2008, 11:58 AM   #4 (permalink)
BlackBerry Extraordinaire
 
flash24's Avatar
 
Join Date: Aug 2006
Location: San Antonio, TX
Model: 9930
OS: 7.1
PIN: 3319688F
Carrier: Verizon
Posts: 2,178
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by JSanders View Post
Wirelessly posted (8310; The Juggernaut)

I haven't had any issues and haven't heard of any either.

How are you certain that it was the OS and what happened?
I've only had my sim card for 6 months, I was running 4.5 on my 8320 and then all of a sudden, I can't connect with the tmobile network.

Same thing happened to a friend, when he upgraded to 4.5

I'm not exactly sure it's the 4.5, but I've never had this problem with 4.2.
__________________
http://twitter.com/billydasco

Proud to Serve USAF
Offline  
Old 05-25-2008, 11:59 AM   #5 (permalink)
No longer Registered.
 
Join Date: Jan 2007
Model: 8900
OS: 4.6.1.199
Carrier: None
Posts: 2,622
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

i have upgraded my 4.5 4 times now and have never had this issue at all!
Offline  
Old 05-25-2008, 12:05 PM   #6 (permalink)
BlackBerry Extraordinaire
 
flash24's Avatar
 
Join Date: Aug 2006
Location: San Antonio, TX
Model: 9930
OS: 7.1
PIN: 3319688F
Carrier: Verizon
Posts: 2,178
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

What could be another possible cause then?
__________________
http://twitter.com/billydasco

Proud to Serve USAF
Offline  
Old 05-25-2008, 12:23 PM   #7 (permalink)
BBF Moderator
 
rachamphetamine's Avatar
 
Join Date: Mar 2008
Model: --
PIN: E SOL
Carrier: VZW
Posts: 3,117
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Aren't sim cards only supposed to last for about a year? It could be that they just hit their due date and checked out because of that. How old was your friend's sim card?
Offline  
Old 05-25-2008, 12:27 PM   #8 (permalink)
BlackBerry Extraordinaire
 
flash24's Avatar
 
Join Date: Aug 2006
Location: San Antonio, TX
Model: 9930
OS: 7.1
PIN: 3319688F
Carrier: Verizon
Posts: 2,178
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by rachamphetamine View Post
Aren't sim cards only supposed to last for about a year? It could be that they just hit their due date and checked out because of that. How old was your friend's sim card?
He had his for less than a year and I've had mine for only six months. Sim cards are suppose to last for more than a year.
__________________
http://twitter.com/billydasco

Proud to Serve USAF

Last edited by flash24 : 05-25-2008 at 12:36 PM.
Offline  
Old 05-25-2008, 12:32 PM   #9 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,679
Post Thanks: 4
Thanked 96 Times in 71 Posts
Default

Sim cards last a lot longer than a year.

NOt sure what would cause this problem.
Offline  
Old 05-25-2008, 01:51 PM   #10 (permalink)
Grumpy Moderator
 
NJBlackBerry's Avatar
 
Join Date: Aug 2004
Location: Somewhere in the swamps of Jersey
Model: i5s
Carrier: AT&T
Posts: 27,803
Post Thanks: 33
Thanked 441 Times in 381 Posts
Default

I've had the same SIM card for at least 5 years.
And we have some Omnipoint cards still around (that was before Voicestream which was before T-Mobile).
Not sure where this One Year comment came from.
Offline  
Old 05-25-2008, 01:57 PM   #11 (permalink)
Thumbs Must Hurt
 
Join Date: Oct 2007
Location: New Jersey
Model: I9000
Carrier: AT&T
Posts: 53
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

i dont know its because of the 4.5 but what but im having the same problem cant connect to network (sim not allowed)
any advice would be appreciated???
Offline  
Old 05-25-2008, 03:48 PM   #12 (permalink)
BlackBerry Extraordinaire
 
flash24's Avatar
 
Join Date: Aug 2006
Location: San Antonio, TX
Model: 9930
OS: 7.1
PIN: 3319688F
Carrier: Verizon
Posts: 2,178
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by tsubasa55 View Post
i dont know its because of the 4.5 but what but im having the same problem cant connect to network (sim not allowed)
any advice would be appreciated???
Try your sim card with other phone if it works, then it's not the sim card. Also try a "working" sim card on your berry.
__________________
http://twitter.com/billydasco

Proud to Serve USAF
Offline  
Old 05-25-2008, 03:49 PM   #13 (permalink)
CrackBerry Addict
 
hotburnttoast's Avatar
 
Join Date: Aug 2006
Location: Hell Passhole
Model: 9700
OS: 5.0.0.442
PIN: Unique 8-character hexadecimal ID number assigned to all BlackBerrys
Carrier: T-Mobile
Posts: 524
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by flash24 View Post
It happened to me and reportedly to some who have installed 4.5 to their blackberry device. I've only had the sim card for about 6 months and all of a sudden my blackberry wont connect to tmobile. What could have cause this? 4.5? Any of you guys experience this?
This happened to me with 4.5.0.37, it did something to my sim card in the middle of the night, my sim card was only like 2 months old.
Offline  
Old 05-25-2008, 03:55 PM   #14 (permalink)
BlackBerry Extraordinaire
 
flash24's Avatar
 
Join Date: Aug 2006
Location: San Antonio, TX
Model: 9930
OS: 7.1
PIN: 3319688F
Carrier: Verizon
Posts: 2,178
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by hotburnttoast View Post
This happened to me with 4.5.0.37, it did something to my sim card in the middle of the night, my sim card was only like 2 months old.

Same exact thing happened to me, I was just watching TV one afternoon and then all of a sudden UMA is gone, no EDGE, no nothing.

Also, sim card will cost you $20 (tmobile) make sure you contact them first, maybe you can get a free one, if not they will give you credit for it.
__________________
http://twitter.com/billydasco

Proud to Serve USAF
Offline  
Old 05-25-2008, 03:59 PM   #15 (permalink)
BlackBerry Extraordinaire
 
flash24's Avatar
 
Join Date: Aug 2006
Location: San Antonio, TX
Model: 9930
OS: 7.1
PIN: 3319688F
Carrier: Verizon
Posts: 2,178
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by NJBlackBerry View Post
I've had the same SIM card for at least 5 years.
And we have some Omnipoint cards still around (that was before Voicestream which was before T-Mobile).
Not sure where this One Year comment came from.
lol I think it's time to upgrade your sim.
__________________
http://twitter.com/billydasco

Proud to Serve USAF
Offline  
Old 05-25-2008, 04:06 PM   #16 (permalink)
BBF Moderator
 
rachamphetamine's Avatar
 
Join Date: Mar 2008
Model: --
PIN: E SOL
Carrier: VZW
Posts: 3,117
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by NJBlackBerry View Post
I've had the same SIM card for at least 5 years.
And we have some Omnipoint cards still around (that was before Voicestream which was before T-Mobile).
Not sure where this One Year comment came from.
I heard it from a T-Mobile rep. It was probably just something to get me to buy another one but mine did end up kicking the bucket at a little after a year. My mistake!
Offline  
Old 05-25-2008, 04:19 PM   #17 (permalink)
BlackBerry God
 
jibi's Avatar
 
Join Date: Oct 2004
Location: Jibi's Secret Place
Model: 8900
OS: 4.6.1.174
Carrier: AT&T
Posts: 11,310
Post Thanks: 0
Thanked 1 Time in 1 Post
Default

There is a chance that carriers and/or RIM are monitoring the networks and killing devices and/or SIM cards. I wouldn't put it past them, as I know someone's pre-release BlackBerry 9000 was rendered useless by RIM.

They have the right to protect their networks, although I also think someone could very easily slap a lawsuit against them, if proven this was the case.
__________________
In the beginning the Universe was created. This has made a lot of people very angry and is widely regarded as a bad move.
Offline  
Old 05-25-2008, 04:36 PM   #18 (permalink)
CrackBerry Addict
 
hotburnttoast's Avatar
 
Join Date: Aug 2006
Location: Hell Passhole
Model: 9700
OS: 5.0.0.442
PIN: Unique 8-character hexadecimal ID number assigned to all BlackBerrys
Carrier: T-Mobile
Posts: 524
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by jibi View Post
There is a chance that carriers and/or RIM are monitoring the networks and killing devices and/or SIM cards. I wouldn't put it past them, as I know someone's pre-release BlackBerry 9000 was rendered useless by RIM.

They have the right to protect their networks, although I also think someone could very easily slap a lawsuit against them, if proven this was the case.
How on earth can they tell if we are running beta software on our phones.... Why on earth would they start with 4.5.0.37 and not the others?
Offline  
Old 05-25-2008, 04:42 PM   #19 (permalink)
BlackBerry God
 
jibi's Avatar
 
Join Date: Oct 2004
Location: Jibi's Secret Place
Model: 8900
OS: 4.6.1.174
Carrier: AT&T
Posts: 11,310
Post Thanks: 0
Thanked 1 Time in 1 Post
Default

What do you mean how can they tell? Your phone registers with their network. When you get a new phone and login to T-Mobile's Customer Care Portal, it asks if you want to update your profile with the new device. They own the network. Think of the carrier or RIM as 'God' - all-knowing...

...as for why this release, I have no clue. Perhaps since this release ultimately kills UMA (first one to do this), maybe they thought it best that their customers not be able to use it.

Or maybe this is the reason why UMA wasn't working in the first place. Honestly, it wouldn't surprise me a bit to see a carrier start blocking devices running certain rogue OS versions that have the potential of harming their network (more of a legal thought than actual reality).
__________________
In the beginning the Universe was created. This has made a lot of people very angry and is widely regarded as a bad move.
Offline  
Old 05-25-2008, 04:46 PM   #20 (permalink)
BlackBerry Extraordinaire
 
Lex Luthor's Avatar
 
Join Date: Nov 2005
Model: 9800
Carrier: xxx9824;xxx9824;xxx9824;xxx9824;xxx9824;
Posts: 1,620
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by flash24 View Post
It happened to me and reportedly to some who have installed 4.5 to their blackberry device. I've only had the sim card for about 6 months and all of a sudden my blackberry wont connect to tmobile. What could have cause this? 4.5? Any of you guys experience this?

Have you tried wiping the device than reloading the OS? I've had that issue in the past with both OS 4.2 as well as OS 4.5 but a reload of the OS corrected the issue for me.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.