BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   Beta You Than Me (http://www.blackberryforums.com/beta-you-than-me/)
-   -   RSA SecurID (http://www.blackberryforums.com/beta-you-than-me/135603-rsa-securid.html)

jtchristiansen 06-17-2008 04:24 PM

RSA SecurID
 
I just upgraded my 8310 to the official release vodaphone OS released here. Everything seems to work OK except RSA SecurID. I'm running 2.1.1 (but I'll take any version that works). The software runs, but I never get the option to import the token. I even had our IT guys look at it to make sure I wasn't doing anythign wrong with the token import (which I've done many times on my own when switching blackberries).

Has anyone found a trick to get this version (or any other version) of RSA SecurID running properly on the OS I have or, alternatively, has anyone been able to get any version of the 4.5 OS working with any version of RSA SecurID?

Any help would be greatly appreciated.

rjplatt 06-18-2008 12:35 PM

I am experiencing the same issue. Did some searching and found this.

From the RSA knowledgebase:

"Software token cannot be imported on to a devices with newer firmware. The token cannot be imported to the devices with OS version 4.3.0.97


Solution
This is a known issue and RIM Engineering is aware of it. This will be addressed in OS version 4.5. A case with RIM Engineering has already been opened.

RIM Case: SDR169651 with severity 1

Please contact RIM support to obtain the most recent version OS. This issue is expected to be resolved in OS 4.5 Build 42."

The Vodafone release is Build 37 so it looks like we will have to wait for an updated version of the BB OS.

domenic72 06-18-2008 03:45 PM

Quote:

Originally Posted by rjplatt (Post 976871)
I am experiencing the same issue. Did some searching and found this.

From the RSA knowledgebase:

"Software token cannot be imported on to a devices with newer firmware. The token cannot be imported to the devices with OS version 4.3.0.97


Solution
This is a known issue and RIM Engineering is aware of it. This will be addressed in OS version 4.5. A case with RIM Engineering has already been opened.

RIM Case: SDR169651 with severity 1

Please contact RIM support to obtain the most recent version OS. This issue is expected to be resolved in OS 4.5 Build 42."

The Vodafone release is Build 37 so it looks like we will have to wait for an updated version of the BB OS.

This sucks but the new features far outweigh me caring a hardware token ;-)

domenic72 06-21-2008 08:43 AM

I noticed that RSA released SecurID 3.0 for BlackBerry last week...has anyone tried it with 4.5?

bperkins 06-21-2008 11:37 AM

I too was having an issue with earlier builds .18 .37. I noticed that .44 is out now (sorry cannot provide links, simply search Google). I am going to try this version today to see if it works.

With each build it seemed to get further along to allow it to work. With .37 I was at least able to install the app and accept the T&C's. But when I went to import the Token it would show in the menu "import" clicked on it and went back to the app and it never appeard.

I will let you know if .44 fixes this issue.

jtchristiansen 06-22-2008 12:42 PM

I think RSA SecurID 3.0 may be the issue. When I tried this last week, 3.0 was not out. It must have been released Thursday or Friday. I'll try this on Monday and see if it works and let everyone know.

Spamdumpster 06-24-2008 02:11 PM

No luck with 3.0 -- no option to import the token.

8820 / 4.5.0.42

domenic72 06-24-2008 02:13 PM

Quote:

Originally Posted by Spamdumpster (Post 985285)
No luck with 3.0 -- no option to import the token.

8820 / 4.5.0.42



:cry:

jtchristiansen 06-24-2008 02:35 PM

no luck with 3.0 for me either
 
I tried RSA SecurID on my 8310 running 4.5.44 with 3.0. I had the option to import the token, but everytime I tried to import, nothing would happen. Note that I was able to get this far with RSA SecurID 2.11 on 4.5.42, with the exact same results.

Also note that the release notes for RSA SecurID 3.0 state "RSA does not recommend installing the RSA SecurID Token application on devices running BlackBerry OS version 4.3. Changes made in RIM BlackBerry OS version 4.3 do not support certain functions of the application."

If I've been following the OS versions properly, I believe 4.5 is basically the same as 4.3, but rebranded (although I could be incorrect on this fact), which means RSA SecurID 3.0 may not work exactly right on 4.5.

Ultimately, I had to downgrade back to 4.2 for now. :(

Please someone figure out a way to get this working so I can upgrade!!

jibi 06-24-2008 03:07 PM

OS 4.5 is the same as OS 4.3.1 not OS 4.3.0 (which is available for the Pearl 2 devices).

speedy1971 06-26-2008 08:41 AM

I also have the BES 4.5 and an BB 8110 with 4.5.0.42 and i am no longer able to import my software token.
Actually i can say import token, but nothing happens. We have also opened an call at RSA, but still waiting for answer.

bremere 06-26-2008 10:20 AM

I just downloaded RSA 3.0 from their website and attempted to install on my 8130...no luck...I get a message that "There is no software applicable for your device"

Running 8130 ver 4.3.0.97 if it helps....I am stumped....

jtchristiansen 06-26-2008 10:44 AM

Quote:

Originally Posted by bremere (Post 988560)
I just downloaded RSA 3.0 from their website and attempted to install on my 8130...no luck...I get a message that "There is no software applicable for your device"

Running 8130 ver 4.3.0.97 if it helps....I am stumped....

I can't offer any guarantees that it will work on your particular setup, but to get past the problem it sounds like you are having now, here is a suggestion. If you are upgrading from a prior version, you will need to uninstall the prior version and then go back into the apploader and "delete" the RSA SecurID. Once that is done, you can then "add" the RSA SecurID 3.0 and it should install. My experience has been that even though it is a new version, the apploader doesn't detect it as anything new (I think it has to do with it not being in the right folder or something based on the release notes in 3.0).

I don't know about RSA SecurID 3.0, but I can tell you that I was able to run RSA SecurID 2.11 with no problems on my Sprint 8130, which should have basically the same OS as the Verizon version (I think).

Hope this helps.

bremere 06-26-2008 09:34 PM

Quote:

Originally Posted by jtchristiansen (Post 988628)
I can't offer any guarantees that it will work on your particular setup, but to get past the problem it sounds like you are having now, here is a suggestion. If you are upgrading from a prior version, you will need to uninstall the prior version and then go back into the apploader and "delete" the RSA SecurID. Once that is done, you can then "add" the RSA SecurID 3.0 and it should install. My experience has been that even though it is a new version, the apploader doesn't detect it as anything new (I think it has to do with it not being in the right folder or something based on the release notes in 3.0).

I don't know about RSA SecurID 3.0, but I can tell you that I was able to run RSA SecurID 2.11 with no problems on my Sprint 8130, which should have basically the same OS as the Verizon version (I think).

Hope this helps.

Any idea if I am not upgrading....this is a fresh install.....I really hate carrying a token....

jtchristiansen 06-27-2008 08:46 AM

Did you install the handheld OS software on your computer? You'll also need to delete the vendor.xml if you are using a version of the handheld OS that is not from your phone manufacturer.

bremere 06-28-2008 09:52 PM

Quote:

Originally Posted by jtchristiansen (Post 990201)
Did you install the handheld OS software on your computer? You'll also need to delete the vendor.xml if you are using a version of the handheld OS that is not from your phone manufacturer.


Well, after fighting with this and giving up...I upgraded DM to 4.5....plugged in my BB and WHAM!!! It worked like a charm!!! Thanks to all for assistance!

-emb

rjplatt 07-03-2008 07:13 PM

Installed 4.5.0.46- the option to import the token is gone once again in this release.

Vin McLellan 07-08-2008 04:32 PM

Re: RSA SecurID for the BB -- Status Report
 
bremere wrote:

> Well, after fighting with this and giving up...I upgraded DM to
> 4.5....plugged in my BB and WHAM!!! It worked like a charm!!!
> Thanks to all for assistance!

Good news and bad news, eager Crackberries! The scuttlebutt around RSA, where I do some consulting, says RIM has successfully nailed the beta 4.5 bugs that disrupted the SecurID BB application. (And we expect problems in beta code, right?) In some recent 4.5 builds, the mechanism for importing and installing a SecurID token's "seeds," via a BB email attachment, was inadvertently broken.

In the latest BB build -- OS 4.5.0.52 b75 -- that's now fixed. Hallelujah!

Murphy tagged us twice, however, which doubled the trouble. A June 29th upgrade to RIM's BIS servers also broke at the server's end, the email attachment mechanism for all handhelds on the BIS service. That's still a problem. (The two issues sound similar, but they were actually quite different.) RIM, reportedly, already has the BIS fix in hand, but with QA and testing, it will probably be at least a week before the patch shows up on the BIS production servers.

BIS/SecurID customers who want to use email attachments to initialize their SecurID token apps will have to wait at bit, but RIM's enterprise customers, on BES, are unaffected, obviously. Watch for a BIS upgrade, probably next week.

For BES sites, with the latest upgrades on the BB OS, everything should work, including SecurID email attachments for procurement. Any carrier which accepts BB build 4.5.0.52 b75, or something higher, will have the fix. (Unfortunately, a few carriers -- Vodafone in Germany, Rogers in Canada, to mention two -- jumped early and adopted 4.5.0.37, which does not contain the fix. Stay tuned for BB upgrade info from the affected carriers.)

RSA's recently upgraded SecurID token-emulation code for the Blackberry (v3.0) seems stable and sturdy. No changes in the SecurID app were required to address either of these BB issues, rumors to the contrary.

Soon, hopefully by next week, BB/SecurID support will be available for everyone who needs it. I'm biased, but I think a SecurID OTP and a Blackberry Prayer make a powerful combination.

Suerte,
_Vin

bperkins 07-08-2008 09:10 PM

Vin thanks for the reply and info. Just to clarify if I download and install OS 4.5.0.52 b75 I will be able to successfully use (import the token from email, etc.) the RSA SecurID app v. 2.11?

bperkins 07-09-2008 08:43 AM

Guys-
Very happy to report that .52 and RSA app 2.11 now work!!! Finally!!!


All times are GMT -5. The time now is 06:21 AM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.