BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 08-20-2008, 06:55 AM   #1 (permalink)
Thumbs Must Hurt
 
myk.dinis's Avatar
 
Join Date: Aug 2007
Model: 8900
Carrier: AT&T - 8120/8310, Sprint - 8830
Posts: 133
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default 4.5.0.69 Camera/Video Camera Bug

Please Login to Remove!

I've noticed, in all the 4.5 builds, a persistent bug.

If you invoke Video Camera from the menu in Camera and then use the menu to close Video Camera it freezes the device. Battery pull only...

I've found this in every build so far and it's model agnostic. Well, the device needs a camera.

Anyone else seen this, if not give it a try.

Cheers!

Myk
Offline  
Old 08-20-2008, 07:00 AM   #2 (permalink)
Talking BlackBerry Encyclopedia
 
ubizmo's Avatar
 
Join Date: Dec 2007
Location: Philadelphia
Model: 9780
OS: 6.0.0.600
PIN: ultimate
Carrier: T-mobile
Posts: 423
Post Thanks: 0
Thanked 2 Times in 1 Post
Default

I just tried it, and there was no freeze. It worked normally. OS 4.5.0.69
Offline  
Old 08-20-2008, 07:10 AM   #3 (permalink)
Thumbs Must Hurt
 
myk.dinis's Avatar
 
Join Date: Aug 2007
Model: 8900
Carrier: AT&T - 8120/8310, Sprint - 8830
Posts: 133
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Sorry, more specifics needed...
Record sample video...
Then Menu > Close

So, the bug is: Camera > Menu > Video Camera > Record (ball click) > Pause (ball click) > Menu > Close

It's always hung for me right there...
Offline  
Old 08-20-2008, 07:48 AM   #4 (permalink)
CrackBerry Addict
 
wibbly's Avatar
 
Join Date: Apr 2005
Location: UK
Model: 9700
Carrier: T-Mobile UK
Posts: 857
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Just reproduced the bug in a 8300 running .55. I can exit out using the red phone key, but it returns to the hung video application if I try to get in to it again. I didn't need to do a battery pull to fix it. Alt-rightshift-Del was good enough.

If I make sure I choose to delete or save the video first I don't think it hangs.

Last edited by wibbly : 08-20-2008 at 07:50 AM.
Offline  
Old 08-20-2008, 07:51 AM   #5 (permalink)
Thumbs Must Hurt
 
myk.dinis's Avatar
 
Join Date: Aug 2007
Model: 8900
Carrier: AT&T - 8120/8310, Sprint - 8830
Posts: 133
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks Wibbly... I didn't know there was a BB three finger salute!

Cheers!

Myk
Offline  
Old 08-20-2008, 07:58 AM   #6 (permalink)
CrackBerry Addict
 
wibbly's Avatar
 
Join Date: Apr 2005
Location: UK
Model: 9700
Carrier: T-Mobile UK
Posts: 857
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm not sure it's as 'good' as a battery pull, but works well enough in many cases.
Offline  
Old 09-16-2008, 01:07 AM   #7 (permalink)
New Member
 
dt1401's Avatar
 
Join Date: Sep 2008
Model: 8320
PIN: N/A
Carrier: T-mobile
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by myk.dinis View Post
I've noticed, in all the 4.5 builds, a persistent bug.

If you invoke Video Camera from the menu in Camera and then use the menu to close Video Camera it freezes the device. Battery pull only...

I've found this in every build so far and it's model agnostic. Well, the device needs a camera.

Anyone else seen this, if not give it a try.

Cheers!

Myk

I have noticed the same thing on my 8320.
Offline  
Old 09-16-2008, 08:01 AM   #8 (permalink)
Thumbs Must Hurt
 
curriertech's Avatar
 
Join Date: Nov 2006
Location: Danville, NH
Model: 9800
OS: 6.0.0.141
Carrier: AT&T
Posts: 143
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by ubizmo View Post
I just tried it, and there was no freeze. It worked normally. OS 4.5.0.69
+1 on the same version, and I know I did it this way with .55 and didn't have the issue then, either.
__________________
AT&T 9700 : BES 4.1.6 MR6 : Domino 8.5
Offline  
Old 09-16-2008, 04:24 PM   #9 (permalink)
BlackBerry Extraordinaire
 
DallasFlier's Avatar
 
Join Date: Feb 2006
Location: Dallas, TX
Model: 9800
OS: 6.0.0.666
PIN: OT NOIR
Carrier: AT&T/Cingular/AT&T
Posts: 1,741
Post Thanks: 30
Thanked 20 Times in 15 Posts
Default

Quote:
Originally Posted by myk.dinis View Post
Sorry, more specifics needed...
Record sample video...
Then Menu > Close

So, the bug is: Camera > Menu > Video Camera > Record (ball click) > Pause (ball click) > Menu > Close

It's always hung for me right there...
Just tried your EXACT sequence above. Even did it twice. No problems, closed normally, no hang, and when I look at active programs list, no camera or video camera listed. Works just fine for me on 4.5.0.69.
__________________
Top 50 Year Win%: Nebraska-.785 tOSU-.768 Penn St-.740
Oklahoma-.740 Texas-.733 Alabama-.729 Michigan-.724 USC-.723
Dominance! The HUSKER Tradition!
Offline  
Old 09-16-2008, 10:25 PM   #10 (permalink)
CrackBerry Addict
 
Join Date: Sep 2005
Location: Northern Virginia
Model: 8830
OS: 4.5.0.138
Carrier: Verizon
Posts: 680
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by DallasFlier View Post
Just tried your EXACT sequence above. Even did it twice. No problems, closed normally, no hang, and when I look at active programs list, no camera or video camera listed. Works just fine for me on 4.5.0.69.
Same here, no issues. On .69 too.
__________________
xyrcncp | BB8830 | BES
BlackBerry FAQs
Offline  
Old 09-16-2008, 10:52 PM   #11 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,686
Post Thanks: 4
Thanked 100 Times in 72 Posts
Default

Yep...no issues here either. Tried it twice, as well.
Offline  
Old 09-17-2008, 12:48 AM   #12 (permalink)
BlackBerry Extraordinaire
 
Join Date: Oct 2007
Location: Los Angeles
Model: None
PIN: N/A
Carrier: ATT
Posts: 1,638
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

8320 running .69. I can duplicate the freezing. If I get out with the red end key, it leaves the video cam frozen. I was able to get into camera and take a picture, but it would never go back in to the video cam. Shows as running but will highlight and not enter the app.
Offline  
Old 09-17-2008, 01:08 AM   #13 (permalink)
New Member
 
dt1401's Avatar
 
Join Date: Sep 2008
Model: 8320
PIN: N/A
Carrier: T-mobile
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by curriertech View Post
+1 on the same version, and I know I did it this way with .55 and didn't have the issue then, either.
I am runing 4.5.0.55 here. I tried installing 4.5.0.69 but for some reason its not wanting to install to my phone.
Offline  
Old 09-18-2008, 05:24 AM   #14 (permalink)
Thumbs Must Hurt
 
Join Date: Apr 2008
Location: Kenosha, WI
Model: 9800
OS: 6.0.0.246
PIN: 235977d4
Carrier: ATT
Posts: 115
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I was able to replicate this with .69. Turning the phone off with the red end key will also solve the problem.
You can get into videos and view the video thats in limbo, but it wont play (yet it doesnt freeze the media player).
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.