BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   Beta You Than Me (http://www.blackberryforums.com/beta-you-than-me/)
-   -   Browser Fix - Why is it needed? (http://www.blackberryforums.com/beta-you-than-me/213275-browser-fix-why-needed.html)

devnull 12-09-2009 04:26 PM

Browser Fix - Why is it needed?
 
Im posting this in the beta forum since I believe it the most appropriate.

Thinking of upgrading to a beta v5 OS so I have been trying to find and extract information regarding the "browser fix" and why its needed. I have found numerous threads on BBF and other forums talking about it and explaining how to perform the fix, but no real conclusive info on whats happening underneath the fix.

Obviously there is something missing in the beta OS which limits browser functionality. Based on what Ive read, it seems we are unloading the net_rim_bb_browser_daemon.cod, loading a different service book file, then reloading the net_rim_bb_browser_daemon.cod. Can someone explain why this has to happen?

Just wanting to understand what I am doing before I take the v5 plunge. I'm probably over analyzing as usual.

rdef 12-10-2009 12:25 AM

If you don't do it, you can only access the MediaNet (wap) browser.

If you asking why the browser doesn't work without doing this, who the hell knows, and why does it matter? Just do it. It's easy, and it works.

captain_tinker 12-10-2009 01:38 AM

Ok, perhaps I'm not understanding either. I'm on 5.0.0.238 on an ATT branded Bold 9000, and I also keep hearing about this "browser fix" too. Not sure what it even means, what is broken about the browser? I've not had any problems with it. I have the WAP browser AKA MediaNet, and it works fine. Though frankly, I'm not sure what the other browser is for. Is it different than the other one? If so, how? It looks pretty much the same to me... Oh, also, how do you know if you need to do the browser fix?

-capT

penpower 12-10-2009 02:21 AM

My guess is that it has something to do with service books.

devnull 12-10-2009 07:10 AM

Quote:

Originally Posted by rdef (Post 1524521)
If you don't do it, you can only access the MediaNet (wap) browser.

If you asking why the browser doesn't work without doing this, who the hell knows, and why does it matter? Just do it. It's easy, and it works.

Yes, I am asking why the browser doesn't work without doing this.

It only matters because I'm curious.

devnull 12-15-2009 09:29 AM

Another question regarding this procedure. Why don't the "generic" service books get written over with future service book pushes?

rdef 12-15-2009 09:32 PM

kill me...

Jason Mark 12-15-2009 10:21 PM

It was a service book issue, at least for AT&T. AT&T did not push the necessary books for 9000's on the AT&T network. This however, is no longer a problem for AT&T users and the browser fix is not needed. As for other carriers, I can't speak to that, but for Rogers and AT&T the browser fix isn't needed.

MyPearl 12-18-2009 03:50 AM

Wirelessly posted

Quote:

Originally Posted by Jason Mark
It was a service book issue, at least for AT&T. AT&T did not push the necessary books for 9000's on the AT&T network. This however, is no longer a problem for AT&T users and the browser fix is not needed. As for other carriers, I can't speak to that, but for Rogers and AT&T the browser fix isn't needed.

Here is my experience. 2 att phones. 8900 with os 4 and 9700 with os 5. The browser worked on later but when 8900 was upgraded to os 5, browser issue surfaced. To make things more complicated, I have an Old sim card from att blue which works fine on my pearl. Put it in my 9700 and lost the browser

endure161 12-20-2009 08:41 PM

Quote:

Originally Posted by Jason Mark (Post 1528398)
It was a service book issue, at least for AT&T. AT&T did not push the necessary books for 9000's on the AT&T network. This however, is no longer a problem for AT&T users and the browser fix is not needed. As for other carriers, I can't speak to that, but for Rogers and AT&T the browser fix isn't needed.

AT&T has not fixed this for 8900 users - at least I cannot tell that anything has change. I requested that the service books be resent several times and it still only gives me medianet browser. Opera Mini works well but I still prefer the regular browser. Since they fixed it for 9000 users I assume that the same will be done for 8900's when an official release of OS 5 is made.

smoothballer 01-08-2010 04:16 PM

Does this "browser fix" apply to Verizon Blackberries as well? Because my Browser is completely missing after upgrading my 8230 to 5.0.0.230.


All times are GMT -5. The time now is 11:14 PM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.