BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 10-17-2011, 12:57 PM   #1 (permalink)
New Member
 
Join Date: Oct 2011
Model: 9520
PIN: N/A
Carrier: Vodafone Ghana
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default 9520 net.rim.platform.ecmascript error in reloading OS

Please Login to Remove!

Hi all, can someone please give me a solution to this problem????

i got a bb 9520 Storm 2 (IMEI:356297032015655/PRD: PRD-20973-801) to remove IT policy and after i used CrackUtil software to remove and wipe my device, i got a

"Reload software 507" message.

1. i used the "LOADER" application (with battery inserted and also without battery inserted) from C:\Program Files\Common Files\Research In Motion\AppLoader to load the OS but ALWAYS have this error message:

"The Blackberry Desktop Software does not have Blackberry Device Software for the device that you have connected to the computer. Contact your wireless service provider or system administrator"

though i have installed the os and used to reload previous bb storm 2s.

2. i used the BB desktop manager software to reload the os but i get the same error message and this too:

""This application requires that these other applications or libraries be installed:

Blackberry Fast Predictive Input Method Library

Unavailable application (net.rim.platform.ecmascript)"

3. when i attempt to manually load the os, i get this error message as well

"The application "Blackberry 5.0.0 Core Applications" cannot be loaded because some required files are not available"


4. i have used the MEP and IMEI to get the service provider for my handset and downloaded the Service provider os and installed on an entirely new pc which hasn't as yet had desktop manager nor any BB software/Os installed whatsoever but i still get these error messages.

5. i have read the BB FAQs and tried most of the possible solutions to no avail.

6. have tried on 4 pcs with desktop manager 4.7, 5.0.1 and 6 installed and the last one had no previously installed desktop manager nor any bb software or os.

i have tried in over a week to reload the os to no avail.

anyone with a solution should kindly help as i seem to be at my wits end now.

Please note that the pc connects to the bb and reads the pin.
thanx and best wishes
Offline  
Old 10-17-2011, 08:14 PM   #2 (permalink)
BlackBerry Mensa
 
tsac's Avatar
 
Join Date: Mar 2005
Location: Others run out when we run in
Model: Z10
OS: 10.010219
PIN: No Pin just a Tack
Carrier: at&t
Posts: 8,121
Post Thanks: 38
Thanked 556 Times in 551 Posts
Default Re: 9520 net.rim.platform.ecmascript error in reloading OS

Delete the DM and any OS files. Redownload new DM and the OS for the BB. Install DM first then install the OS for the BB.

The error messages indicate the OS is NOT installed on the PC so it may be that the OS was in a directory DM cannot see. Make sure it is installed without any errors . Use the default without changing any directory locations.

Good luck.
__________________
If someone helps, tell them by clicking the Thanks buttonî


9810 BES
Z10 on BES
9700 BIS
Offline  
Old 10-17-2011, 11:51 PM   #3 (permalink)
New Member
 
Join Date: Oct 2011
Model: 9520
PIN: N/A
Carrier: Vodafone Ghana
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: 9520 net.rim.platform.ecmascript error in reloading OS

have tried with DM 6.1.0.35 and the os installed without success. have tried with 5.0 as well without success and also without DM installed but os installed and run "loader.exe" all to no avail.

i'm using windows 7 Ultimate, 32-bit Operating system.

have tried several suggestions for over two weeks without success.

can i copy that file off another storm 2 and see if it'll work???

best wishes
Offline  
Old 10-18-2011, 01:18 AM   #4 (permalink)
New Member
 
Join Date: Oct 2011
Model: 9520
PIN: N/A
Carrier: Vodafone Ghana
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: 9520 net.rim.platform.ecmascript error in reloading OS

i still get this error when i attempt to load via "loader.exe";

"The application "Blackberry 5.0.0 Core Applications" cannot be loaded because some required files are not available"

after following your suggestion.

when i select the "Blackberry 5.0.0 Core Applications" item and click on "Details",and then under the "Dependencies" tab, i see this message:

"This application requires that these other applications or libraries be installed:

Blackberry Fast Predictive Input Method Library

Unavailable application (net.rim.platform.ecmascript)"

how do i get to install this application???

please help. thank you
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads for: 9520 net.rim.platform.ecmascript error in reloading OS
Thread Thread Starter Forum Replies Last Post
Losing Call Logs, SMS or Emails? Optimize your BB! How To Setup for max free memory! John Clark BlackBerry Help 1620 12-31-2012 06:43 AM
Latest OS: 9520 5.0.0.1729/5.0.0.1068 (nodrm) (Multilanguage) JSanders General 9500 Series Discussion - Storm 2 04-10-2011 05:46 PM
Differences between recently released GSM BlackBerry OS files Raptor464 General BlackBerry Discussion 3 10-07-2009 05:52 PM
HELP PLEASE - Problem reloading OS StanMort General 8300 Series Discussion - Curve 3 04-15-2008 07:50 PM
Question about reloading OS pkguy999 General Legacy Device Discussion 5 02-21-2008 09:58 PM





Copyright © 2004-2014 BlackBerryForums.com.
The names RIM © and BlackBerry © are registered Trademarks of BlackBerry Inc.