BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 08-30-2006, 11:44 PM   #1 (permalink)
New Member
 
Join Date: Aug 2006
Model: 7100
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default installing files OTA from apache

Please Login to Remove!

i have done a little homework on this already. i can't seem to get any blackberries to download/install anything from my server. i have edited the httpd.conf file already and, put in all the addtypes. the BB browser keeps giving me 406 errors. is there anything else that needs to be done other than the mime types? all the searching i have done seems to show that this is all that ya' need to make it work. apparently i am missing something simple.

as of right now i have the following in the mime.types, .htaccess (which are all in various directories with the files to be served) and, httpd.conf .

Quote:
#
# AddType allows you to add to or override the MIME configuration
# file mime.types for specific file types.
#
AddType application/x-tar .tgz
AddType application/x-vnd.rim.pme .pme
AddType application/x-vnd.rim.pme.b .pmb
AddType text/vnd.sun.j2me.app-descriptor .jad
AddType application/vnd.rim.cod .cod
AddType application/java-archive .jar
AddType audio/adpcm .adp
AddType text/x-pcs-gcd .gcd
AddType text/vnd.sun.j2me.app-descriptor .jad
AddType text/x-hdml .hdml
AddType text/vnd.wap.wml .wml
AddType text/vnd.wap.wmlscript .wmls
AddType image/vnd.wap.wbmp .wbmp
AddType audio/x-midi .mid
AddType audio/vnd.qcelp .qcp
AddType image/png .png
AddType application/vnd.wap.wmlc wmlc
AddType application/vnd.wap.wmlscriptc wmlsc
AddType image/vnd.wap.wbmp wbmp
AddType application/vnd.smaf .mmf



redundant, yes but i'm trying everything i can think of here.

also, does anyone have a list of the extensions that you can do OTA?

if anyone wants to give it a shot, PM me and i'll give you the test servers address

Last edited by cjohnson1979 : 08-31-2006 at 12:02 AM.
Offline  
Old 08-31-2006, 04:48 PM   #2 (permalink)
Thumbs Must Hurt
 
Join Date: Apr 2005
Model: 950
Carrier: T-Mobile
Posts: 185
Post Thanks: 0
Thanked 0 Times in 0 Posts
Lightbulb

Uhm, I don't know if it makes any difference, but it looks like you've got this twice:

AddType text/vnd.sun.j2me.app-descriptor .jad
AddType text/vnd.sun.j2me.app-descriptor .jad

You will probably want to restart Apache so that it can read the new config.

Also, you might try clearing the BlackBerry Browser cache.

Jon
Offline  
Old 09-01-2006, 07:17 AM   #3 (permalink)
New Member
 
Join Date: Aug 2006
Model: 7100
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

point taken i removed the extra line.
apache has been restarted and i clear the cache everytime i try it....so no luck though
Offline  
Old 09-02-2006, 03:46 PM   #4 (permalink)
Thumbs Must Hurt
 
Join Date: Apr 2005
Model: 950
Carrier: T-Mobile
Posts: 185
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well, maybe it's not a problem with the MIME type then.

Could be an IT policy or an issue with the browser.

Are you an a BES? Do you have more than one browser on the BB?
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.