BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 07-29-2010, 06:29 PM   #1 (permalink)
New Member
 
Join Date: Feb 2009
Model: 9000
PIN: N/A
Carrier: O2-UK
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Question Theme Builder - Bold 9000 not rendering themes correctly

Please Login to Remove!

I installed OS 5 on my Bold a few months ago to gain some features such as message threading and a better browser. The BlackBerry help page shows the difference between the Precision theme on the 9000 and the "updated Precision" theme on the 9700, and the most obvious difference is - as the Theme Builder calls it - the 'tab focus', or the blue highlight that appears to show which icon you are on. On the 9000 this is a simple darkening and a glow, but on the 9700 it is a gradient blue background with a slight glow.

I understand that they are different hardware, but I can't understand why even installing OS 5 won't give this blue icon highlight on the 9000.

For me this was just a minor annoyance as I thought it looked better, but when I create a theme in the Theme Builder using the Bold 9000 > Zen template and send it to the BlackBerry to simulate it doesn't appear correctly at all! I can mess around with a few settings to get the tab focus to appear, but in the main menu it doesn't appear at all!

Can somebody PLEASE shed some light on this situation and possible solutions on how to fix it? Thanks

EDIT: Theme fonts are also not rendering correctly - font sizes are all over the place and it's making it very difficult to gauge where things should be. In other words, the themes I'm designing look nothing like the design once they're on the device :(

Last edited by monkfishbandana : 07-29-2010 at 06:53 PM. Reason: Adding information
Offline  
Old 07-30-2010, 09:21 AM   #2 (permalink)
New Member
 
Join Date: Feb 2009
Model: 9000
PIN: N/A
Carrier: O2-UK
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Turns out I've solved it myself. For anyone else who may come across this problem (or wants the current 9700 theme on the 9000) then you just need to copy the images you want to show from

C:\Program Files (x86)\Research In Motion\BlackBerry Theme Studio 5.0\samples\Themes\Images\Precision480x320\icons


and paste them in a new folder elsewhere on your computer. Then simply go into the theme editor, create a new theme with the Bold 9000 Zen template and replace the files with the identical ones that are in the new location. The fonts are still a bit off but with some tweaking they'll be fine - hope this helps
Offline  
Old 07-30-2010, 09:58 AM   #3 (permalink)
CrackBerry Addict
 
Join Date: Dec 2006
Location: US
Model: 9930
PIN: Ask please
Carrier: Verizon Wireless
Posts: 694
Post Thanks: 0
Thanked 3 Times in 3 Posts
Default

I think that the issue you are running into here is that the 9700 is 480x360, and the 9000 is 480x320, therefore the items used in the themes may not be the same exact size, like fonts, which is why you are having font issues.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.