BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 06-05-2008, 09:10 PM   #1 (permalink)
Thumbs Must Hurt
 
Join Date: Jan 2008
Model: Tour
PIN: N/A
Carrier: verizon
Posts: 62
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default My Blue Ant Z9 experience

Please Login to Remove!

I bought a Blue Ant Z9 from Best Buy on 2/18. I really liked this headset. It fit great, it was small, and the sound was good. But it only worked for 2 months, then the speaker wouldn't work. I couldn't hear anyone, but they could hear me.

I called the company support line and they told me to upgrade the firmware. They sent me the instructions on how to do this. Unfortunately this required the Blue Ant usb cable, which apparently came in the package with the headset. I stupidly must have thrown it away with the box - totally my fault. So I needed to use another usb cable, but it turns out that the Blue Ant usb cable is proprietary. No problem, I ordered one from someplace on the internet, it came quickly and only set me back about $15. However upgrading the firmware didn't fix the problem.

Tech support told me to send back the headset and they would send me a new one. I sent it back the last week of April. The second week of May, after not receiving anything, I called them back to find out what was happening. They asked me when they received the package. How would I know, I asked, since I am not there. They told me to track the package. I went to the post office and was told that Blue Ant received the package on May 2.

I called Tech support back and was told that they couldn't look that up right now, but she would call me back tomorrow. Tomorrow came and went, with no call. I called again. This time I was told "Don't worry, if I said I would call you back I will call you back." OK.

She said the reason she didn't call me back was because she hadn't received the shipment receipts from that day yet and mine might have been in that batch. OK. So can you check now? No, I don't have the receipts.

I asked what could be taking so long to get a response. She explained that the warehouse moved, so that delayed things for a couple of days. And tech support is in Canada, the warehouse is in California, the company is in Australia and the parts are made in China. So it could take awhile. Well, I like geography as much as the next person and I appreciate that those places are far away from each other. But that is not my problem right now.

I was as nice as possible to the tech support person, since I realize its not a great job and she probably has to deal with angry and/or stupid people all day and night. But I told her that I was quite disappointed with the product and the customer service at this point.

It is now June 5 and I have not heard anything by mail, email, or phone about a replacement for my Z9. I have since bought a Jawbone (the original since the price went down) and I like it, but I like the fit and size of the Z9 better.

I guess I'll just write off the $100. I feel badly because I'm sure that they are a great little company just having production problems. But they really should do something for their customers in the way of communication.
Offline  
Old 06-05-2008, 10:31 PM   #2 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: May 2007
Model: 8830
PIN: N/A
Carrier: verizon
Posts: 274
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Wirelessly posted

Wow, that is totally unacceptable and a damn shame. I have had my blue ant for @ 6 months and it has been great. I used a jawbone before that and although the sound quality was first class the fit was not. As a result I never used it. The blue ant is as good in the sound department but the fit is far superior (for me).
I think you showed excellent patience and understanding but be persistent. It is not rude to be persistent, you are the customer after all.
Offline  
Old 06-05-2008, 11:26 PM   #3 (permalink)
BlackBerry Extraordinaire
 
003402's Avatar
 
Join Date: Nov 2005
Location: Colorado Foothills
Model: 8330
PIN: S AND NEEDLES
Carrier: VZW
Posts: 1,098
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

i have a blue ant as well, and although I haven't had any problems with it, I have been always a bit concerned with the support, mainly due to the geography issue.

I would send the president a letter or something like that. I couldn't hurt at this point. Knowing that you post on a board like this might help. If its small enough still, it might have some effect.

Good luck!
__________________
"out of chaos comes opportunity"
Offline  
Old 06-19-2008, 12:05 PM   #4 (permalink)
Thumbs Must Hurt
 
Join Date: Jan 2008
Model: Tour
PIN: N/A
Carrier: verizon
Posts: 62
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default My BlueAnt Z9 experience - Update

Update - I did email the vice president of the company (couldn't find the name of the president via google). He called me and apologized for the problems, didn't offer any lame excuses, just took full responsibility. He was very pleasant and had a hunky australian accent. A week later I had a brand new BlueAnt z9i that arrived via FedEx. Its working great so far. I'm not sure how the z9i differs from the z9, but as long as it works I'm happy. This has been the best fitting headset for me and its easy to get on and off. I still recommend it, I'm sure my broken headset was just an anomaly and not the norm.

Its just too bad I had to contact the VP in order to get anywhere.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.