BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   Bluetooth Connection (http://www.blackberryforums.com/bluetooth-connection/)
-   -   How to use the Native Bluetooth Drivers with Most Bluetooth Adapters (http://www.blackberryforums.com/bluetooth-connection/28166-how-use-native-bluetooth-drivers-most-bluetooth-adapters.html)

morser 03-09-2006 11:03 AM

How to use the Native Bluetooth Drivers with Most Bluetooth Adapters
 
I searched the Bluetooth forum for instructions on how to use the native XP SP2 Bluetooth drivers and only came up with pieces. I found this on the net. THe link is below, plus a copy of the page incase it disappears. I got my Kensington Bluetooth USB Adapter to finally syncronize. I also had to change my BES Policy to set the following two IT Policies were FALSE
DISABLE DESKTOP CONNECTIVITY
DISABLE WIRELESS BYPASS

Blackberry Support Article on Pairing:
Livelink - Redirection

Web Article that explained how to use the native XP SP2 Drivers:
Using the Microsoft Bluetooth Stack (instead of WIDCOMM) on Windows XP w/ SP2

Copy of the Web Article:

Using the Microsoft Bluetooth Stack (instead of WIDCOMM) on Windows XP w/ SP2

I recently purchased a Kensington USB Bluetooth adapter, and wanted to use it on my laptop to connect to Motorola V600 cell phone and dial up to the internet. I remember reading that the newly released Service Pack 2 for Windows XP had Bluetooth support (stack) built in.

This means that all you should be able to plug in your USB Bluetooth adapter, a Bluetooth icon should appear in the control panel, and you should be on your way! Well, that would be nice, but after some research I found that the xpsp2 Bluetooth support was only for adapters that had WHQL certified drivers. According to Microsoft, only a handful of these adapters were supported by the built in Windows XP (WHQL) driver.

The drivers that came with my Kensington adapter were WIDCOMM drivers.
Unfortunately these drivers are not WHQL certified, and cannot use the XP(sp2) built in Bluetooth stack. You must instead install the WIDCOMM Bluetooth stack, which seemed to work ok for me, but if Windows has this built in, why not use it?
Besides, I hate installing extra software that I don't need!

So I got started looking for a WHQL certified driver for the Kensington adapter. Well, to make this short, they don't exist (not that I could find at least). I did find newer WIDCOMM drivers though on Logitech's website, but they were still not WHQL certified, and therefore can not use the XP Bluetooth stack.

After going back and reading the list of Bluetooth adapters support by XP, I noticed the PnPID's listed next to each device. So I figured, why not just add the Kensington PnPID to the built in drivers inf file, and see if the built in drivers will work?

After locating the proper inf file: %windir%\inf\bth.inf
I opened it in notepad, read through it a little bit, and saw that there wasn't anything specific for each of the different manufactures devices. So on about line 60, under one of the device sections, I added my USB adapters PnPID like so:

;----------------------- Device section - Start -----------------------

[ALPS.NT.5.1]
ALPS Integrated Bluetooth Device= BthUsb, USB\Vid_044e&Pid_3005
Alps Bluetooth USB Adapter= BthUsb, USB\Vid_044e&Pid_3006

[Belkin.NT.5.1]
Belkin Bluetooth Adapter= BthUsb, USB\Vid_050d&Pid_0081
Belkin Bluetooth Adapter= BthUsb, USB\Vid_050d&Pid_0084
Kensington USB Bluetooth Adapter= BthUsb, USB\Vid_0db0&Pid_697a


Now, you may ask, well how did I know my adapters PnPID?
Well, I pulled mine out of the registry, but there is a much easier way!

After inserting the Bluetooth adapter into one of the computers USB ports, Windows will ask to install drivers for it, and it wonxxx8217;t be able to find any drivers for the device, and it will simply add the adapter to device manager as "USB Device" with a small yellow exclamation point under it. Well if you go into the device manager, double-click on the "USB Device" and look at the details tab, you will notice that in the drop down menu, there is an option called "Hardware Ids". Select this option, and in the area below will appear that devices Hardware (or PnPID) Ids. You need to copy one of those strings EXACTLY from that area, into the bth.inf file.

After that, delete the "USB Device" from device manager, and un-plug, and re-plug the Bluetooth adapter into your computer system. When prompted, let Windows search for a device driver, and it should pick up the adapter, and install the correct drivers for it. Also, there should now be an icon in the control panel for Bluetooth configuration.

Now, since I had already installed the adapter using the WIDCOMM drivers, I had to repeat the above steps, except instead of "USB Device" in device manager, I saw a "MSI USB Bluetooth Device" that had to be deleted.

Update 10/7/08
Wow, I was googling a bluetooth issue (not related) and this post came up 3rd in the rankings. Weird to see your own posts so high on the list.
I hope this thread helped those with problems, however looking over the replys, there are still lots of incompatible BT stacks out there. Best of luck to us all.

d_fisher 03-09-2006 11:57 AM

Good information! I hope someone else can try it out and verify.

Jimbob_1000 03-09-2006 09:41 PM

Hey great write up. I got it to work and show the BT icon in the Control Panel. But once I am in the BT folder I cannot get it to find my device and also the discoverability will not turn on. It says that the setting, when i check the box to be discovered, will not save.

are you experiencing any of this or am I the only one? thanks for your help.

KonTiki 03-10-2006 07:30 PM

Similar situation here, I got it to show in the taskbar, I can add my device but when I try to configure the bluetooth so I can wirelessly sinch, it doesnt work. For me this is the third time that I have upgraded to 4.1 OS and have never been able to synch wirelessly, I think in my case it is simply that my dongle is not supported, I will try with a nother type soon to see. And again I lost my modem tethering ability when it upgraded to 4.1 It sees the modem and tries to connect but then it simply says that it has a bad username or passsowrd. I have done this both manualy and with the verizon access manager.

opirrotta 04-19-2006 08:21 AM

Interesting
 
Great post above, I have a brand new 7130e with 4.1, and a zoom wireless PCMCIA card bluetooth adapter that is not supported by the XP stack. I can pair my phone, but the only service that works is "audio gateway", which I obviously cannot use to synch. From what I can tell, my bluetooth adapter/driver/software supports serial port connections with other devices, which is the way most pdas and smartphones synch, but my blackberry does not support this for some reason, it seems to use some different method of transfering info with the phone, that my bluetooth device doesn't support. Has anyone else run into this "bluetooth serial port" issue?

I have also noticed that the built in XP drivers seem to only support USB bluetooth device. In reading the bth.inf file, under device section, it only shows "bthusb, usb\" type devices. So, in short I am assuming I cannot update this file with my pcmcia adapter???

It looks like I may be forced to just buy a usb bluetooth adapter that has an approved XP stack driver. Does anyone have any recomemndations?

morser 04-19-2006 09:37 AM

opirrotta,
You may still be able to use your adapter... you need to get rid of the manufactuer's driver off your system so that it won't try to load that anymore, then edit the bth.inf file like it explains in the instructions, then it should pick up the adapter.
I bet all adapters will not work under the native bluetooth drivers though, but many people have had success. My USB adapter was a kensington.
good luck.
The neat thing about having your berry bluetoothed to your computer is that it will use your connection to Desktop Manager to transfer data instead of the cellular connection. for example, i'm in an I.T room with thick walls where there is no signal. my berry still picks up all the emails while in this room thanks to the bluetooth. when i walk out of range, i'm within reach of the cell towers...

opirrotta 04-19-2006 10:15 AM

Thanks morser, my only question is that can I still edit that bth.inf file even though my adapter is pcmcia and not usb? Seems like all the device entries in that file are usb? Also, what would the entry look like? I pulled the PnPid info from the device and it looke like this "PCMCIA\PCMCIA-BLUETOOTH_CARD-13AE\1",
So would my entry be:???

[Zoom.NT.5.1]
Zoom Bluetooth Adapter= Bthpcmcia, PCMCIA\PCMCIA-BLUETOOTH_CARD-13AE\1

morser 04-19-2006 04:55 PM

Wow. Good question. All you can do is try. I think since it detects just "bluetooth adapters" and not specifically pcmcia or usb you may have a chance at success.

alphasports 04-28-2006 10:34 AM

Thanks Morser! I had given up hope of getting my collection of BT dongles to work (Kensington & D-Link) but after following your instructions and jumping thru a couple minor hoops (and reboots) my 8700r syncs like a champ! Have only tried the Kensington but will try the D-Link next...

morser 04-28-2006 10:50 AM

Well I'm glad i could help. I ask quite a few questions (difficult as well as dumb) on this board and it's nice to be able to contribute back a little.

I love how it uses my bluetooth connection to transfer ALL data instead of the cellular network. However when i try to download a large application it fails at the end. so much for saving bandwidth that way. i think they did that on purpose.

Glad i could help.

opirrotta 04-28-2006 12:12 PM

another question
 
So, it seems like you have a deep BB background, any recomendations on a tiff file viewer? I am not really looking to spend $$

bldkcstark 05-08-2006 06:05 AM

100m BT for under $20!
 
I just got a USB dongle today that works great. It is a Bluetooth ver. 2 class 1 USB 2.0 100m (328ft!!) 2.4Ghz type. It works from every point in my house up to about 60 feet away and out into my yard. The good news? It uses the WIN XP SP2 BT stack drivers and costs only $12. Sounds too good to be true doesn't it? I ordered my first one when I got my 7130e, and it didn't work (it uses the WIDDCOMM BlueSoleil drivers, even tried the bth.inf mod), then I found another generic one that was guaranteed to work for $30, and bought it. That same day I was cruising geeks.com and found two more and bought them. One at geeks was the Kensington that several people have had success with after modifying the bth.inf so I was pretty sure it would work. The other was only $12, so I bought it too just in case I could get it to work. The geeks order got here first.

I plugged in the $12 dongle, I told it not to check the internet for drivers. XP asked me which driver I wanted to use, I selected the Microsoft drivers from a list of three choices.
I chose the drivers in the location c:windows\inf\bth.inf These are version 5.1.2600.2180.
When installation finished, I enabled BT on the phone and ouila! I got 100m BT sync goin' on! This even worked through a USB 2.0 hub. I had to reinstall when I plugged it into the hub, but I repeated the above instructions and it works great.

It boasts a 3Mbps data transfer rate. Okay enough gloating - here is a link to the item titled a Cambridge Silicon Radio Ltd. BT-B1 Class 1 v2 USB 2.0 BT dongle. It is listed as Model: BT-333E is listed at the address below, and made by Suncore Tech. Inc.
geeks.com/details.asp?invtid=BT-B1&cpc=SCH&srm=0 Sorry I can't post url's yet:oops: , I just signed up last week and have been reading, not writing in the forums.

Edit: The Guaranteed to work dongle doesn't work. Cellphone mall .net doesn't have any idea what they are selling. The Kensington does work with the bth.inf mod found here, although it costs more. The regular price of the CSR ltd. item is 14.99 and is $3 off as of 4-8-2006.

lsdillard 05-15-2006 10:58 PM

You rock!
 
I had spent entirely too much time trying to figure this out and was just about to give up and take the Kensington dongle back when I found your post. Thank you, thank you, thank you.
Oh, btw, for those with Kensington, either do not install the software at all or uninstalling it before doing this. The only downside is that this fix does not allow the dongle to expose all the possible services it supports, but I only bought mine for this purpose anyway...

afox3600 05-23-2006 10:09 PM

I have a Kensington USB adapter, and I am trying to connect it to a BB 8700C. Is this device 'Data transfer' enabled? Is there any good information on how to go step by step to set up the synchronization?

Andy

whsbuss 05-25-2006 12:52 PM

Has anyone gotten a D-link dongle to work yet?

whsbuss 06-01-2006 08:41 AM

D-Link Dongle
 
I finally got the D-Link DBT-120 dongle to work with my 7130e. Here's what I did:

1. Installed the latest Kensington 33348 dongle software/drivers for WIDCOMM (downloadable from kensington.com site under support).

2. In Control Panel, did an Add/Remove of the WIDCOMM software (remove) and rebooted PC.

3. Plugged in D-Link dongle and confgiured it using installed software (listed in device manager as Generic Bluetooth Radio).

4. Followed instructions from RIM knowledgebase http://www.blackberry.com/knowledgec...7250&vernum=13 - pay attention to Step 6.

Works like a charm even though RIM states in the article D-Link is not supported.

zarza 06-14-2006 03:42 PM

Ok, so I've followed all the instructions to add my Kensington to bth.inf. Drivers are now properly installed and 7130e paired. RIM Device Manager shows that I am allowed to use Bluetooth, so I try to add a device and none get found. Any thoughts?

I am on BIS, Sprint, Telstra OS.

EDIT: I tried it with my 8700g, and it worked great, so there must be an issue with my OS on my 7130e like some have noted in other threads.

mrogers 06-24-2006 01:21 PM

I tried to do this with my PCMCIA Billionton Bluetooth card, and it worked insofar as it loaded the XP drivers but then the device wouldn't start. Apparently Windows doesn't like using USB drivers for a PCMCIA device. :(

howlingthunder 06-29-2006 09:50 PM

Something Isn't Right
 
I have a Kingston BT USB dongle and I was able to get it to install with the MS drivers. But, after I pair, the Blackberry Device Manager doesn't see it, although the connected symble appears next to the BT symble on the device. Also, in the MS BT client, when I go to properties then services, none are listed. Could this be why? If so, why are none there? Thanks in advance for any help!

jfkuchta 06-29-2006 10:25 PM

Quote:

Originally Posted by howlingthunder
I have a Kingston BT USB dongle and I was able to get it to install with the MS drivers. But, after I pair, the Blackberry Device Manager doesn't see it, although the connected symble appears next to the BT symble on the device. Also, in the MS BT client, when I go to properties then services, none are listed. Could this be why? If so, why are none there? Thanks in advance for any help!

Do you have "Desktop Connectivity" and "Wireless Bypass" listed under your Bluetooth options on your BB?


All times are GMT -5. The time now is 02:08 AM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.