BlackBerry Forums Support Community               

Closed Thread
LinkBack Thread Tools
Old 10-17-2009, 08:40 PM   #1 (permalink)
New Member
Join Date: Oct 2009
Model: 8120
Carrier: ATT
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Unable to registerred to AT&T

Please Login to Remove!

I have a BB8120 with AT&T, but after I put in AT&T SIM card, I can't make call or other operations, I can see "SOS" besides the signal sign.

Do i need to activate SIM card first? How?

Old 10-17-2009, 09:09 PM   #2 (permalink)
Grumpy Moderator
NJBlackBerry's Avatar
Join Date: Aug 2004
Location: Somewhere in the swamps of Jersey
Model: iPh6
Carrier: AT&T
Posts: 27,855
Post Thanks: 34
Thanked 453 Times in 389 Posts

Was the card used in another phone?
Old 10-18-2009, 02:11 AM   #3 (permalink)
New Member
Join Date: Aug 2009
Model: 9000
Carrier: AT&T
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts

this might sound stupid but have you tried turning of the radio completely (AKA airplane mode w.e u wanna call it) and then turning it back on again. this happened to me once and i did that and it worked.

If not like NJblackberry said. was the card on any other phone? if so just call up att from another phone they'll activate it for you
Closed Thread

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Copyright 2004-2014
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.