BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 10-19-2007, 04:20 PM   #1 (permalink)
New Member
 
Join Date: Oct 2007
Model: 7100i
PIN: N/A
Carrier: Nextel
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Midlet icon will not show up on ribbon

Please Login to Remove!

This has been driving me crazy, I am trying to get my icon to show up on ribbon but it always shows the default icon. The icon is located in my img directory and the path works fine when I show another image on a splash screen and this also works on other phones. Below are the entries in my jad file that I am using RAPC to convert from jad/jar to a cod file. I have the icon entrie in both places since I am not sure where crackberries look for it. I am loading this OTA since that is how the app will be deployed.

MIDlet-1: AppName,/img/icon.png,MidletName
MIDlet-Icon: /img/icon.png

Thanks for looking!
Offline  
Old 10-23-2007, 12:41 AM   #2 (permalink)
New Member
 
Join Date: Oct 2007
Model: 7100i
PIN: N/A
Carrier: Nextel
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

OK guys I figured it out, you have to have the icon file in the same path of where you build your cod file. So if you are converting your jad/jar to cod and your icon file location is "img/icon.png" then you need to have that path relative to your cod build directory. So if you are builiding in the jde\bin dir you need to have your icon file in jde\bin\img then it will include it correctly in the cod.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.