BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 11-01-2007, 10:57 AM   #1 (permalink)
New Member
 
Join Date: Nov 2007
Model: 8700g
PIN: N/A
Carrier: Claro
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Smile Possible problem with OS

Please Login to Remove!

Hi,

I'm a beginner with Blackberry and I tried to make a simple test with my Blackberry. I installed JDE 4.3 and JSDK 1.5.0_13 in my machine. I took the HelloWorld example from blackberry.com and compiled it. It was fine, my application was running correctly with the Simulator. So I tried do Upload it to the Blackberry device (Blackberry 8700g) using the Desktop Manager. So when I try to upload the application an error occurred:

"A fatal error has occurred while updating your handheld's software. Please try again.
Unspecified error encountered [J:00000000A]"

And I was looking for it on Internet and I saw that it could be some incompatible between OS version and my application.

My OS is 4.1.0.351. So I found that I should update it. But I found that I couldn't do it before try to know if my carrier accept the update.

Well, my problem is that I'm not the owner of the Blackberry, I only want to make some tests. I can't update or change anything in Blackberry. I can download a new version of JDE, but I don't know exactly wich one will work to me.

Now my question, How can I do the HelloWorld application works with my Blackberry 8700g OS 4.1.0.351???

Thanks....
Offline  
Old 11-01-2007, 10:59 AM   #2 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,686
Post Thanks: 4
Thanked 100 Times in 72 Posts
Default

Moved to Developer Forum
Offline  
Old 11-01-2007, 11:14 AM   #3 (permalink)
CrackBerry Addict
 
Join Date: Jun 2005
Location: Manchester, UK
Model: BOLD
Carrier: t-mobile
Posts: 714
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

you develop using the jde that matches your target os - for the 8700 you'd use jde 4.0 or 4.1

for pearl, curve, 8800 you'd usually use 4.2

not many people have any 4.3 devices, some development houses get preview devices and early access to os upgrades - most developers won't start using 4.3 until the majority of their target users are using it - and that'll probably be 6months to a year yet.

there's no problem with the os. just download an earlier jde from blackberry.com
__________________
new job doesn't allow a public profile - please do not contact this user with questions, you will not get a response. good luck!

Last edited by jfisher : 11-01-2007 at 11:16 AM.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.