BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 11-05-2007, 10:05 AM   #1 (permalink)
New Member
 
Join Date: Feb 2006
Model: 7290
Carrier: Vodafone
Posts: 14
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default runtime OS

Please Login to Remove!

Hi all,

I have an application which detects at runtime which OS the device supports and perform some operations. The problem I am facing is as follows:

If the OS detected is 4.2 I want to use File API (which is not available in 4.1) so the problem comes in compilation as the application will not compile with 4.1 and I do not want o compile with 4.2.

Is there any way such problem can be resolved. thanks in advance for any hints you can give me.

regrds,

troy .
Offline  
Old 11-06-2007, 02:27 AM   #2 (permalink)
Talking BlackBerry Encyclopedia
 
Skipper_Joe's Avatar
 
Join Date: Jan 2007
Location: Kharkov, Ukraine
Model: 8300
Carrier: N/A
Posts: 237
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

the only solution which I know - compile 2 different binaries: using JDE 4.1 and without file support and using JDE 4.2 with file support.

I usually use preprocessor (antenna or netbeans) for divide source branches.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.