BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 04-09-2008, 09:24 AM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Sep 2006
Model: 8700c
Carrier: Cingular
Posts: 32
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default JDE version vs. device OS version?

Please Login to Remove!

I'd like to get some clarification on the limitation that apps built in the JDE aren't backwards compatible with devices running earlier versions of the device OS. I understand you can't build in JDE 4.2 to run on a 4.1 device. But could you build in (for example) JDE 4.1.0.185 to run on an earlier 4.1.0.nnn device?
Offline  
Old 04-09-2008, 09:44 AM   #2 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Oct 2006
Model: 7103
Carrier: Verizon
Posts: 259
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I would think that if .nnn < .185, you should be fine.
Offline  
Old 04-12-2008, 01:55 PM   #3 (permalink)
Thumbs Must Hurt
 
Join Date: Jan 2007
Model: 8800
Carrier: Orange
Posts: 181
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

It is to do with the APIs you use rather than the actual JDE number. I'm using the latest 4.3 JDE (well the components actually) but developing for a 4.1 device.

The API docs give details about what version each class/method was introduced it - make sure you only use ones that are available on your target platform.
Offline  
Old 04-26-2008, 09:28 AM   #4 (permalink)
New Member
 
Join Date: Apr 2008
Model: none
PIN: N/A
Carrier: starhub
Posts: 11
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for the answer. At first, I was looking at where to specify that i want to compile for 4.1, or 4.2, or etc.

But is there some verification tool that can detect the version during development? So that if i accidentally used a method available for another version, at least i know.
Offline  
Old 04-28-2008, 09:57 AM   #5 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Oct 2006
Model: 7103
Carrier: Verizon
Posts: 259
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

The best way to handle this is to have multiple jde's of the OS's. If you try and build a method available only in say 4.2 or greater on the 4.1 jde, you'll get a compile time error that'll indicate the disparity

Quote:
Originally Posted by samwize View Post
Thanks for the answer. At first, I was looking at where to specify that i want to compile for 4.1, or 4.2, or etc.

But is there some verification tool that can detect the version during development? So that if i accidentally used a method available for another version, at least i know.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.