BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 05-07-2008, 09:53 AM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: May 2008
Model: 8330
PIN: N/A
Carrier: Telus
Posts: 26
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default No menu icon after installing application

Please Login to Remove!

I compiled a simple Hello World program using Eclipse and the Blackberry JDE plugin. The code for this program is here:
Programming the BlackBerry With J2ME

I used this batch file to create the .alx file:
RapidShare: 1-Click Webhosting

and then uploaded it to the device using the Application Loader. The device is a BlackBerry 8100 from Cingular with OS v4.2.0.69. The application seems to have loaded properly. It appears in the list of applications under Options > Advanced Options > Applications. However, there is no icon in the menu. I tried the Show All option, but the icon is still not there.

I have also tried the alternative method of copying the jad/jar/cod to the Device memory, but it cannot be installed using that method.

I also tried loading the same program onto my Curve 8330 from Telus with OS v4.3.0.124 and the icon appears just fine. I assume it's an issue with the OS, but I don't see what the issue is.

Any help would be greatly appreciated.
Offline  
Old 05-07-2008, 10:16 AM   #2 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Apr 2008
Location: Germany, BW
Model: -
PIN: N/A
Carrier: -
Posts: 310
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Did you use JDE 4.3 to compile your code?
To use it on "older" devices you need to compile it against the lowest OS version you want to support. So use 4.2.0 components in Eclipse to compile it for your Pearl and it will also run on your Curve like it should...
Offline  
Old 05-07-2008, 11:23 AM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: May 2008
Model: 8330
PIN: N/A
Carrier: Telus
Posts: 26
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Do I need to download an older version of the plugin to use 4.2.0? Or is there an option I can set to compile against the older OS with the current plugin?

In the lib folder (C:\eclipse\plugins\net.rim.eide.componentpack4.3. 0_4.3.0.8\components\lib) there is only one library called net_rim_api.jar

Thanks for the quick response.

*EDIT* I found the BlackBerry JDE Components version 4.2.

I assume that I need to add it to the "Imported jar files" section in the BlackBerry workspace properties. Is this correct? Do I also need to remove the 4.3.0 jar file?

Last edited by Massif : 05-07-2008 at 11:49 AM.
Offline  
Old 05-07-2008, 01:00 PM   #4 (permalink)
Knows Where the Search Button Is
 
Join Date: May 2008
Model: 8330
PIN: N/A
Carrier: Telus
Posts: 26
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I added the 4.2.0 jar and removed the 4.3.0 version. It compiles fine, but I still see no icon on the 4.2.0.69 Cingular 8100. I also downloaded 2 more simulators. The Cingular 8100 with 4.2.0.71 simulator has the same problem.
The Verizon 8130 with 4.3.0.97 simulator runs the application fine.

I'm going to try the 4.2.1 and 4.2.2 simulators to see if they also have the problem.
Offline  
Old 05-08-2008, 02:40 AM   #5 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Apr 2008
Location: Germany, BW
Model: -
PIN: N/A
Carrier: -
Posts: 310
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

How do you set the icon for your application?

You can have several JDE version installed on the same machine and compile against the corresponding API version. You can select it in Eclipse under Window/Preferences/BlackBerry JDE/Installed Components. You should be able to choose between the installed JDE/Components versions.
Offline  
Old 05-09-2008, 04:16 AM   #6 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Jan 2008
Location: France
Model: 8310
PIN: N/A
Carrier: Vodafone
Posts: 217
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

So try the JDE 4.0.

I'm sure it's a version problem.
Offline  
Old 05-09-2008, 01:46 PM   #7 (permalink)
Knows Where the Search Button Is
 
Join Date: May 2008
Model: 8330
PIN: N/A
Carrier: Telus
Posts: 26
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I tried the 4.1.0 component pack under eclipse and it works now.
Thanks for the help!
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.