BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 05-30-2008, 08:37 AM   #1 (permalink)
New Member
 
Join Date: May 2008
Model: 8130
PIN: N/A
Carrier: T-Mobile
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Enable reply to email added programmatically

Please Login to Remove!

Hi there,

In my application I am adding email messages to the inbox programmatically. When I open a message the headers say 'Received Using: Unknown', presumably because the message didn't come through a service book transport. The name of the inbox I'm using appears to be 'no service book://Inbox', but they still appear in the main message application.

The problem comes when you reply to the message, there is no Send option. I'm wondering if anyone can tell me exactly why this is, and how to get round it?

I've tried this on several devices and the emulator with differing results. A couple of the devices have a BIS account so have CMIME service records setup, others have CMIME service records from a previous setup but no BB account. For some reason a couple of the devices are able to send the message, I've got no idea whats different about their configuration.

I'm getting the inbox to add messages to using this code:
Code:
inbox = Session.getDefaultInstance().getStore().getFolder(Folder.INBOX);
Any help is appreciated!

Cheers
Rory
Offline  




Copyright 2004-2016 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.