BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   Developer Forum (http://www.blackberryforums.com/developer-forum/)
-   -   Troubles with Eclipse JDE Plugin (http://www.blackberryforums.com/developer-forum/144957-troubles-eclipse-jde-plugin.html)

tOMPSON 08-13-2008 04:12 AM

Troubles with Eclipse JDE Plugin
 
First I have to say that I am really happy that there is an Eclipse plugin for BlackBerry Java development. I am using it now for four months and it seems like it has some troubles:

I am developing an application with two entry points. From time to time (in case to often) I get the following warning message in the BlackBerry Builder window:

[wtkrapc] Warning!: No entry points found
[wtkrapc] Warning!: No definition found for exported static routine: .main(String[])

It seems that the EntryFor configuration somehow gets removed from the JDP file. After cleaning, rebuilding, restarting adding the EntryFor, opening the properties dialog and changing something everything compiles again. But it seems like there is no logic why this happens and why it works again.

Does anybody know this problem?

Airport1 08-13-2008 04:19 AM

> [wtkrapc] Warning!: No definition found for exported static routine: .main(String[])

is it a midlet? if yes you may have to add the argument

-midlet

to the rapc call. otherwise it searches for the main method, instead of the midlet specific one. ps: this is guessed by me. I am new in all of this, I could be incorrect.. anyway it seems (!?) to solve exactly this problem, but I still have further problems - I think it's not that big easy to port a midlet to blackberry as I thought :(

tOMPSON 08-13-2008 04:43 AM

Thanks for the quick answer, I think I read the tip with the parameter somewhere before but I did not give it a try because my application is a CLDC application.


All times are GMT -5. The time now is 12:40 AM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.