BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 08-25-2008, 05:45 AM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Aug 2008
Location: Scotland
Model: None!
PIN: N/A
Carrier: Vodafone
Posts: 31
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default KSoap/Build.xml

Please Login to Remove!

Hi,

I'm a .NET coder but trying to develop Blackberry apps in Java so i'm a little out of my comfort zone.

I've googled and searched on here but I can't find any exlpanation. My problem is that I recently downloaded KSoap2, added it as a referenced library in my project. The actual code builds okay but since i added it in my Build.xml is throwing an error when I build.

Do i somehow have to include, or reference, my ksoap2-j2se-full-2.1.2.jar in the build.xml file?

Thanks
Offline  
Old 08-26-2008, 12:46 AM   #2 (permalink)
Knows Where the Search Button Is
 
Join Date: Aug 2008
Location: Scotland
Model: None!
PIN: N/A
Carrier: Vodafone
Posts: 31
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Can anyone help? The debugger is spitting on the following line:
<rapc jdehome="${jdehome}" jdkhome="${javahome}" output="${output}" >

It's unchanged and what i use in other projects, am i correct in thinking that it's getting errors elsewhere and just giving up at this line?
Offline  
Old 08-27-2008, 04:34 AM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: Aug 2008
Location: Scotland
Model: None!
PIN: N/A
Carrier: Vodafone
Posts: 31
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

No one???..... I suppose you are all sick of KSoap questions?

I'm using eclipse and I've tried creating a new project and stripping everything out except a call to a webservice using ksoap. I've added the preverified ksoap jar into lib folder and added it to the build path but when i build the project I get the same line of Build.xml as above. I think it's nothing to do with this line, when i double click on the error for a more detailed list i get the following errors:

package org.ksoap2 does not exist
package org.ksoap2.serialization does not exist
package org.ksoap2.transport does not exist
and "cannot find symbol" on every line of code where i have used any ksoap objects or methods.
Offline  
Old 08-30-2008, 08:26 AM   #4 (permalink)
Thumbs Must Hurt
 
baran_khan's Avatar
 
Join Date: Apr 2008
Model: 9500
PIN: N/A
Carrier: Airtel
Posts: 110
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi,

Follow following instructions to get this sorted:

1. You have already preverified the ksoap2.jar and added it as reference.

2. create a new Blackberry Project in eclipse, name it ksoap2. A new project not the one you are working on.

3. Right click on the project in the navigation menu and click on "Add file to blackberry project".

4 Browse to the ksoap2.jar and add it to the project.

5. Now go to the build properties of the actual project you are working on and select "Blackberry Project Dependencies" and add the newly created ksoap2 as a reference to the project.

6. Now run your project, I guess your issue will be sorted after this...I spent weeks on that...

Hope that helps!!!
__________________
Smart People ask for Help!!!
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.