BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 09-09-2008, 08:12 PM   #1 (permalink)
New Member
 
Join Date: Sep 2008
Model: 8830
PIN: N/A
Carrier: TM
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default OS 4.2 compatibility with OS 4.6

Please Login to Remove!

Will the 4.6 on Bold be compatable with 4.2 on previous devices, i.e. will the applications written for 4.2 function on 4.6? Appreciate the answer. Thank you.
Offline  
Old 09-09-2008, 08:20 PM   #2 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2008
Location: Austin, TX
Model: 9700
PIN: N/A
Carrier: T-Mobile
Posts: 1,644
Post Thanks: 0
Thanked 34 Times in 33 Posts
Default

For the most part, they will function. You'll need to put the program on the Bold and have a look for issues. For example, icons used on the 4.2 devices are extremely small on the Bold (due to the higher screen resolution).

Likewise, if you have any paint() code that assumes a particular screen size, you'll have issues.
Offline  
Old 09-10-2008, 02:21 AM   #3 (permalink)
New Member
 
Join Date: Sep 2008
Model: 8830
PIN: N/A
Carrier: TM
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thank you, Doug! Anyone else?
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.