BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 10-15-2008, 09:29 PM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Sep 2008
Model: 7100T
PIN: N/A
Carrier: Carrier
Posts: 18
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default RIM-COD-Module-Dependencies

Please Login to Remove!

Hi guys,

I have created a simple application that creates a customized indicator icon. I have got it running on my 4.6 device simulator. But when i tested it on my 8820 BB phone, an error appeared saying:

"This application requires the following module, which is not installed: net_rim_bbapi_messagelist"


And i figured out that in my .jad file the module "net_rim_bbapi_messagelist" is listed in the RIM-COD-Module-Dependencies together with the module "net_rim_cldc".


Now my question is, how can i install the module "net_rim_bbapi_messagelist"? Or can i say how can i include the "net_rim_bbapi_messagelist" module on my application?

Thanks guys!
Offline  
Old 10-16-2008, 04:37 AM   #2 (permalink)
New Member
 
sri_mform's Avatar
 
Join Date: Sep 2008
Model: 7290
PIN: N/A
Carrier: airtel
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi,
I think the module,net_rim_bbapi_messagelist, is already included in ur application thats why it is comming in the JAD file.
Reason for failling might be missing on the device.

Check the modules list on the device whether "net_rim_bbapi_messagelist" is been listed or not.
to view the modules list,
select settings>advanced option>application>select any application>click modules.

hope this will help you
Offline  
Old 10-16-2008, 09:10 PM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: Sep 2008
Model: 7100T
PIN: N/A
Carrier: Carrier
Posts: 18
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by sri_mform View Post
Hi,
I think the module,net_rim_bbapi_messagelist, is already included in ur application thats why it is comming in the JAD file.
Reason for failling might be missing on the device.

Check the modules list on the device whether "net_rim_bbapi_messagelist" is been listed or not.
to view the modules list,
select settings>advanced option>application>select any application>click modules.

hope this will help you
Thanks for your reply.

I viewed the module list and the net_rim_bbapi_messagelist is not listed. :(

How do i install this module on my device?

Thanks again!
Offline  
Old 10-16-2008, 11:25 PM   #4 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2008
Location: Austin, TX
Model: 9700
PIN: N/A
Carrier: T-Mobile
Posts: 1,644
Post Thanks: 0
Thanked 34 Times in 33 Posts
Default

What version of BB OS is your 8820 running? Probably 4.2 or maybe 4.5?

You cannot run an application built on 4.6 on an earlier version of OS (like 4.2 or 4.5).
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.