BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 10-30-2008, 01:28 PM   #1 (permalink)
Thumbs Must Hurt
 
Join Date: Nov 2007
Location: atm: Kunming norm: Berlin
Model: 8700v
PIN: N/A
Carrier: ChinaMobile
Posts: 55
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default problems loading file / playing video

Please Login to Remove!

Hi,
I want to play a video from the local store in my application using net.rim.plazmic.mediaengine.MediaManager.
When I try to load a video(or any other file) I get a "File not found Exception" at this line:
media = mm.createMedia("file:///store/home/videos/BlackBerry.mp4");

The file is definitely at this path (I copied it there myself and also opened it from there in the BB-Mediaplayer...)

what do I do wrong?

Thanks in advance,
JJ


update:
when I use the class javax.microedition.media.Manager ( mp = Manager.createPlayer("file:///store/home/music/Alarm_EarlyRiser.mp3"); ) (again, i copied the files to that path)
I get an IOException with the following message:
"Locator does not reference a valid media file"

When I open the file(s) in the normal BB-Mediaplayer everything works fine...

any ideas?

Last edited by jenselense : 10-30-2008 at 02:05 PM.
Offline  
Old 10-30-2008, 03:35 PM   #2 (permalink)
Thumbs Must Hurt
 
Join Date: Nov 2007
Location: atm: Kunming norm: Berlin
Model: 8700v
PIN: N/A
Carrier: ChinaMobile
Posts: 55
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default ouups....

I'm sorry...
Obviously I was blind and didn't notice that the "user" in the path was missing :-/

it works fine now...

JJ
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.