BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   Developer Forum (http://www.blackberryforums.com/developer-forum/)
-   -   building an app. to run on 4.2, 4.6 and 4.7. How do I??? (http://www.blackberryforums.com/developer-forum/177754-building-app-run-4-2-4-6-4-7-how-do-i.html)

damicolo 02-23-2009 03:11 AM

building an app. to run on 4.2, 4.6 and 4.7. How do I???
 
I'm not new to hand-held developement, but I'm almost new to Java. My problem is that I've to build and application that will run on "basic" BB running version 4.2 and new devices, like Bold and Storm running 4.6 and 4.7. Some APIs are very different from 4.2 to 4.7 (i.e. WIFI and touch). I don't want to build a lot of projects, but i want to work always on the same project, making all the required branches depending on the version specific APIs. For example, if I were working in C++ I would use Preprocessor statement (#ifdef....)
I know the in java there isn't any preprocessor... How can I do that?
I'm working with JDE (I mean, many different JDEs at the moment...). I cannot use Eclipse.

Thank you all in advance,
Damiano.

bemshaswing 02-23-2009 09:04 AM

things like
//#ifdef VERSION_TOUCH
//#endif

do work with the jde's with minimal configuration

hrbuckley 02-23-2009 09:42 AM

Wirelessly posted (8820)

I've been using JEnable. But I would really like to know what the minimal configuration bemshaswing is talking about.

There is also this thread.

And the BlackBerry JDE Plugin for Eclipse.

damicolo 02-23-2009 11:47 AM

Thanks a lot. JEnable works great for me!!!

lionscribe 02-24-2009 07:26 AM

Wirelessly posted

I have posted a solution for this issue at http://www.blackberryforums.com/developer-forum/177904-solution-jde-preprocessor-defines.html
Lionscribe


All times are GMT -5. The time now is 03:20 AM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.