BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 03-02-2009, 10:25 PM   #1 (permalink)
New Member
 
Join Date: Mar 2009
Model: 9000
PIN: N/A
Carrier: none
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Web connection over wifi

Please Login to Remove!

I have been developing an application using Eclipse and the Blackberry plugin. I have had no trouble running in the simulator and calling my REST api.

Today, I attempted to load the application on the unlocked Blackberry Bold that I got from the Developer's conference and hit a brick wall. I want to use the Wifi for my connection since I do not have a sim or data plan for this phone. Only it is failing to populate with the data from my REST. I can reach my REST endpoints fine using the Web Browser. Surely other applications can take advantage of the wifi connection..

Any ideas on what the problem could be?
Offline  
Old 03-03-2009, 11:12 AM   #2 (permalink)
New Member
 
Join Date: Mar 2009
Model: 9000
PIN: N/A
Carrier: none
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have tried appending ";interface=wifi" to the connection string in hopes of forcing a WIFI connection but it still errors with an 'APN is not scpecified'. =/
Offline  
Old 03-03-2009, 11:33 AM   #3 (permalink)
New Member
 
Join Date: Mar 2009
Model: 9000
PIN: N/A
Carrier: none
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Seems that the latest build did not get deployed. When I was still receiving the APN error. It is now working.

It is a shame that blackberry does not take it upon itself to find any open connection and use it. Guess I am too used to WM development. Thanks for the help!
Offline  




Copyright 2004-2016 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.