BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   Developer Forum (http://www.blackberryforums.com/developer-forum/)
-   -   GSM CDMA problem (http://www.blackberryforums.com/developer-forum/180179-gsm-cdma-problem.html)

Meenal 03-09-2009 05:35 AM

GSM CDMA problem
 
Hi All,

I have an application which does some webservice calls to the server .. I am using KSOAP2 for the same. The application works fine on a GSM BB with BIS service, but refused to work on a CDMA phone. It keeps on giving the error Server Time Out.

I dont know y its happening. Does any body have any suggestions abt what could be going wrong. Or are there specific settings required on the ph (Eg say APN setting on gsm).

Please do let me know.

hrbuckley 03-09-2009 09:51 PM

Are you using a port other than the standard web services ports? Our CDMA provider here (Bell) does not allow the use of APNs, I don't know that there is an equivalent to the APN in the CDMA world. The only solution I've found is to use a BES or Unite server, or put the server process on a standard web server port ie 80.

Meenal 03-10-2009 01:17 AM

Hi,

A few more questions ....
1. What is a unite server?
2. On the same device google maps and such stuff works fine. Does that mean there is something wrong with my app specially.

Meenal 03-10-2009 01:30 AM

I guess the unite server is still not available in india. :(

hrbuckley 03-10-2009 09:09 AM

Quote:

Originally Posted by Meenal (Post 1313918)
Hi,

A few more questions ....
1. What is a unite server?
2. On the same device google maps and such stuff works fine. Does that mean there is something wrong with my app specially.

1. Unite is a reduced functionality version of BES for home or small office use. It has unfortunately suffered from some implementation problems and poor information, but allows the SOHO user to have many of the features of a BES for free.

2. I imagine Google is a member of the Blackberry Independent Software Vendor program and therefor has access to features or facilities that I don't.

Meenal 03-10-2009 10:17 AM

When i try run the httpdemo app provided in with jde ... even thts not working on 8830. The error for any http transaction is :
'java.io.IOException: Malformed Address. Returning null connection'.
Funny part is if i i do some garbage APN setting, the application starts gives a connection time out error, but it atleast initiates a connection.
Would it be possible tht the service provider has blocked certain services. Is there a way to check?

I tried calling up the service provider .... but they said they are not trained to request from 3rd party apps :? . Any help will be Appreciated.

hrbuckley 03-10-2009 01:06 PM

When you use the BIS for the connection (without APN) the TCP stack in the device is not used, the BIS establishes the connection and communicates with the BB using some RIM proprietary protocol. When you specify an APN the TCP stack in the device is used, and tries to negotiate a connection through the carrier APN specified.

The malformed address error, I think, indicates that some portion of the URL you specified is syntactically incorrect, or not supported by the BIS.


All times are GMT -5. The time now is 06:44 AM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.