BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   Developer Forum (http://www.blackberryforums.com/developer-forum/)
-   -   Using JSR 172 WebServices (http://www.blackberryforums.com/developer-forum/181564-using-jsr-172-webservices.html)

vlady.rafael@gmail.com 03-17-2009 03:03 AM

Using JSR 172 WebServices
 
Hi,

I am trying to connect to a simple web service from BlackBerry simulator (Bold version 4.6) using the JSR 172 spec. I generated the stub and created my application that uses this stub. Unfortunately when trying to invoke the webservice the client is stuck (the call doesn't return and no exception thrown). I tried to use both .NET web service and JBoss web service.

Can anyone help me?

Thanks

Timbo70 03-17-2009 06:24 PM

Hi,

I have been having similiar issues with trying this method and ksoap2 with netbeans 6.5.

I suggest you try making sure that MDS is running with the simulator.

Regards

Tim

vlady.rafael@gmail.com 03-18-2009 12:50 AM

Jsr 172
 
Hi,

Do I have to have MDS for using the web services?
How does it work on a real BlackBerry device?

Thanks

SamuelD 03-18-2009 09:23 AM

Hello, you don't need the MDS application on the device but you may need the MDS Emulator running on your computer.

Just before trying your application that use web services, are you able to navigate with the BB Browser? If you can't then the problem is that your application is just not able to contact the web service at all.

You can download the JDE and run the application MDS. It will open a small command prompt and load a bunch of thing. let MDS run and try to navigate with the BB Browser, if it work, you'll be able to try your application.


All times are GMT -5. The time now is 08:49 PM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.