BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 03-22-2009, 12:54 PM   #1 (permalink)
New Member
 
Join Date: Dec 2008
Model: 8310
PIN: N/A
Carrier: Cellcom
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Cool Blackberry bold platformRequest after open connection

Please Login to Remove!

Hi,
I've a code that working on 8310 Curve but not working on bold 9000.
The problem: Midlet is not able to launch web page after opening connection (and closing) using platform request.
Code:


Code:
				http = (HttpConnection) Connector.open(formatUrl(url), Connector.READ_WRITE);
				System.out.println("---> Open connection 2");	
				//Initiate an Http Post request..
				http.setRequestMethod(HttpConnection.POST);
				http.setRequestProperty("Accept", "*/*");
				http.setRequestProperty("Content-type","multipart/form-data");
				http.setRequestProperty("Cache-Control", "no-cache");
...

Code:
			http.close();
Code:
AppManager.get_instance().get_midLet().platformRequest(Url);
I tried lowercase url and closed connection every time I could. I tried system.gc() (garbage collector) and used synchronized functions.
Also used exceptions.
The problem is that 90% of the time, native browser opens up on loading screen and is unable to reach page. This happens even I change the url to some working url, the problem still occurs, so the problem is not the url.
If I launch platform request first (before opening connection) everything works fine.

Either way, the code works on 8310 and not on 9000.
I can, I'm not saying that I'm, but I can jump out of the window right now.
please help.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.