BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 03-27-2009, 12:03 PM   #1 (permalink)
New Member
 
Join Date: Mar 2009
Model: 8310
PIN: N/A
Carrier: sfr
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Webservice soap and complex type

Please Login to Remove!

HI,

I'm currently developping an application using Blackberry JDE and Netbeans that calls axis2 soap webservices.

The problem I have is that if my service returns strings or int no problems but if I try to retrieve complex types as class instances or class instances arrays it doesn't work I always get a null.
It's the same if a send complex types to my webservice, if I log what's incoming on the server it's always null.

I've implements my class objects as serializable and it was working great last week. Don't understand what's going on now.

If someobne could help....

Thanks
Offline  
Old 03-27-2009, 01:53 PM   #2 (permalink)
Thumbs Must Hurt
 
Join Date: May 2008
Model: 8700
PIN: N/A
Carrier: Telcel
Posts: 69
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Can you post some of you code to see how are you handling the response of the webservice.

Also, post the responseDump of your HttpTransport please.

I also handle some complex types on my webservices response, most of them being DataSets returned by .NET WebServices
Offline  
Old 03-30-2009, 03:08 AM   #3 (permalink)
New Member
 
Join Date: Mar 2009
Model: 8310
PIN: N/A
Carrier: sfr
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for your reply.

I've created a new Java ME Webservice client from a wsdl.
Here is how I handle the response :

easywork_ws_Stub _wStub = new easywork_ws_Stub();
site[] tSite = null;
try { tSite = _wStub.getSites(new Integer(0)); }
catch (RemoteException ex) { ex.printStackTrace(); }
And it always results with tSite = null;

The site Class is implemeted as Serializable.

Sorry, I'm very new to blackberry developement and I 'm not familiar with debugging this kind of application. the response Dump you'd like to see is produced when using kSOAP, but I don't use it. I don't really know how to get a trace of the response I get from the server. I'm currently just debugging with breakpoints, blackberry simulator and MDS simulator.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.