BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 04-19-2009, 11:15 AM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Mar 2009
Location: Bilbao
Model: 8900
PIN: N/A
Carrier: Vodafone
Posts: 29
Post Thanks: 0
Thanked 0 Times in 0 Posts
Question Problem with persistence in simulator

Please Login to Remove!

Hi,

i need to store some object in persistence (differents class).

It seems to work perfect with the first that i create, but the second disappear from persistence when i start for the second time the simulator.

Two classes are similar, and i debug the application and i see that i store both object (i try to store and then load) but the second time, i can restore the first but not the second

The only different thing is in the out of simulator. For the second object i see this
VM:NPOEr=0x86676000,t=foo.MySecondPersistableObjec t
VM:NPORr=0x7D790000,t=<array-piece>
VM:NPOLv=1,w=0

any idea?
Thanks
Offline  
Old 04-20-2009, 09:04 AM   #2 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Apr 2008
Location: Germany, BW
Model: -
PIN: N/A
Carrier: -
Posts: 310
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

any code?
__________________
Blessed is the end user who expects nothing, for he/she will not be disappointed. (Franklin's Rule)
Offline  
Old 04-26-2009, 04:51 PM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: Mar 2009
Location: Bilbao
Model: 8900
PIN: N/A
Carrier: Vodafone
Posts: 29
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

hi, i find the problem: in my persisten object i use another object that not implemented the persistable interface...
Offline  




Copyright 2004-2016 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.