BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 05-15-2009, 04:41 AM   #1 (permalink)
New Member
 
Join Date: Jul 2008
Model: 8330
PIN: N/A
Carrier: Verizon
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Does module compiled by JDE4.7 can work fine on OS4.2?

Please Login to Remove!

JDE4.7 support more API than JDE4.2. I am wonder can those new API compiled with JDE4.7 work on OS 4.2?
Offline  
Old 05-15-2009, 07:23 AM   #2 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2008
Location: Austin, TX
Model: 9700
PIN: N/A
Carrier: T-Mobile
Posts: 1,644
Post Thanks: 0
Thanked 34 Times in 33 Posts
Default

You cannot deploy a BB application on a device that has a lower version number than the JDE that compiled it.

To run on your 4.2 device, you'll need to compile under 4.2.
Offline  
Old 05-31-2009, 04:39 AM   #3 (permalink)
New Member
 
Join Date: Jul 2008
Model: 8330
PIN: N/A
Carrier: Verizon
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

In fact, The module we compiled by JDE4.7 can work well on 4.2 device. Unless the new API do not supported by JDE4.2.

Thank you.
Offline  
Old 05-31-2009, 10:10 AM   #4 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2008
Location: Austin, TX
Model: 9700
PIN: N/A
Carrier: T-Mobile
Posts: 1,644
Post Thanks: 0
Thanked 34 Times in 33 Posts
Default

Sorry, but this is not supported. You run a very real risk of "bricking" the device.

Good luck.
Offline  




Copyright 2004-2016 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.