BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 07-14-2009, 04:19 PM   #1 (permalink)
New Member
 
Join Date: Jan 2009
Model: pearl
PIN: N/A
Carrier: att
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default SOLVED ksoap tunnel error

Please Login to Remove!

My project is using the ksoap2 libraries, and it works great on the simulator.

On the device, the first connection works great, I get my soap response. My carrier is AT&T and my apn is wap.cingular, so apparently it is working semi-properly.

The second connection however throws an error that I can see in the system.out panel due to my httptransport object being in debug mode
:

Choking Tunnel.open due to 'max tunnels' error; id=3

This eventually times out and then the connection is made, but it takes minutes.

Any ideas anyone? My blackberry was initially a Verizon blackberry but it is unlocked and I'm using it with the at&t service books on my unlimited data plan.

Last edited by davidhaner : 07-14-2009 at 06:00 PM. Reason: Solved
Offline  
Old 07-14-2009, 06:00 PM   #2 (permalink)
New Member
 
Join Date: Jan 2009
Model: pearl
PIN: N/A
Carrier: att
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok, this is working now, I am now using the blackberry.net apn and I no longer get errors.

I had to remove the battery from the Storm for it to update the apn properly.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.