BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   Developer Forum (http://www.blackberryforums.com/developer-forum/)
-   -   browsercontentmanager problem (http://www.blackberryforums.com/developer-forum/197061-browsercontentmanager-problem.html)

davidhaner 07-14-2009 07:43 PM

browsercontentmanager problem
 
I'm using a Verizon Storm, and I have downloaded the appropriate simulator.

Everything works like a dream on the simulator; I use ksoap to connect up and download the content to be stored locally, and then invoke my own httpconnectionwrapper to pass the local content to the browsercontentmanager and the html renders fine.

However, on the device it does not render; it steps through the same code and looks to me like it should render but nothing happens.

I'm using an unlocked Storm, could this have something to do with it? When stepping through the code in the thread that sets the browsercontent manager's content I see it try to set the content, throw no errors but afterwards when doing a watch on the browsercontentmanager's browsercontent it is always null.

try {
synchronized (Application.getEventLock())
{
fs._browserContentManager.setContent(connection, this, e);
System.out.println("The content of the web page has been set.");
}

} catch(Exception ex) {
System.out.println("problem setting the content of the web page!");
} finally {
SecondaryResourceFetchThread.doneAddingImages();
}

No errors are thrown. I can see the html in the buffer of the connection, for some reason it is not getting set.

Anyone have any ideas? Is this because it's an unlocked phone?

davidhaner 07-15-2009 06:08 PM

anyone have any ideas? I switched to Verizon so the phone will be using the service books built for the OS it has on it, still the same problem, and it still works on the simulator.

davidhaner 07-15-2009 09:34 PM

ok, i've wiped the blackberry completely clean, restored to a vanilla verizon storm 4.7.0.148 os, and still when i set the browsercontent it is null

basically as far as i can tell browsercontentmanager is not working on blackberry storm, even though it works in the simulators perfectly.

Anyone at RIM have any ideas?

davidhaner 07-16-2009 07:40 PM

I purchased a blackberry curve, and it is having exactly the same problem, and yet again it works in the simulator.

I'm very frustrated; I can switch to using just a browserfield and load up the content locally there but I will be restricted to not displaying images.

Hasn't someone else had this problem?

davidhaner 07-20-2009 03:14 PM

Anyone at RIM care to chime in? I'm still stuck and becoming very worried.

davidhaner 07-28-2009 07:26 PM

I have also tried with a browserfield now, and it still works on the simulator and not on the device. I am convinced at this point that you just cannot host a browser control (browserfield or browsercontentmanager) and display local content and have it work on the device.

I would gladly pay if someone has made this work recently. It worked on my older pearl.


All times are GMT -5. The time now is 02:16 PM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.