BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 07-22-2009, 03:38 PM   #1 (permalink)
New Member
 
Join Date: Jul 2009
Model: 8330
PIN: N/A
Carrier: verizon
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default socket help!!

Please Login to Remove!

ok, so I've been beating my head against this problem for a long time now and cant seem to make heads or tails of it.
I cant seem to get the socket to recieve data without first sending data. I cant figure out why.

example:
ssh server sends info first, not client
so after the connection is made, the client is waiting on data that never arrives.
if I were to inject a byte or two, say "\r\n", the response immediately comes back. however this is not what te ssh server is expecting and therefore aborts

this is just an example as the application in question is a proxy and many many different protocols will be routed through it. HTTP seems to work ok seeing as how the client sends a request immediately upon connecting.

if anyone has any knowledge on this matter please help me out, this is driving me insane (have i mentioned that I HATE java and would love to be using a real programming language here?)
Offline  
Old 07-24-2009, 02:55 PM   #2 (permalink)
New Member
 
Join Date: Jul 2009
Model: 8330
PIN: N/A
Carrier: verizon
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

bump....
really? has no one run into this issue?
Offline  
Old 07-28-2009, 11:58 PM   #3 (permalink)
New Member
 
Join Date: Jul 2009
Model: 8330
PIN: N/A
Carrier: verizon
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

has anyone on here even used tcp/ip sockets on the blackberry?
I could really use some help on this. I'm a low level C coder trying to write a J2ME counterpart for a pipe style proxy system. any help will be greatly appreciated
I'm just not used to code not doin what i'm telling it to (don't use java much teehee)
Offline  
Old 07-29-2009, 11:04 AM   #4 (permalink)
BlackBerry Extraordinaire
 
Join Date: Jan 2006
Model: LEZ10
OS: 10.0.10
Carrier: Rogers CA
Posts: 1,704
Post Thanks: 20
Thanked 77 Times in 68 Posts
Default

I use them all the time, even used the SSL sockets to connect to servers written in C. Never had a problem like you describe so I can't help with the information you've provided so far.
__________________
My other Blackberry is a PlayBook.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.