BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 11-14-2009, 05:38 AM   #1 (permalink)
New Member
 
jamjoen's Avatar
 
Join Date: Apr 2005
Location: Edinburgh
Model: 7290
Carrier: 02
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Install MDS Simulator - Startup fails

Please Login to Remove!

Hi:
I have installed the latest JDK to:
C:\Program Files\Java\jdk1.6.0_17

I have set my JAVA_HOME variable to this and updated the path variable, see below:
PATH=C:\Program Files\Java\jdk1.6.0_14\bin;C:\Program Files\JavaFX\javafx-sdk1.2\bin;C:\Program Files\JavaFX\javafx-sdk1.2\emulator\bin;C:\Windows\system32;C:\Windows ;C:\Windows\System32\Wbem;C:\Program Files\Common Files\Ulead Systems\MPEG;C:\Program Files\Common Files\DivX Shared\;C:\Program Files\QuickTime\QTSystem\

Finally, I installed the MDS Simulator 4.1.2 but on running I receive the following error:
Exception in thread "main" java.lang.NoClassDefFoundError: net/rim/application/i
pproxyservice/IPProxyServiceApplication
Caused by: java.lang.ClassNotFoundException: net.rim.application.ipproxyservice.
IPProxyServiceApplication
at java.net.URLClassLoader$1.run(URLClassLoader.java: 200)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.j ava:188)
at java.lang.ClassLoader.loadClass(ClassLoader.java:3 03)
at sun.misc.Launcher$AppClassLoader.loadClass(Launche r.java:301)
at java.lang.ClassLoader.loadClass(ClassLoader.java:2 48)
at java.lang.ClassLoader.loadClassInternal(ClassLoade r.java:316)
Could not find the main class: net.rim.application.ipproxyservice.IPProxyService
Application. Program will exit.

I have browsed the forum and different posts suggest I have not the relevant JDK or my environmental variables for the classpath are incorrect. However I have checked and double checked while also trying a reinstall of both JDK and the MDS Simulator to no avail.

Appreciate any guidance or anything that I may have missed being a newbie to BB development.

Thks
__________________
========================
brandyG
BES 4.0 Domino 6.5
Offline  
Old 11-14-2009, 09:20 AM   #2 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2008
Location: Austin, TX
Model: 9700
PIN: N/A
Carrier: T-Mobile
Posts: 1,644
Post Thanks: 0
Thanked 34 Times in 33 Posts
Default

Why 4.1.2?? In Blackberry terms, this version dates back to the Jurassic period.

The current version is 4.1.5.26

I seriously doubt if 4.1.2 will even run under JRE 1.6 - it was designed for JRE 1.4 (but IO beleive it will also work OK with 1.5).
Offline  
Old 11-16-2009, 03:28 AM   #3 (permalink)
New Member
 
jamjoen's Avatar
 
Join Date: Apr 2005
Location: Edinburgh
Model: 7290
Carrier: 02
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default 4.1.4

Checked blackberry.com again and from their simulators drop down they have the MDS simulator 4.1.2 hence I downloaded this version.

Dug around some more and found 4.1.4 on their site but can't find any 4.1.5.
Would you have a link?

Installed 4.1.4 and still the same error message.
Appreciate any guidance.
__________________
========================
brandyG
BES 4.0 Domino 6.5
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.