BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 11-27-2009, 10:23 AM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2009
Model: 8300
PIN: N/A
Carrier: Rogers
Posts: 43
Post Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy WTF have I done?? No longer able to copy to device :(

Please Login to Remove!

Hey all,

3 months ago I made an app for my blackberry. I have a Blackberry 8310 (with OS version 4.2.2.163). I purchased the signing key thing so I can copy the apps to my phone. All worked great.

Today i tried to make an update to the app. I noticed I had 2 versions of the JDE installed (4.7.0.41 and 4.0.2.188). From what I have read I cannot use a JDE with a greater version than my phone is using. However, after looking at the older JDE, I swear I didn't use that. It doesn't look at all like the JDE I was using before... and the newer JDE is what I remember using.

The big problem is : I load my app in the older jde and when I try and "request signatures" it fails saying my password is incorrect.

I try "requesting signatures" with the newer JDE and it is successful. However, when i try and use the javaloader and load the app on my phone, it says "Error: file is not a valid Java code file" (which I believe is because the versions are incorrect).

I had this working 3 months ago. Nothing has chnaged as far as I know. What is going on? :(

Thanks for any advice you can give!!
Offline  
Old 11-27-2009, 02:05 PM   #2 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2008
Location: Austin, TX
Model: 9700
PIN: N/A
Carrier: T-Mobile
Posts: 1,644
Post Thanks: 0
Thanked 34 Times in 33 Posts
Default

I would download and install the 4.2.1 JDE, then copy the sigtool.* files from the /bin directory of the "working" JDE installation.

And you are correct, your 4.7-compiled code won't run on the 4.2 device.
Offline  




Copyright 2004-2016 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.